Configuration of flashplugin-installer succeeds even when download fails

Bug #409119 reported by Geir Ove Myhr on 2009-08-05
124
This bug affects 19 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Debian)
Fix Released
Unknown
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

After really wanting to see a web page that uses flash in Firefox I clicked the "Install Missing Plugins..." button and chose the Adobe flash player (because the others don't really work in practice, do they?). After entering my password to allow the system to install the package flashplugin-installer, it reported "Successfully applied all changes. You can close the window now." When revealing the details in the dialog, however, the picture is less clear:

wget: unable to resolve host address `archive.canonical.com'
download failed
The falsh plugin is NOT installed.

Of course only serious bug hunters click the the "Details" button... Most users would wonder why on earth flash isn't working when they were told that it installed successfully.

I'm aware that since Adobe only allows limited distribution of flash through 3rd parties, flashplugin-installer uses apt in a convoluted way to download the actual files only during package configuration. The problem here is that the configuration reports success even if it really fails.

There are a few similar bug reports, but they never ended up going anywhere so I figured I'd better file a new report with updated (and English) information. Similar bugs include bug 215191, bug 218597, bug 311746, and bug 334601.

This bug is filed in Jaunty, but currently the package version in Karmic is the same.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: flashplugin-installer 10.0.22.87ubuntu2
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: flashplugin-nonfree
Uname: Linux 2.6.28-13-generic i686

Geir Ove Myhr (gomyhr) wrote :
Geir Ove Myhr (gomyhr) wrote :

A picture of the dialogs shown. Never mind the multiple images in the background, it is just because the firefox window doesn't refresh while the package installation is going on.

Geir Ove Myhr (gomyhr) on 2009-08-05
description: updated
Geir Ove Myhr (gomyhr) wrote :
Geir Ove Myhr (gomyhr) wrote :

For the record, flash worked okay after a `sudo dpkg-reconfigure flashplugin-installer`. It was probably just a temporary wireless network failure. However, the actual problem is that when there is such a failure, the configuration reports success.

helix84 (helix84) wrote :

I was just going to report same bug. Only my download failed due to wrong setting of http_proxy environment variable.

Setting up flashplugin-installer (10.0.42.34ubuntu0.9.10.1) ...
Downloading...
Error parsing proxy URL wpad://: Unsupported scheme.
download failed
The Flash plugin is NOT installed.

> For the record, flash worked okay after a `sudo dpkg-reconfigure flashplugin-installer`.

Here, too.

> However, the actual problem is that when there is such a failure, the configuration reports success.

100% agreed. This happened during my upgrade to Karmic shortly after release. Only now I found out that Flash isn't working. Explicit error is better than a hidden one.

A solution would be to leave the package unconfigured.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
helix84 (helix84) wrote :

The line that causes this is
in postinst function fp_exit_with_error():
        exit 0 # still install the Debian package, undoes the fix for #387263

This is the upstream bugreport:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=387263

I fail to understand why the change was reverted.

Changed in flashplugin-nonfree (Debian):
status: Unknown → Fix Released
Daniel Stoni (stoni.ch) wrote :

Same here.

Download fails from the particular site used by both flashplugin-installer AND Firefox 3.5
***
Richte flashplugin-installer ein (10.0.42.34ubuntu0.9.10.1) ...
Downloading...
--2010-02-15 09:01:36-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.42.34.orig.tar.gz
Auflösen des Hostnamen »archive.canonical.com«.... 91.189.90.142
Verbindungsaufbau zu archive.canonical.com|91.189.90.142|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 404 Not Found
2010-02-15 09:01:36 FEHLER 404: Not Found.
***
YET, installation completes wich no warning and success state.

Rgds, Dani

JB (jb-ubuntu1804) wrote :

Same here ..

Not Found

The requested URL /pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.42.34.orig.tar.gz was not found on this server.
Apache/2.2.8 (Ubuntu) mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.8 OpenSSL/0.9.8g Server at archive.canonical.com Port 80

juan24085 (enma-joan) on 2010-04-29
Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → New
John Vivirito (gnomefreak) wrote :

Setting back to confirmed.
Please do not change status or importance or package source without commenting on what and why you changed it.
This being set to "new" is not accurate since this bug is not new and has been confirmed.

Can anyone use latest version in your Ubuntu releases' archives and let us know if this is still an issue

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed

I had a similar problem today in maverick with the latest flash plugin update:

Preparing to replace flashplugin-installer 10.2.152.27ubuntu0.10.10.1 (using .../flashplugin-installer_10.2.153.1ubuntu0.10.10.1_i386.deb) ...
Unpacking replacement flashplugin-installer ...
Setting up flashplugin-installer (10.2.153.1ubuntu0.10.10.1) ...
Downloading...
--2011-03-24 07:59:05-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.153.1.orig.tar.gz
Resolving false... failed: Name or service not known.
wget: unable to resolve host address `false'
download failed
The Flash plugin is NOT installed.

The download failed for some other reason, and at least the previous flash version with the security hole has been removed.
However the package is considered as installed by apt/dpkg and in order to have a working flash plugin again the user has to either:
 - purge and reinstall the package
 - run "dpkg-reconfigure flashplugin-installer"

vladf (vlad-chel) wrote :

Same promlem in 10.04 LTS after last update:
--------------------------------
Setting up flashplugin-installer (10.2.153.1ubuntu0.10.04.1) ...
Downloading...
--2011-03-25 23:45:15-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.153.1.orig.tar.gz
Resolving false... failed: Name or service not known.
wget: unable to resolve host address `false'
download failed
The Flash plugin is NOT installed.
--------------------------------

If I run wget manually for this URL it works fine:
----------------------------------------
vlad@vlad-desktop:~$ wget http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.153.1.orig.tar.gz
--2011-03-25 23:52:54-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.153.1.orig.tar.gz
Resolving archive.canonical.com... 91.189.88.33
Connecting to archive.canonical.com|91.189.88.33|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4967805 (4.7M) [application/x-gzip]
Saving to: `adobe-flashplugin_10.2.153.1.orig.tar.gz'

100%[===================================================================================================================>] 4,967,805 1.15M/s in 4.6s

2011-03-25 23:52:59 (1.02 MB/s) - `adobe-flashplugin_10.2.153.1.orig.tar.gz' saved [4967805/4967805]
-----------------------------------

So I have run "sudo dpkg-reconfigure flashplugin-installer" and have installed manually.

Jos Dehaes (jos-dehaes) wrote :

I've had to do the same as vladf. On my laptop the flashplugin-installer worked fine, on the desktop it didn't (both up to date natty). Strange, as the network settings are exactly the same, and go over the same router. Manually downloaded via wget.

vladf (vlad-chel) wrote :

Same problem with new update of 10.04 LTS:
-------------------------
--2011-04-19 21:49:15-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.159.1.orig.tar.gz
Resolving false... failed: Name or service not known.
wget: unable to resolve host address `false'
-------------------------

This error is caused by wget using a proxy (named "false"?), even if you didn't want or choose to use one. As a temporary fix it is possible to uncomment "use_proxy = off" in /etc/wgetrc, or add "--no-proxy" to the wget command in the package's postinst script.

My problem with the proxy named "false" was caused by an old proxy setting in /etc/apt/apt.conf dating back to Ubuntu dapper. Removing this proxy setting cured the problem.

But the problem with the flashplugin-installer package remains in case of a network failure.

Jamie Lokier (jamie-shareable) wrote :

I've hit this bug when upgrading Maverick to Natty, and
I've also had it happen a year or two ago during a previous upgrade.

The older one:

 - For some reason after downloading everything in a full GUI-led upgrade, some other package
    caused the wireless network to turn off and flashplugin then quietly failed to install properly
    but marked itself as done. It was a proper Ubuntu upgrade, so it's only by chance that I
    happened to look at the "details" window as it failed and knew what to do.

 - Maverick to Natty failure. Again a full upgrade (this time I used do-release-upgrade from the
   command line though.) flashplugin again failed, this time with the same errors as comment
   #10 - it's trying to resolve "false".

   Because it shows the full URL, and finished with a permission error rather than an DNS failure
   (unfortunately my ISP has a wildcard DNS for all failed matches), I wrongly thought it was
   a Canonical server being temporarily broken, and would be well known and fixed in due course.

   But no, and looking now, I see it's an old proxy setting in /etc/apt.conf.

   Here's the thing: That setting is exactly what the original CD-ROM installer had put there.
   I've never changed it. It says:

      APT::Authentication::TrustCDROM "true";
      Acquire::http::Proxy "false";

   That's been there since my first Ubuntu (probably Dapper) from CD-ROM, and not many
   packages use that setting. It's been there for so long, why did previous flashplugin
   installers work fine? Has the meaning of Acquire::http::Proxy changed, and flashplugin
   (perhaps foolishly) decided to depend on the new meaning ,without apt's own upgrade script
   deleting redundant old settings?

Anyway, the main point of *this* bug is it silently leaves "flashplugin-installer" installed and configured but Flash not working. And sometimes, even reinstalling/reconfiguring the package doesn't fix an Ubuntu that's been
through quite a few upgrades before getting to Natty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.