flashplugin-installer package fails to handle temporarily unavailable network

Bug #369025 reported by fbusse on 2009-04-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-installer

in upgrading from kubuntu 8.04 to 9.04 using adept, my network was temporarily unavailable during package update for flashplugin-installer.

after reestablishing the network, the update process remained at something like
"150 ..... ....." for about 10 minutes. when i tried to copy the contents from the update window with ctrl-c for a request in a forum, the contents of the update window changed to

"dpkg: Error in processing of flashplugin-installer (--configure):
 Subprocess post-installation script killed with Signal (Interrupt)
dpkg: Problems concerning dependencies inhibit configuratin of flashplugin-nonfree:
 flashplugin-nonfree depends on flashplugin-installer; but:
  Package flashplugin-installer is not configured yet.
dpkg: Error in processing of flashplugin-nonfree (--configure):
 Problems concerning dependencies - leaving it unconfigured"
(manual translation from german language system)

after acknowledging a related error message window, the upgrade continued with the next package. would have expected the package to continue after reestablishing the network, instead.

fbusse (frank-busse) on 2009-04-30
description: updated
Alexander Sack (asac) wrote :

yes, its an issue. not sure what the right solution would be. we cannot just not fail as this wont trigger a new download next upgrade.

Also waiting for network isnt possible either because that might never happen.

Anyway, the reason why networks frequently got disconnected during upgrade is now worked around in update manager. so this should happen less frequently.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Triaged
momeara (mattjomeara) wrote :

I would like to add that this also happened to me.

Thanks,

-m

Greg A (etulfetulf) wrote :

Similar is Bug #661979

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers