nspluginviewer comsumes allmoust all CPU

Bug #240930 reported by dumas33 on 2008-06-18
194
This bug affects 26 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
kdebase (Debian)
Fix Released
Unknown
nspluginwrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Its not a crash, but if I use konqueror or firefox for viewing any flash nspluginviewer consumes 100% of CPU, Its really annoying e.g. I opened 3 or 4 interestig articles for www.gizmodo.com (or whatever) with flash in it. Browser start to freeze. As far as I remember in Kubuntu 7.10 it was not problem.

I use Kubuntu 8.04.

dumas33 (danas-augutis) wrote :

Maybe its adobe flash problem, but I we all now that I lot website us it for advertisements. 100% of CPU for a few advertisements is to much I think.

Greg A (etulfetulf) wrote :

Is with KDE 3.5 (Ubuntu 7.10 and 8.04 default) or with KDE 4?

dumas33 (danas-augutis) wrote :

The problem is in KDE 3.5.9

Greg A (etulfetulf) wrote :

Marking as a bug in the konqueror-nsplugins package so the relevant people see this bug.

Harald Sitter (apachelogger) wrote :

The report says "konqueror or firefox" that makes it fairly unrelated to kdebase, moving over to flashplugin-nonfree.

Dave Gilbert (ubuntu-treblig) wrote :

Lots of dupes - marking as meta

Changed in flashplugin-nonfree:
status: New → Confirmed
Changed in kdebase:
status: Unknown → Confirmed
fedenunez (fedenunez) wrote :

This still happening on Jaunty with KDE Version 4.2.2.

FMaz (fmaz008) wrote :

No matter if it's KDE or Gnome. I'm using gnome and firefox here. Watching a video on youtube make one of my CPU core to raise upto 100% of CPU usage.

if I'm starting many video, I'm able to make the browser unresponsive. "But why are you looking at more than 1 flash movie at once ?" ... well, many menu, video, publicity are using flash, so it's easy to have many flash animations loaded in a couple of tabs at once.

Ken Hagan (k-a-hagan) wrote :

I posted bug 238394, currently marked as one of 6 duplicates of this bug, but I have to say that (for me) the problem disappeared when I upgraded from 7.10 to 8.04, which isn't the experience here. I say "upgrade", I think I did upgrade originally, but I have since had to restore my system to a new hard disk, which I did by installing a clean 8.04 and restoring large parts of the file-system from backup, so I'm probably not a good reference point. Nevertheless, I'm not convinced these seven reports are all true duplicates.

Whilst I'm here, those affected by this bug might want to try Flash 10. It's available as a clean 64-bit plug-in and presumably has fewer hoops (bugs?) to jump through to actually put pixels on the screen. (It certainly gives me no problems.)

Also, since the unavoidability of Flash comes largely from its use in adverts, there's the option of blocking flash in most pages and only enabling it for sites where you actually wanted to watch the video. Won't help with YouTube, but certainly would for the average site, where flash videos are *only* used in annoying adverts!

when will the native 64-bit flash plugin be installed by default?
I've been using it with no problems for over a year with intel
integrated graphics.

On Mon, Oct 12, 2009 at 5:07 AM, Ken Hagan <email address hidden> wrote:
> I posted bug 238394, currently marked as one of 6 duplicates of this
> bug, but I have to say that (for me) the problem disappeared when I
> upgraded from 7.10 to 8.04, which isn't the experience here. I say
> "upgrade", I think I did upgrade originally, but I have since had to
> restore my system to a new hard disk, which I did by installing a clean
> 8.04 and restoring large parts of the file-system from backup, so I'm
> probably not a good reference point. Nevertheless, I'm not convinced
> these seven reports are all true duplicates.
>
> Whilst I'm here, those affected by this bug might want to try Flash 10.
> It's available as a clean 64-bit plug-in and presumably has fewer hoops
> (bugs?) to jump through to actually put pixels on the screen. (It
> certainly gives me no problems.)
>
> Also, since the unavoidability of Flash comes largely from its use in
> adverts, there's the option of blocking flash in most pages and only
> enabling it for sites where you actually wanted to watch the video.
> Won't help with YouTube, but certainly would for the average site, where
> flash videos are *only* used in annoying adverts!
>
> --
> nspluginviewer comsumes allmoust all CPU
> https://bugs.launchpad.net/bugs/240930
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

h3 (h3) wrote :

This problem was present for me in Ubuntu 9.04 and is still present in Ubuntu 9.10

In fact, the only unstable part of my OS for the past 2 years has been this proprietary POS (Flash).

God I hate Flash.

Chris Samuel (chris-csamuel) wrote :

This is likely related to KDE bug #182869 which itself implies it to be a Qt issue fixable by setting the environment variable QT_NO_GLIB to 1.

KDE bug is here: https://bugs.kde.org/show_bug.cgi?id=182869

Jeremy Nickurak (nickurak) wrote :

I also get this behavior with epiphany and nspluginviewer. Makes the browser totally unresponsive.

vista killer (vistakiller) wrote :

I have the same problem with kubuntu 9.10 kde 4.3.5 and with kde 4.4.1.

vista killer (vistakiller) wrote :

The problem still exist in kubuntu 10.04 with all the last updates

Jeremy Nickurak (nickurak) wrote :

What happens in this scenario when it's the flash plugin without nspluginviewer? Does flash simply crash? In which case, shouldn't nspluginviewer stop the crash from reaching the web browser? Is it possible that nspluginviewer could catch the frozen/crashed flash plugin, and stop running, preserving the browser from the effects of the crash/freeze?

Jeremy Nickurak (nickurak) wrote :

Sorry, nspluginwrapper, that is.

Jeremy Nickurak (nickurak) wrote :

To be clear, this is occuring for me with gnome, not KDE. Is that a different bug?

This is basically a stock ubuntu system but running epiphany with flashplugin-nonfree, and it frequently makes the browser unusable without opening a terminal to kill the nsplugin process every 10-15 minutes...

oli z (oliver-z) wrote :

same problem here, in window mode i can watch flash movies
but when i try the fullscreen mode something kills my system and i have to kill the process in a terminal (npviewer.bin)
please dont say anything like "old hardware" ...
its a i5 750 mit 4gb ram and a sapphire 5750 vapor-x
in ubuntu 9.10 i was able to watch (with some lags) flash movies in fullscreen
in 10.04 its impossible, i even cant stop the player with ESC

Miroslav Hadzhiev (xtigyro) wrote :

Just watching the first free practice of Formula 1 in Monaco (http://atdhe.net/19218/watch-formula-1-monaco-grand-prix-practice) and "noticed" that the computer is almost freezed by nspluginwrapper and Adobe Flash.

Ubuntu Lucid in use.

My computer has Intel Core 2 Duo T7200 (2 x 2 GHz), 3 GB 1066 MHz RAM, ATI Mobility X1600 GDDR3 256 MB.

Jeremy Nickurak (nickurak) wrote :

What's the behavior of this problem on a 32-bit system? Does flash consume overly high cpu usage by itself? Does it (and the browser) crash?

My guess is that npviewer.bin is getting into a crazy 100% cpu loop after the flash plugin crashes (there are lots of reports of that). In which case, nspluginwrapper should be responding better to this situation, likely by simply shutting down.

Is there a good way to get debugging information from nspluginwrapper, so we can get some idea what it's doing?

Leo (leorolla) wrote :

I notice this problem on Karmic 64-bit install. Firefox totally freezes sometimes.

Changed in nspluginwrapper (Ubuntu):
status: New → Confirmed
linuxar (linuxar) wrote :

The same happens to me while viewing internet videos in Chromium on Natty x64:
Linux <machine> 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

npviewer.bin hogs my dual core.

Irenux (irenux) wrote :

Same here, Kubuntu Oneiric x64, 3.0.0-15-generic. Uninstalling and using adobe-flashplugin instead seems to solve it for now. I'm not really sure whether flash will keep working properly in the browsers I use, mainly Chromium and Firefox.

Changed in kdebase (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.