Ubuntu

flashplugin-nonfree should include libflashsupport as a dependency

Reported by Craig on 2008-01-18
50
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

pulseaudio is to be included in Hardy, so flashplugin-nonfree should depend on libflashsupport - otherwise, the flash plugin is more or less useless as it's audio output won't work.

description: updated
Changed in flashplugin-nonfree:
importance: Undecided → Medium
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flashplugin-nonfree - 9.0.115.0ubuntu4

---------------
flashplugin-nonfree (9.0.115.0ubuntu4) hardy; urgency=low

  * Depend on libflashsupport, since hardy uses pulseaudio by
    default. (LP: #183943)

 -- Timo Aaltonen <email address hidden> Fri, 18 Jan 2008 11:04:01 +0200

Changed in flashplugin-nonfree:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

reopening because we see crashes because of this. Craig i couldn't find anyone for who the latest flash doesn't work without libflashsupport with pulse. can you please verify that moving /usr/lib/libflashsupport.so doesn't hurt you anymore?

Changed in flashplugin-nonfree:
status: Fix Released → Incomplete
Craig (candrews-integralblue) wrote :

Removing /usr/lib/libflashsupport.so seems to have no impact. I can play Flash sound and other sound simultaneously - not sure what was done to allow this, but libflashsupport doesn't seem to be needed anymore.

Craig (candrews-integralblue) wrote :

so is this dependency going to be removed?

Rob Adams (readams) wrote :

I need to install libflashsupport in order to get flash pulseaudio sound to work. This is presumably because I have my sound going to a remote pulseaudio server. On my computer I get annoying interference on the audio whenever stuff is moved on the screen, so my workaround is to plug my headphones into a different computer and send all my sound through pulse to the remote sound server. Everything works easily like this except for flash. Installing libflashsupport means the sound works, but my firefox will crash regularly as a consequence.

John Vivirito (gnomefreak) wrote :

Rob what version os flashplugin-nonfree from ubuntu repos are you using? The latest flash package doesnt need to use libflashsupport anymore, Can you please verify that moving /usr/lib/libflashsupport.so doesn't hurt you anymore? Also what version of Firefox, Ubuntu are you using?

Rui Castro (rui.castro) wrote :

Hi,

I have just installed Hardy and flashplugin-nonfree and i had no sound in flash movies.
I've found out this bug https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/196470 that libflashsupport is a dependency to be able to have sound in flashusing pulseaudio.
I definitely support that libflashsupport should be a depency. Without sound, flash is pretty useless.

John Vivirito (gnomefreak) wrote :

Rui what arch are you using and what version of flash are you using? Is the flash package from our archives?

Jeremy Nickurak (nickurak) wrote :

Bug #192888 ( https://bugs.launchpad.net/bugs/192888 ) covers the problems that libflashsupport causes right now, in particular frequent firefox crashes. That's why the dependency was removed.

Mario Vukelic (mario-vukelic) wrote :

I can confirm this, too. I use up-to-date Hardy, which was upgraded from Gutsy before the alphas. Consequently, all my pulseaudio settings had to be done manually, but I thought I had it gotten it right. Anyway, everything else works. I have gstreamer and all other sound-using apps set up for pulseaudio, I have the "start esd" box checked in the Gnome sound preferences, and the user is in the pulse* groups.

With libflashsupport I have flash sound but also seem to crash easily on youtube, without it I have no flash sound but it seems stable.

Mario Vukelic (mario-vukelic) wrote :

Gah, I forgot, this is on i386.

apt-cache policy flashplugin-nonfree
flashplugin-nonfree:
  Installed: 9.0.124.0ubuntu2
  Candidate: 9.0.124.0ubuntu2
  Version table:
 *** 9.0.124.0ubuntu2 0
        500 http://de.archive.ubuntu.com hardy/multiverse Packages
        100 /var/lib/dpkg/status

John Vivirito (gnomefreak) wrote :

They fixed the need for libflashsupport due to crashes with it. Without libflashsupport you wont crash as much and the crashes are unrelated to libflashsupport if its gone. Now PulseAudio and flash you will lose sound the PulseAudio guys are working on this per bug #192888 so ntil this is fixed we are leaving libflashsupport out due to the crashes. Crashes are a higher priority as aposed to sound in flash.

Rob Adams (readams) wrote :

Sorry I wasn't on the CC list for this bug. Here are the software versions I have installed:

$ dpkg -l libflashsupport flashplugin-nonfree firefox
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii firefox 3.0~b5+nobinon meta package for the popular mozilla web bro
ii flashplugin-no 9.0.124.0ubunt Adobe Flash Player plugin installer
ii libflashsuppor 1.9-0ubuntu1 Support library for sound output of Flash 9

If I remove libflashsupport then restart firefox, I get NO SOUND in flash. Reinstalling it gives me sound again.

I have a remote sound server selected using padevchooser (I should note that the volume control applet doesn't like this much either, as in order for this to work I need to select the sound server then remove and re-add the volume control applet to the panel, then select the pulse device manually on each login)

Here's my asound.conf:
$ cat /etc/asound.conf
pcm.pulse {
            type pulse
}

ctl.pulse {
            type pulse
}

pcm.!default {
            type pulse
}
ctl.!default {
            type pulse
}

joehill (joseph-hill) wrote :

As an ltsp user, I agree that it would be ideal to include this as a dependency. I spent quite a bit of time trying to get YouTube to work over ltsp before realizing that simply installing this package fixed the problem. I understand that the Adobe plugin is extremely buggy and crashy though.

joehill wrote:
> As an ltsp user, I agree that it would be ideal to include this as a
> dependency. I spent quite a bit of time trying to get YouTube to work
> over ltsp before realizing that simply installing this package fixed the
> problem. I understand that the Adobe plugin is extremely buggy and
> crashy though.
>
>
We had made this a dep and than once new flash came out we had to remove
it due to causing alot of crashes. I would say a suggestion or a
recommends but not as default for all the users that caused their
systems to crash and caused PA to not work. since PA is default having
libflashsupport.so will only cause issues

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Daniel T Chen (crimsun) wrote :

Now that Flash 10 beta is available, we can address this issue (see also bug 192888).

Rob Adams (readams) wrote :

I can confirm that installing flash 10 removes the need for libflashsupport, works with all the crazy features of pulseaudio that I'm using, and doesn't crash constantly. A win/win I'd say.

Though there seem to be some web sites with incredibly stupid flash version detection scripts that don't see flash 10 as flash. I imagine that will get fixed in not too long though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flashplugin-nonfree - 10.0.1.218ubuntu1

---------------
flashplugin-nonfree (10.0.1.218ubuntu1) intrepid; urgency=low

  * New upstream beta fixes many crashers (most significantly
    LP: #192888).
  * debian/config:
    debian/postinst: Update md5sums, filenames, and paths. Remove
    debugging bits (LP: #176226).
  * debian/control: Readd versioned dependency for libflashsupport|
    libasound2-plugins to play nicely with either PulseAudio config
    while preserving OSSv4 users' ability to have audible "shiny"
    (LP: #206307, #186726, #183943, #151849).

 -- Daniel T Chen <email address hidden> Tue, 20 May 2008 16:34:40 -0400

Changed in flashplugin-nonfree:
status: Incomplete → Fix Released
Michael Rooney (mrooney) wrote :

What are the requirements for updating this in Hardy as well (point release?), or backporting? It would be great to be able to use Flash 10 in Hardy with official support (and via a package, and not manually copying an .so file). Thanks for any input!

Look for the package here when it shows up:

http://us.archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/

Then just download it and double click it.

On Tue, 2008-05-20 at 22:40 +0000, Mike Rooney wrote:
> What are the requirements for updating this in Hardy as well (point
> release?), or backporting? It would be great to be able to use Flash 10
> in Hardy with official support (and via a package, and not manually
> copying an .so file). Thanks for any input!
>

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rob Adams wrote:
| Look for the package here when it shows up:
|
| http://us.archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-
| nonfree/
|
| Then just download it and double click it.
|
|
| On Tue, 2008-05-20 at 22:40 +0000, Mike Rooney wrote:
|> What are the requirements for updating this in Hardy as well (point
|> release?), or backporting? It would be great to be able to use Flash 10
|> in Hardy with official support (and via a package, and not manually
|> copying an .so file). Thanks for any input!
|>
|
Instead of downloading it why not just install it with atp or adept or
synaptic since its in repos. This package should end up in security
repos but so far as far as i can tell its only been uploaded to Intrepid
at the moment but i wont know until im done with emails.

- --
Sincerely Yours,
~ John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFINPmdqig4QTwcPCoRAhJNAJ9yXR03ANSUjNIh1avFezi57a2x/ACfSIEH
Xh6oCv3x33olFD/TIaJ2ks4=
=dYbB
-----END PGP SIGNATURE-----

Rob Adams (readams) wrote :

By the way why is libflashsupport needed in flash 10? It works without libflashsupport natively with pulseaudio. At least it does in the version I downloaded from the adobe site.

Bart Verwilst (verwilst) wrote :

I just manually installed Flash 10.0.0.569 from the adobe site ( http://labs.adobe.com/downloads/flashplayer10.html ) and i have no sound without libflashsupport. Installing libflashsupport gives me sound in both banshee and firefox/flash at the same time..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers