Ubuntu

Firestarter fails to open system log

Reported by Keith Taylor on 2011-05-03
112
This bug affects 28 people
Affects Status Importance Assigned to Milestone
firestarter (Ubuntu)
Undecided
Unassigned

Bug Description

Installed Firestarter 1.0.3 under 11.04. Firestarter reports error on startup:

 Failed to open the system log
 No event information will be available.

As predicted by the message, there is no event logging. Why can't it access the logs? Also, Log File Viewer reports errors attempting to open almost every log file. Both are being run as root, so why the problem? Any help will be greatly appreciated. Thanks!

tags: added: firestarter log messages rsyslog
max (maxilianus) wrote :

I can confirm that, after upgrade to Ubuntu 11.04, Firestarter stops to display any events information. Nothing appears in /var/log/messages anymore and the last thing recorded in /var/log/messages.1, apparently during the process of upgrade to 11.04 (for days ago), is "Kernel logging (proc) stopped."

I thought my post on launchpad would be referenced by this bug report but I guess not.

When installing (or upgrading) to 11.04 syslogd is upgraded to rsyslog. This uses the file /etc/rsyslog.conf which references the file configuration /etc/rsyslog.d/50-default.conf.

You can edit this file and change the lines commented out that create the relevant logfile

#*.=info;*.=notice;*.=warn;\
# auth,authpriv.none;\
# cron,daemon.none;\
# mail,news.none -/var/log/messages

to

*.=info;*.=notice;*.=warn;\
        auth,authpriv.none;\
        cron,daemon.none;\
        mail,news.none -/var/log/messages

and then restart rsyslog or reboot

Note: As rsyslog is referencing the directory /etc/rsyslog.d/ you could just put a new file in that location that would be included in the configuration so as not to fall foul of an ubuntu upgrade at a later date. The choice is yours.

max (maxilianus) wrote :

Yeah, that appears to have solved the problem. And Firestarter flashes red at hits again and shows the events as before. Thank you...:)

IKT (ikt) on 2011-05-06
affects: ubuntu → firestarter (Ubuntu)
Changed in firestarter (Ubuntu):
status: New → Fix Committed
Changed in firestarter (Ubuntu):
status: Fix Committed → Confirmed

For me, problem solved also. Great, thanks! Telmo

redtux (redtux2000) wrote :

Also working here, thx! Please, include the proposed fix in the next release.

Changed in firestarter (Ubuntu):
status: Confirmed → Fix Committed
rush_696 (freshmenta3) on 2011-05-23
Changed in firestarter (Ubuntu):
status: Fix Committed → Confirmed
Rezes (mzperx7) wrote :

That appears to have solved the problem me too! Thanks!

Mike Jelfs (mike-jelfs) wrote :

Thanks that fix worked for me also, don't quite understand the

Note: As rsyslog is referencing the directory /etc/rsyslog.d/ you could just put a new file in that location that would be included in the configuration so as not to fall foul of an ubuntu upgrade at a later date. The choice is yours.

What file do I place in this directory?

Mike,

if you cut/paste the following into a terminal (as root)

/usr/bin/printf '*.=info;*.=notice;*.=warn;\\\n\tauth,authpriv.none;\\\n\tcron,daemon.none;\\\n\tmail,news.none -/var/log/messages\n' > /etc/rsyslog.d/99-fixlog.conf

this will create a file that will fix the bug in the /etc/rsyslog.d/ directory.

Mike Jelfs (mike-jelfs) wrote :

Thanks Keith,

Instead of using the printf statement (got trouble copying carriage return chars from your example I simply created a file with the lines

*.=info;*.=notice;*.=warn;\
        auth,authpriv.none;\
        cron,daemon.none;\
        mail,news.none -/var/log/messages

using

sudo gedit /etc/rsyslog.d/99-fixlog.conf

Thanks for all your help.

Kind Regards

Mike

jgratero (jgratero) wrote :

I followed adviced post by Keith Taylor (post #2) and indeed, the error message dissapeared. But as a result, I can't see any events happening in the event tab (which is greyed out)

What happened here?

Do you have any rules in your iptables, try typing

sudo /sbin/iptables -L -n

Are there logging (LOG) rules displayed?

ls -l /var/log/messages

Does the file exist?
Is the timestamp recent?

If not then try a reboot and when your system returns, check the timestamp on the file and is it after your reboot, if it isn't then the change isn't active for some reason.

jgratero (jgratero) wrote :

This is the output of those commands:

http://paste.ubuntu.com/618537/

As line #2 shows, the timestamp is not recent (is in fact, from yesterday)...

What would be the reason for this?

After a reboot is the file/time updated?

jgratero (jgratero) wrote :

Nope, timestamp doesn't change (it's the same)

Pete.Goswell (pete-goswell) wrote :

Went through the sudo process, and got the full window, I'm on DSL, but in this area its slow, I wasn't expecting the number of complex little windows, most of the last few, about outgoing and incoming I ignored and went to the final button but it never progressed past that point. Also I didn't see intially any thing that went past "lUCID" AND i'M ON THE Natty NARWHAL HERE.

Me too.
I have the same problem.
Am about to try this fix.
Ubuntu 11.04 seems full of these little quirks. Wish I still had Ubuntu 10.10.
Am running ubuntu clasic (gnome) rather than unity.
COMPIZ still does not work.
I am trying to control my PC (Ubuntu 11.04) from my laptop (Ubuntu 10.10).
This might fix it.
Another problem is using FTP inside nautilus.
Typically starting nautilus as nautilus /home/myname.
Then control L. Then control A. Then control X. (to wipe the /home/myname)
Then ftp://ftp.mywebsite.com.
But it tries to access /home/myname/ftp://ftp.mywebsite.com.
Also a few quirks with USB on virtualbox.
Also GRUB2 v 1.99 still tries to access a USB hard drive even if it has been removed.
sudo update-grub before shutdown and after removing USB ensures PC will start up again.
etc.

odror (ozdror) wrote :

I have the same problem in the new UBUNTU 11.10.

I tried the fix. it did not work. Do I need to reboot for the fix to work?

Thanks

Me too.
I have the same problem in the new Ubuntu 11.10.

Is this the case that the repair is not valid with Ubuntu 11.10? Do I need to make repair in some other way?
Or have I got missed something important?

Yannick Mouëzy (ymouezy) wrote :

Hi

I have the same problem in Ubuntu 11.10.
The fix have resolved this problem.

Thanks a lot.

Doug (douglasblackusa-b) wrote :

I can not change the file as I do not have permission to write to the folder

OK, I hate to be a troll in this, but if you do not really understand unix/linux ownerships/permissions and how to elevate your status to enable to you edit the files in question then you should not really edit the files.

If you really insist on doing this however, then I suggest you look at the sudo command.

Tim Jensen (timj-tech) wrote :

Same story for 12.04 LTS. The fix works (uncomment lines in rsyslog.d/50-default.conf), but I'm wondering why this isn't being fixed. The bug was reported last year, and it's included in the latest release. At least a warning to edit the default log config would be nice.

Young (y478ga) wrote :

This fix is already in my system but has not fixed the bug. Any advice. I am a newbie and used Konquer to access command line.
Thanks.

ubun-tu-much (c-born) wrote :

Personally i realy start to HATE ubuntu VERY MUCH... i have (of course) the same bug in my ubuntu system and if i search with STARTPAGE.com i find this bug as UBUNTU ONLY...
the power and FREEDOM of LINUX is neglected and tied down in ubuntu systems....eg ubuntu does NOT let me COPY&PASTE their own error message which comes with this NEGLECTION...i have to manualy write the error down in the search machine, leading to possible type-errors by which i will not find an solution...BUT IT USED TO BE THAT AN ERROR MESSAGE WAS EASILY COPIED...with selecting the text by clicking on it , do a copy, select eg gedit and do a PASTE...

UBUNTU DOES NOT ALLOW SUCH A NEEDFULL COPY ANY MORE !!!!!!

UBUNTU IS MORE AND MORE RESTRICTIVE TO THEIR USERS

UBUNTU IS PUSHING COMMERCIAL PEEP IN YOUR COMPUTER WITH THEIR CORRUPT ¨¨ ubuntu one ¨¨¨ i am downloading DEBIAN to realy get rid of this freedom blocking microsoft copying load of b#ll sh!t.

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in firestarter (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers