Comment 14 for bug 95241

If you still wish to use firefox and bypass the error, you can:
1) To the following file /etc/issue add the next string(save a backup, we will restore it):
6.10
2) run as sudo the firefox install script from http://pykeylogger.sourceforge.net/installnewfirefox.sh
this script will install firefox 2.0.0.3 (http://www.psychocats.net/ubuntu/firefox)
3) restore the /etc/issue file

Worked for me.

Please note: by doing this you are damageding the ubuntu maintained firefox on your computer, so be advised about updating firefox related packages - use at your own risk.