[Lucid Beta2] nrf-003 testcase failed Default "Welcome to Ubuntu" page doesn't appear without connectivity

Bug #557640 reported by Sergio Zanchetta on 2010-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
ubufox (Ubuntu)
High
Chris Coulson
Lucid
High
Chris Coulson

Bug Description

Binary package hint: firefox

Case ID: nrf-003 failed

Default "Welcome to Ubuntu" page doesn't appear without connectivity.

Instead it tries to load
http://start.ubuntu.com/10.04//Amazon.com/
but an "Server not found" error message appear.

ProblemType: Bug
Architecture: i386
Date: Wed Apr 7 21:08:44 2010
DistroRelease: Ubuntu 10.04
FirefoxPackages:
 firefox 3.6+nobinonly-0ubuntu6
 firefox-gnome-support 3.6+nobinonly-0ubuntu6
 firefox-branding 3.6+nobinonly-0ubuntu6
 abroswer N/A
 abrowser-branding N/A
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100326)
Package: firefox 3.6+nobinonly-0ubuntu6
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: firefox
Uname: Linux 2.6.32-17-generic i686

Sergio Zanchetta (primes2h) wrote :
tags: added: iso-testing
Steve Langasek (vorlon) on 2010-04-08
Changed in firefox (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-10.04
Martin Pitt (pitti) on 2010-04-09
Changed in firefox (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in firefox (Ubuntu Lucid):
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

Ok, there are 2 issues here:

1) We've got network manager integration disabled in the preferences

2) The about:home handler is checking the browser.offline preference for determing if the network is present. This is not reliable though, as it is only updated when toggling the "Work Offline" check-box in the menu, and isn't updated to reflect the connection state indicated by network manager

Changed in ubufox (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: New → In Progress
Chris Coulson (chrisccoulson) wrote :
Changed in ubufox (Ubuntu Lucid):
status: In Progress → Fix Committed
Chris Coulson (chrisccoulson) wrote :

Firefox part fixed too:

bzr commit -m '* Fix LP: #557640 - nrf-003 testcase failed Default "Welcome to Ubuntu" page
  doesn't appear without connectivity - re-enable the NetworkManager
  integration
  - update debian/firefox.js' --fixes 'lp:557640'
Committing to: /home/chr1s/src/firefox/3.6/
modified debian/changelog
modified debian/firefox.js
Committed revision 571.

Changed in firefox (Ubuntu Lucid):
status: In Progress → Fix Committed
Chris Coulson (chrisccoulson) wrote :

ubufox (0.9~rc2-0ubuntu1) lucid; urgency=low

  New upstream release 0.9rc2:
  * fix online/offline detection by using nsIIOService rather than browser.offline pref
    - thx to Chris Coulson <email address hidden> for the patch
  * use nsIPluginHost to reloadPlugins as nsIPluginManager was removed in ffox 3.6
    - update content/pluginAlternativeOverlay.js
  * fix problem in plugin installer wizard as ubufoxPluginWizardString bundle
    is not accessible through 'this' since ffox 3.6 anymore
    - update content/pluginInstallerWizard.js
  * use Google by default for all languages
    - update locale/*/ubufox-search.properties
  (merge lp:~csaba-kertesz/ubufox/lp418777)
  * fix LP: #418777 - Portuguese string consistency
  (merge lp:~csaba-kertesz/ubufox/lp381674)
  * fix LP: #381674 - Unnecessary whitespace before ellipsis in Ubuntu Firefox menu
  (merge lp:~csaba-kertesz/ubufox/lp414926)
  * fix LP: #414926 - add Bulgarian translation
  (merge lp:~csaba-kertesz/ubufox/lp509536)
  * fix LP: #509536 - add dutch translation
 -- Alexander Sack <email address hidden> Fri, 09 Apr 2010 15:31:08 +0200

Changed in ubufox (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 3.6.3+nobinonly-0ubuntu2

---------------
firefox (3.6.3+nobinonly-0ubuntu2) lucid; urgency=low

  [ Chris Coulson <email address hidden> ]
  * Fix LP: #526291 - abrowser menu entry has Firefox icon. After changing the
    branding in common-post-build-arch, ensure that the firefox icons in
    dist/bin/icons are replaced with the abrowser icons
    - update debian/rules
  * Fix LP: #408238 - does not provide gnome-www-browser
    - update debian/firefox-gnome-support.postinst.in
    - add debian/firefox-gnome-support.prerm.in
    - update debian/rules
  * Update Google and Yahoo! search URL's
    - add debian/patches/ubuntu_codes_google.patch
    - update debian/patches/series
    - update debian/firefox.js
  * Fix LP: #520166 - Restore ability to set a preferred plugin for a given
    mime-type, which regressed since we are not using the system xulrunner
    - add debian/patches/bzXXX_plugin_for_mimetype_pref.patch
    - update debian/patches/series
  * Fix LP: #557640 - nrf-003 testcase failed Default "Welcome to Ubuntu" page
    doesn't appear without connectivity - re-enable the NetworkManager
    integration
    - update debian/firefox.js
  * Fix LP: #541951 - Firefox 3.6 does not honour lockPref - resurrect the
    patch used in xulrunner to reimplement this
    - add debian/patches/bz467738_att351145_lockPref_everywhere.patch
    - update debian/patches/series

  [ Jamie Strandboge <email address hidden> ]
  * AppArmor:
    - add apturl (LP: #558432)
 -- Chris Coulson <email address hidden> Fri, 09 Apr 2010 12:29:53 +0100

Changed in firefox (Ubuntu Lucid):
status: Fix Committed → Fix Released
Sergio Zanchetta (primes2h) wrote :

Just tested with RC prerelease and this bug is still present.

firefox 3.6.3+nobinonly-0ubuntu3
ubufox 0.9~rc2-0ubuntu2

Changed in firefox (Ubuntu Lucid):
status: Fix Released → Triaged
Chris Coulson (chrisccoulson) wrote :

Can you detail steps to recreate it then? It's working fine here. If network manager indicates there is no network connectivity, Firefox loads the offline page as expected

1) 3G internet connection using Network-Manager.
2) Click on NM icon, Disconnect.
3) Open Firefox
4) Server not found (the page could not be loaded)

Chris Coulson (chrisccoulson) wrote :

Hmm, WFM. Do you have any other network connections?

Sergio Zanchetta (primes2h) wrote :

No other connection.
I tested using Live USB and the issue is present.
The URL he tries to load is
http://start.ubuntu.com/10.04//Amazon.com/

I have just done another test, I tried using a VM installation I had
from Beta 2, updated and it works.
The URL in address bar is about:home.

Chris Coulson (chrisccoulson) wrote :

I can't recreate the issue from any configuration here

Changed in firefox (Ubuntu Lucid):
assignee: Chris Coulson (chrisccoulson) → nobody
milestone: ubuntu-10.04 → none
Sergio Zanchetta (primes2h) wrote :

Forgot to mention that in VM I wasn't connected via 3G but in a LAN.

Sergio Zanchetta (primes2h) wrote :

I confirm it on Maverick Alpha 2 live.

Now if I open Firefox without connectivity, it tries to load this page:
http://start.ubuntu.com/10.04//Google/

Hew McLachlan (hew) wrote :

I confirm the issue on UNE Maverick Alpha 2. I did not get this with Alpha 1.

Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

What is happening here is that as Firefox is starting, something initializes nsIOService before libdbusservice.so has registered nsNetworkManagerListener. Because there is no compreg.dat at this state, nothing provides NS_NETWORK_LINK_SERVICE_CONTRACTID at the point that this code section is executed in nsIOService::Init

    // go into managed mode if we can
    mNetworkLinkService = do_GetService(NS_NETWORK_LINK_SERVICE_CONTRACTID);
    if (!mNetworkLinkService)
        mManageOfflineStatus = PR_FALSE;

    if (mManageOfflineStatus)
        TrackNetworkLinkStatusForOffline();

So, from this point, Firefox does no tracking of the network connectivity and nsIOService::GetOffline always returns FALSE (which is what ubufox is using to get the network status).

When you run Firefox for a second time, calling do_GetService(NS_NETWORK_LINK_SERVICE_CONTRACTID); from nsIOService::Init triggers loading of libdbusservice.so and automatic registration of nsNetworkManagerListener, because it exists in compreg.dat from the previous run

XPCOM component registration has changed quite a lot in Firefox 4.0, so I suspect this might not be an issue there.

This isn't going to be fixed in Firefox 3.6.

Changed in firefox (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
importance: High → Low
Chris Coulson (chrisccoulson) wrote :

This is WONTFIX for lucid

Changed in firefox (Ubuntu Lucid):
importance: High → Low
status: Triaged → Won't Fix
Chris Coulson (chrisccoulson) wrote :

And WONTFIX for Maverick too. We'll revisit this when we migrate to FF4.0 in Natty

Changed in firefox (Ubuntu):
status: Triaged → Won't Fix
Chris Coulson (chrisccoulson) wrote :

Urgh, that task wasn't for Maverick. Sorry, we should keep this one open :)

Changed in firefox (Ubuntu):
status: Won't Fix → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Martin Pitt (pitti) on 2011-02-15
Changed in firefox (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers