Comment 6 for bug 528139

Ryan (ubuntu-draziw) wrote :

Hi Micah, output below. However - it looks like the breakage is due to profile issues.
firefox -ProfileManager, and creating a new profile worked. I was able to copy my old extensions directory to the new profile, and all the extensions worked on the new profile. Also tried removing XPC.mfasl, XUL.mfasl etc from my old profile dir. - no luck on having the old profile directory work. So I tried restoring my old profile directory from a backup; trying to launch produced this message: 'Malformed File: Firefox could no install this item because "install.rdf" (provided by the item) is not well-formed or does not exist. Please contact the author about this problem."; after clicking ok, it started with what looked like blank profile.

$ COLUMNS=200 dpkg -l firefox\* xul\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-========================================================================================================
ii firefox 3.6+nobinonly-0ubuntu5 safe and easy web browser from Mozilla
un firefox-2 <none> (no description available)
un firefox-2-dom-inspector <none> (no description available)
un firefox-2-gnome-support <none> (no description available)
un firefox-2-libthai <none> (no description available)
un firefox-3.0 <none> (no description available)
un firefox-3.0-branding <none> (no description available)
un firefox-3.0-gnome-support <none> (no description available)
un firefox-3.1-gnome-support <none> (no description available)
rc firefox-3.5 3.6+nobinonly-0ubuntu5 dummy upgrade package for firefox-3.5 -> firefox
un firefox-3.5-branding <none> (no description available)
un firefox-3.5-gnome-support <none> (no description available)
un firefox-3.6 <none> (no description available)
un firefox-3.6-branding <none> (no description available)
un firefox-3.6-gnome-support <none> (no description available)
un firefox-adblock-plus <none> (no description available)
ii firefox-branding 3.6+nobinonly-0ubuntu5 Package that ships the firefox branding
un firefox-gnome-support <none> (no description available)
un firefox-granparadiso <none> (no description available)
un firefox-granparadiso-gnome-support <none> (no description available)
un firefox-libthai <none> (no description available)
un firefox-trunk <none> (no description available)
un firefox-trunk-gnome-support <none> (no description available)
ii xul-ext-adblock-plus 1.1.3-1 Advertisement blocking extension for web browsers
un xul-ext-thunderbird-locale-en-gb <none> (no description available)
rc xulrunner 1.8.1.16+nobinonly-0ubuntu1 XUL + XPCOM application runner
rc xulrunner-1.9 1.9.0.14+build2+nobinonly-0ubuntu1 XUL + XPCOM application runner
un xulrunner-1.9-dbg <none> (no description available)
un xulrunner-1.9-gnome-support <none> (no description available)
ii xulrunner-1.9.1 1.9.1.8+build1+nobinonly-0ubuntu1 XUL + XPCOM application runner
un xulrunner-1.9.1-gnome-support <none> (no description available)
un xulrunner-gnome-support <none> (no description available)