[MASTER] package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade: update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.

Bug #512937 reported by Tanath
154
This bug affects 32 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

Upgrading from 9.10 to 10.04.

Setting up firefox (3.6+nobinonly-0ubuntu1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2

ProblemType: Package
Architecture: i386
Date: Tue Jan 26 13:53:12 2010
DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 2
NonfreeKernelModules: nvidia
Package: firefox 3.6+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: firefox
Title: package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.31-17-generic i686

Revision history for this message
Tanath (tanath) wrote :
Philip Muškovac (yofel)
description: updated
Revision history for this message
Draycen DeCator (ddecator) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, according to this report, you are not using the most recent version of this package for your Ubuntu release. Please upgrade to the most recent version and let us know if you are still having this issue. Thanks in advance.

Changed in firefox (Ubuntu):
status: New → Incomplete
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".
Thanks again!

Changed in firefox (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
NoOp (glgxg) wrote :

Experienced the same issue on a karmic to lucid upgrade. The key is the error msg:

update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.

The problem is that the symlink /usr/bin/firefox is missing. In my case it was probably due to me previously purging firefox in an earlier version. The workaround for this is to copy the newly installed ubuntu.firefox symlink file:

$ sudo cp /usr/bin/ubuntu.firefox /usr/bin/firefox

or create a 'firefox' symlink to /usr/lib/firefox-3.6.3/firefox.sh

$ sudo ln -s /usr/lib/firefox-3.6.3/firefox.sh /usr/bin/firefox

Changed in firefox (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
John Vivirito (gnomefreak) wrote :

There is a bunch of them from what i saw. If you find them please mark as a duplicate of this one and rename title to have [MASTER] in front of it.

summary: - package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade:
+ [master] package firefox 3.6+nobinonly-0ubuntu1 failed to
+ install/upgrade: update-alternatives: error: alternative path
+ /usr/bin/firefox doesn't exist.
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

There are 3 duplicates (and 3 other closed as invalid) but the packages are coming from a ppa or an umd build.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Used Caps for MASTER to aid in finding it again. thanks

summary: - [master] package firefox 3.6+nobinonly-0ubuntu1 failed to
+ [MASTER] package firefox 3.6+nobinonly-0ubuntu1 failed to
install/upgrade: update-alternatives: error: alternative path
/usr/bin/firefox doesn't exist.
Revision history for this message
kawk (launchpad-ixo) wrote :

In my case the symlink wasn't missing but pointing to a nonexistent file /usr/bin/firefox-3.5 - I had to remove and recreate it in order to (re)install firefox.

Revision history for this message
Achilles (aalmansi) wrote :

Same situation here. Removing the old symlink from /usr/bin/firefox to /usr/libfirefox-3.5 and creating a new one to /usr/lib/firefox-3.6.3 solves the problem.

Revision history for this message
Majestyx (majestyx) wrote : Re: [Bug 512937] Re: [MASTER] package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade: update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.

hello readers,

Am 01.05.2010 14:27, schrieb Achilles:
> Same situation here. Removing the old symlink from /usr/bin/firefox to
> /usr/libfirefox-3.5 and creating a new one to /usr/lib/firefox-3.6.3
> solves the problem.
>

yes, i confirm. it works for me to.

ahoi
michael
[majestyx]

Revision history for this message
NoOp (glgxg) wrote :

Ran into the issue again with updating to FF 3.6.6.

Setting up firefox (3.6.6+nobinonly-0ubuntu0.10.04.1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2

The problem is from the previous symlinks:
$ ls -al /usr/bin/firefox
lrwxrwxrwx 1 root root 33 2010-04-27 12:09 /usr/bin/firefox -> /usr/lib/firefox-3.6.3/firefox.sh

and

$ ls -al firefox.ubuntu
lrwxrwxrwx 1 root root 31 2010-06-29 20:35 firefox.ubuntu -> ../lib/firefox-3.6.6/firefox.sh

So I rm'ed /usr/bin/firefox and
$ sudo mv /usr/bin/firefox.ubuntu /usr/bin/firefox
$ ls -al fire*
lrwxrwxrwx 1 root root 31 2010-06-29 20:35 firefox -> ../lib/firefox-3.6.6/firefox.sh

Following that the upgrade to 3.6.6. worked.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. However, this problem is occuring because some third party package has diverted our /usr/bin/firefox symlink to /usr/bin/firefox.ubuntu. I suspect you have either installed packages from or followed instructions provided by ubuntuzilla.

I'm afraid there's not much we can do about this

Changed in firefox (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Achilles (aalmansi) wrote : Re: [Bug 512937] Re: [MASTER] package firefox 3.6+nobinonly-0ubuntu1failed to install/upgrade: update-alternatives: error:alternative path /usr/bin/firefox doesn't exist.

Yes, that has worked for me too, in this and previous upgrades. In my case, the origin of the problem was the ubuntuzilla installation I made long time ago, and that I have not been able to completely uninstall since the first time I experienced this problem with a firefox upgrade. Any idea on how to find the ubuntuzilla remains and get rid of them?
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: NoOp <email address hidden>
Sender: <email address hidden>
Date: Wed, 30 Jun 2010 15:51:10
To: <email address hidden>
Reply-To: Bug 512937 <email address hidden>
Subject: [Bug 512937] Re: [MASTER] package firefox 3.6+nobinonly-0ubuntu1
 failed to install/upgrade: update-alternatives: error:
 alternative path /usr/bin/firefox doesn't exist.

Ran into the issue again with updating to FF 3.6.6.

Setting up firefox (3.6.6+nobinonly-0ubuntu0.10.04.1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2

The problem is from the previous symlinks:
$ ls -al /usr/bin/firefox
lrwxrwxrwx 1 root root 33 2010-04-27 12:09 /usr/bin/firefox -> /usr/lib/firefox-3.6.3/firefox.sh

and

$ ls -al firefox.ubuntu
lrwxrwxrwx 1 root root 31 2010-06-29 20:35 firefox.ubuntu -> ../lib/firefox-3.6.6/firefox.sh

So I rm'ed /usr/bin/firefox and
$ sudo mv /usr/bin/firefox.ubuntu /usr/bin/firefox
$ ls -al fire*
lrwxrwxrwx 1 root root 31 2010-06-29 20:35 firefox -> ../lib/firefox-3.6.6/firefox.sh

Following that the upgrade to 3.6.6. worked.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6

--
[MASTER] package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade: update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
https://bugs.launchpad.net/bugs/512937
You received this bug notification because you are a direct subscriber
of the bug.

Status in “firefox” package in Ubuntu: Confirmed

Bug description:
Binary package hint: firefox

Upgrading from 9.10 to 10.04.

Setting up firefox (3.6+nobinonly-0ubuntu1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2

ProblemType: Package
Architecture: i386
Date: Tue Jan 26 13:53:12 2010
DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 2
NonfreeKernelModules: nvidia
Package: firefox 3.6+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: firefox
Title: package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.31-17-generic i686

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/512937/+subscribe

Revision history for this message
NoOp (glgxg) wrote : Re: [Bug 512937] Re: [MASTER] package firefox 3.6+nobinonly-0ubuntu1 failed to install/upgrade: update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.

On 06/30/2010 09:12 AM, Chris Coulson wrote:
> Thank you for your bug report. However, this problem is occuring because
> some third party package has diverted our /usr/bin/firefox symlink to
> /usr/bin/firefox.ubuntu. I suspect you have either installed packages
> from or followed instructions provided by ubuntuzilla.
>
> I'm afraid there's not much we can do about this
>
> ** Changed in: firefox (Ubuntu)
> Status: Confirmed => Invalid

Sorry, but I've *never* used ubuntuzilla & the only other version of
Firefox that I use is from Mozilla and that runs within a folder in my
home directory & never touches /usr.

Revision history for this message
NoOp (glgxg) wrote :

On 06/30/2010 10:01 AM, NoOp wrote:
> On 06/30/2010 09:12 AM, Chris Coulson wrote:
>> Thank you for your bug report. However, this problem is occuring because
>> some third party package has diverted our /usr/bin/firefox symlink to
>> /usr/bin/firefox.ubuntu. I suspect you have either installed packages
>> from or followed instructions provided by ubuntuzilla.
>>
>> I'm afraid there's not much we can do about this
>>
>> ** Changed in: firefox (Ubuntu)
>> Status: Confirmed => Invalid
>
> Sorry, but I've *never* used ubuntuzilla & the only other version of
> Firefox that I use is from Mozilla and that runs within a folder in my
> home directory & never touches /usr.
>

I stand corrected. This machine goes back to dapper & I had, at one time
installed via ubuntuzilla. Anyway, correcting the symlink back per
Comment #11 & all is well now. Thanks.

Revision history for this message
Bastian Mäuser (mephisto-mephis) wrote :

Same error here, method from #11 fixed it, too.

I remember that I had similar problems getting firefox running after updating this particular installation from Hardy to Lucid Alpha Versions, but I can't remember installing any non ubuntu FF packages.

Revision history for this message
Ray Lewandowki (rtlewandowski-gmail) wrote :

Same issue - #11 corrected the problem.
Based on comments regarding ubuntuzilla, I also did that a while back. After reading this chain, I deleted everything that had firefox in the file name prior to re-installation. The system has been collecting this trash for the past three years.

Works fine now.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0~b12+build1+nobinonly-0ubuntu2

---------------
firefox (4.0~b12+build1+nobinonly-0ubuntu2) natty; urgency=low

  * Fix some typos in the manpage
    - update debian/firefox.1.in
  * Fix up the mess left by Ubuntuzilla rather than leaving our official
    package in a broken and inconsistent state, which ends up with users
    reporting bugs to Launchpad and giving us a bad reputation. If
    /usr/bin/firefox has been diverted and there is no /usr/bin/firefox
    provided on the system, just do the job of whatever package it was that
    broke the users install and remove the diversion for them. This should
    hopefully stop the frequently reported bugs we get from Ubuntuzilla users
    about /usr/bin/firefox being missing
    - update debian/firefox.postinst.in
    - Fixes LP: #512937, LP: #529136, LP: #552919, LP: #572733, LP: #574111,
      LP: #599978, LP: #600271, LP: #610522, LP: #610756, LP: #610907,
      LP: #612162, LP: #620400, LP: #623980, LP: #625014, LP: #630643,
      LP: #635166, LP: #638342, LP: #641838, LP: #658828, LP: #668809,
      LP: #672282, LP: #676239, LP: #707704, LP: #724090
  * Don't allow users to report bugs with apport-bug when /usr/bin/firefox
    has been diverted
    - update debian/firefox.py.in
  * Don't build with --disable-elfhack on armel. It's been fixed now
    - update debian/rules
 -- Chris Coulson <email address hidden> Fri, 25 Feb 2011 13:54:59 +0000

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers