tried installing firefox-3.6 after adding mozillateam/firefox-stable PPA :: package firefox 3.6+nobinonly-0ubuntu4~mfs~karmic1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #524947 reported by amar on 2010-02-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

tried installing firefox-3.6 after adding mozillateam/firefox-stable PPA

got this error in synaptic:

package firefox 3.6+nobinonly-0ubuntu4~mfs~karmic1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

running "sudo apt-get install firefox-3.6" in terminal returned this :

Reading package lists... Done
Building dependency tree
Reading state information... Done
firefox-3.6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up firefox (3.6+nobinonly-0ubuntu4~mfs~karmic1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of firefox-3.6:
 firefox-3.6 depends on firefox; however:
  Package firefox is not configured yet.
dpkg: error processing firefox-3.6 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 firefox
 firefox-3.6
localepurge: checking system for new locale ...
Some new locales have appeared on your system:

ace frp

They will not be touched until you reconfigure localepurge
with the following command:

    dpkg-reconfigure localepurge

localepurge: processing locale files ...
localepurge: processing man pages ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

Then tried "sudo dpkg-reconfigure localepurge" and tried to install again but no change:

Reading package lists... Done
Building dependency tree
Reading state information... Done
firefox-3.6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up firefox (3.6+nobinonly-0ubuntu4~mfs~karmic1) ...
update-alternatives: error: alternative path /usr/bin/firefox doesn't exist.
dpkg: error processing firefox (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of firefox-3.6:
 firefox-3.6 depends on firefox; however:
  Package firefox is not configured yet.
dpkg: error processing firefox-3.6 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 firefox
 firefox-3.6
localepurge: checking system for new locale ...
localepurge: processing locale files ...
removed `/usr/share/locale/ace/LC_MESSAGES/jokosher.mo'
removed `/usr/share/locale/frp/LC_MESSAGES/exaile.mo'
localepurge: Disk space freed in /usr/share/locale: 16K
localepurge: processing man pages ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
Architecture: i386
CrashDB: ubuntu
Date: Sat Feb 20 21:19:36 2010
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 2
FirefoxPackages:
 firefox 3.6+nobinonly-0ubuntu4~mfs~karmic1
 firefox-gnome-support 3.5.8+build1+nobinonly-0ubuntu0.9.10.1
 firefox-branding 3.6+nobinonly-0ubuntu4~mfs~karmic1
 abroswer N/A
 abrowser-branding N/A
NonfreeKernelModules: nvidia
Package: firefox 3.6+nobinonly-0ubuntu4~mfs~karmic1
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: firefox
Tags: ppa
ThirdParty: True
Title: package firefox 3.6+nobinonly-0ubuntu4~mfs~karmic1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Uname: Linux 2.6.31-19-generic i686

amar (amarendra) wrote :
amar (amarendra) wrote :

actually i was trying to install 3.6 over 3.5.8 using mozilla-stable PPA so it may not actually be a firefox(Ubuntu) bug

amar (amarendra) wrote :

Going back to default ubuntu firefox, that would be 3.5.8. I will not try this again and I won't be able to update on this bug report. However I was able to run firefox from terminal by command: /usr/bin/firefox-3.6/firefox so it must have been a linking issue but nevertheless it's lame not to have the latest packages. that too when the vendor has made a stable release.

May be I will try some rolling release distro and will switch to it if i find it good enough.

TAP (visibletrap) wrote :

I have got some workaround.

You can see from your error log that the cause of this problem start at this line.
"update-alternatives: error: alternative path /usr/bin/firefox doesn't exist."

It tell us that it want "/usr/bin/firefox" which it was disappear.

Then all you have to do is to open terminal and type this command
sudo ln -s /usr/lib/firefox-3.6/firefox /usr/bin/firefox

Then reinstall the packages. It should work with no error.

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories (firefox from a ppa). Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!
If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:
1. http://www.ubuntu.com/community/ubuntustory/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories.

Changed in firefox (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers