Strange behavior when pasting a text in a text box with mouse cursor on the edge of the text box and left mouse button pressed

Bug #508969 reported by Mathieu Marquer on 2010-01-18
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
High
firefox (Ubuntu)
Medium
Unassigned
firefox-3.5 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: firefox-3.5

Bug spotted on http://forum.ubuntu-fr.org/viewtopic.php?pid=3218492#p3218492 , affects at least Firefox 3.5.7, Firefox 3.6RC2, on at least GNU/Linux and MS Windows. I can confirm it affects myself too.

Steps to reproduce :
* Copy any text you want
* Find a webpage with a text box, for example google.com search field
* Put the mouse cursor on the edge of the field (important step)
* Press Ctrl + left click + V
--> Two behaviors observed:
* The text will be pasted, but outside the text box
* The text box will disappear

Video showing this bug on http://www.youtube.com/watch?v=u34e_4_xt2I (Flash player, sorry, not my video...)

ProblemType: Bug
Architecture: amd64
Date: Mon Jan 18 02:11:14 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: firefox-3.5 3.5.7+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-18-generic x86_64

Have you also tested it in safe-mode? This to exclude extension influences.

> Also, very rarely, the pasting text will be implanted in the html just as text.

I believe this is a known bug.

Yes, this does happen in safe-mode as well. I checked extensions (add-ons) and they were all deactivated.
I checked the reported bugs before I posted, but I didn't see one similar to this problem. Do you know the bug #?

I am able to consistently reproduce this bug.
1) go to any page with an input box (I used google.com)
2) type some text in the input box ("asdf"). The cursor should be blinking to the right of the last letter you typed.
3) Ctrl+click on the top border of the input box. This is the one pixel exactly where the cursor changes from default to the text cursor. The blinking cursor should disappear.
4) Hit any letter key. The input box will disappear.

Also note that if you do not type any text in the input box in step 2 then proceed through the steps, the letter you type in step 4 will appear just outside to the left of the input box.

I think this bug has to do with "CTRL-click table selection" (Table cell selection).
When an input box is inside TD element, this happens. For instance, if I try this at http://www.google.com/ since the input box is in a TD element, the bug occurs, Whereas the same doesn't seem to happen at http://www.google.co.jp/, since the input box is not in a TD element.

Created an attachment (id=367957)
testcase

(In reply to comment #2)
> I checked the reported bugs before I posted, but I didn't see one similar to
> this problem. Do you know the bug #?

I was referring to a rather old bug; Bug 339975.
There is a more recent possibly related one now, Bug 424627.

Created an attachment (id=368203)
testcase2

This testcase is more similar to original report.

In , Cork (cork) wrote :

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091016 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091016 Minefield/3.7a1pre

Pasting with ctrl-v in input fields or textareas in tables might remove the widget or paste the text in front of it.

Reproducible: Always

Steps to Reproduce:
1. Have a line of text in your clipboard.
2. Open the testcase.
3. Press and holding ctrl.
4. Mousedown in the widgets, and drag outside and mouseup.
5. Press v while still holding ctrl.
Actual Results:
a. If the widget had text in it, the widget gets removed from the dom.
b. If the widget is empty, the text gets pasted in front of the widget.

Expected Results:
The text should be pasted inside the widget or not at all.

I can reproduce this in all firefox versions on linux and windows back to firefox 1.5, So it happen between firefox 1.0 and firefox 1.5.

This might be a dup on bug 372709, but its to vague or me to post this in it.

In , Cork (cork) wrote :

Created an attachment (id=406804)
Testcase

Is this bug related with Bug 462970 ?

*** Bug 540352 has been marked as a duplicate of this bug. ***

Binary package hint: firefox-3.5

Bug spotted on http://forum.ubuntu-fr.org/viewtopic.php?pid=3218492#p3218492 , affects at least Firefox 3.5.7, Firefox 3.6RC2, on at least GNU/Linux and MS Windows. I can confirm it affects myself too.

Steps to reproduce :
* Copy any text you want
* Find a webpage with a text box, for example google.com search field
* Put the mouse cursor on the edge of the field (important step)
* Press Ctrl + left click + V
--> Two behaviors observed:
* The text will be pasted, but outside the text box
* The text box will disappear

Video showing this bug on http://www.youtube.com/watch?v=u34e_4_xt2I (Flash player, sorry, not my video...)

ProblemType: Bug
Architecture: amd64
Date: Mon Jan 18 02:11:14 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: firefox-3.5 3.5.7+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-18-generic x86_64

Mathieu Marquer (slasher-fun) wrote :
Changed in firefox-3.5 (Ubuntu):
status: New → Confirmed
summary: Strange behavior when pasting a text in a text box with mouse cursor on
- the edge of the text box
+ the edge of the text box and left mouse button pressed
Changed in firefox:
status: Unknown → New
Cork (cork) wrote :

This bug should be linked ageist https://bugzilla.mozilla.org/show_bug.cgi?id=462970 instead, the description in that bug match better as its the bug for clicking on the border of the element.

*** Bug 564109 has been marked as a duplicate of this bug. ***

(From update of attachment 367957)
I can more consistently reproduce this in attachment 368203 following steps there.

*** This bug has been marked as a duplicate of bug 462970 ***

*** Bug 522815 has been marked as a duplicate of this bug. ***

Changed in firefox:
status: New → Invalid
Changed in firefox:
status: Invalid → Unknown
Changed in firefox:
status: Unknown → Confirmed

*** Bug 577562 has been marked as a duplicate of this bug. ***

*** Bug 504749 has been marked as a duplicate of this bug. ***

Micah Gersten (micahg) wrote :

Marking this Triaged as we have an upstream bug.

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Micah Gersten (micahg) wrote :

Adding a firefox task to help with dupe finding.

Changed in firefox (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Sorry for the "aaa" comment.

gloken (elderthing) wrote :

Encountered this in Firefox 3.5.1.1
Pretty much 100% reproducible, but I guess it's not horribly severe.

Changed in firefox:
importance: Unknown → High

*** This bug has been marked as a duplicate of bug 424627 ***

Changed in firefox:
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.