firefox hangup while drag text in kde4

Bug #279654 reported by Magi Su on 2008-10-07
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Firefox hangup when I try to drag some selected text in KDE4. It works in KDE3.5.10. But in KDE4 my computer hangups, and the top command shows the Xorg has a 99% cpu time. Anyone can help?

Ivan Garcia (capiscuas) wrote :

this happens to me too, but I believe is not hang up, but it freezes for a long time.

In my case:

1. I choose (highlighted) some text to move
2. I tried to drag the selected text to the next blank line. The cursor changed to show I had selected text, but the selected text did not move. Only the mouse can move but no answer to any click. Then after like 10 seconds (it depends how far I've tried to drag the selection) the text gets drag, and then after more seconds (maybe 10 or 20 more, that's why it gives the feeling of hanged), finally it comes back to normal and I can click again etc.

I'm using Kubuntu Intrepid but it also happened on my firefox on Kubuntu 08.04 (with KDe4)
The package right now is:
3.0.3+nobinonly-0ubuntu2

is this KDE4 related?

Why so many related bugs are being invalidated?
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/69816
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/71971
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/147018

Magi Su (magisu) wrote :

Hello Ivan

I must say that if I switch off KDE4 desktop effect, everything will go well. So it must be related to OpenGL.

Ivan Garcia (capiscuas) wrote :

hi Magi Su,

that solution worked for me too, disabling by KDE4 desktop effects inside the DESKTOP menu in SYSTEM SETTINGS.

Somehow the effects behind that is interfering with the select and drag text in firefox and making many systems to hang(the X only).

Can this bug be forwarded to the KDE4 desktop effects package bugs for them to check what is going on?

Jahava (danjacques) wrote :

I wanted to post to confirm the bug. I'm using Kubuntu 8.10 with KDE4 and running an NVidia graphics card supported by their proprietary drivers. 'kwin' consumes large amounts of CPU when you highlight and drag text in Firefox. When you highlight more than a line or two, this results it the system hanging for extended periods of time. Highlighting just one line still has a working text-drag effect (with very high CPU consumption).

On Windows and KDE3 with Firefox 3, the text-drag action results in the selected area being rendered in a transparent (and, depending on the quantity of text, scaled) form which follows the cursor around until released. The KDE4 version (when selecting small enough quantities of text to avoid hanging) seems to be visually similar to the KDE3 version.

You are correct when you say that it's related to desktop effects, as disabling them completely solves the problem. Furthermore, changing the Compositing Type from 'OpenGL' to 'XRender' also solves the problem, so it seems like it's a KDE4/OpenGL issue that may also involve (or be caused by) the NVidia proprietary driver.

cologic (cologic) wrote :

I can confirm this bug for the fglrx version that comes with Kubuntu Ibex amd64 as well:

ii fglrx-amdcccle 2:8.543-0ubuntu4 Catalyst Control Center for the ATI graphics
ii fglrx-kernel-source 2:8.543-0ubuntu4 Kernel module source for the ATI graphics ac
ii xorg-driver-fglrx 2:8.543-0ubuntu4 Video driver for the ATI graphics accelerato

I'm seeing precisely the same symptoms as those using NVidia cards and drivers, so it seems unlikely to be specific to that vendor.

peshooo (pesho-yes) wrote :
eMerzh (emerzh) wrote :

it seems that it's fixed in firefox 3.1...

http://bugs.kde.org/show_bug.cgi?id=166271#c7

to be verified....

Jahava (danjacques) wrote :

I'm posting to confirm this. Firefox 3.1 Beta 2 seems to handle the text transparency properly. Same system specs as my previous post.

Setting status to confirmed based on the many confirmations in this bug and that I myself could reproduce it

Changed in firefox:
status: New → Confirmed
Jelle Foks (jellefoks) wrote :

I am affected by this bug. I'm using jaunty with firefox 3.0.5 on intel gm4500 video, and just now I triggered the bug (again), and the system hung for a while, then when it got 'unstuck', I saw a notification flash quickly from kwin that 'compositing was slow', and now while my desktop effects appear disabled (by function only, the 'settings' program still shows them as active), I can't trigger the bug anymore... So I'd agree that it looks like a bug in compositing support in kwin.

xrayspx (xrayspx) wrote :

You can disable this in FireFox by using about:config to set nglayout.enable_drag_images to False. This will force FireFox not to create a little image of highlighted text when you drag it, and will no longer cause KWIN to freak out and disable compositing. The fact that you're dragging will be represented by a little icon rather than a picture of what is being dragged.

A short KB article about how this feature works is here:
http://kb.mozillazine.org/Nglayout.enable_drag_images

eMerzh (emerzh) wrote :

 xrayspx => works for me! thanks a lot!

Richard Johnson (nixternal) wrote :

Closing this report due to the work around seeming to fix the issue initially reported. If you think this is still a valid bug, could you please reopen this report and provide any further information that may be valid. Thank you!

Changed in firefox:
status: Confirmed → Invalid
gnufreex (gnufreex) wrote :

I have same problem, but is not only in firefox. Any text dragging results slowdown and kwin turns off desktop effects.

It is KDE 4.2.3, Ubuntu 9.04 64-bit (Kubuntu added via synaptic), desktop effects turned on. Graphics drivers is 180 series (nvidia's propriatary installed in hardware drivers applet)

Hardware is GF 8800GT, Q9650 CPU, 8igigs of RAM

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.