Ubuntu

MASTER [GUTSY] firefox crashed [@pixman_compositeGeneral] [@_cairo_pixman_composite] [@_cairo_image_surface_composite] from libcairo

Reported by Søren Bredlund Caspersen on 2007-08-17
16
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Mozilla Bugs
libcairo (Ubuntu)
Medium
Unassigned
ubuntulooks (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

Running latest updated gutsy head 4 amd64. Firefox dosn't work.

Confirmed by anders at comment
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/133124/comments/9

From my terminal:

sc@sc-laptop:~$ firefox
Segmentation fault (core dumped)
sc@sc-laptop:~$ uname -a
Linux sc-laptop 2.6.22-9-generic #1 SMP Fri Aug 3 00:20:35 GMT 2007 x86_64 GNU/Linux
sc@sc-laptop:~$ firefox --version
Mozilla Firefox 2.0.0.6, Copyright (c) 1998 - 2007 mozilla.org

Extracted from symbolized stacktrace:
(file: http://launchpadlibrarian.net/8894402/gdb-firefox.log)
...
#0 fbFetch_x8r8g8b8 (bits=0x2aaa39d89068, x=<value optimized out>,
#1 pixman_compositeGeneral (op=<value optimized out>,
#2 _cairo_pixman_composite (op=PIXMAN_OPERATOR_OVER,
#3 _cairo_image_surface_composite (
#4 _cairo_surface_composite (op=CAIRO_OPERATOR_OVER,
#5 _cairo_surface_fallback_composite (
#6 _clip_and_composite_trapezoids (src=0x7fff8927ebc0,
#7 _cairo_surface_fallback_fill (surface=0x13f1bb0,
#8 _cairo_surface_fill (surface=0x13f1bb0,
#9 _cairo_gstate_fill (gstate=0x13fe680, path=0x13fe818)
...

Related branches

Justin M. Wray (wray-justin) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We have instructions on debugging some types of problems. [WWW] http://wiki.ubuntu.com/DebuggingProcedures

Please also attempt obtain a valgrind log following the instructions at [WWW] https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

In addition could you please try to obtain a backtrace by following the instructions on [WWW] https://wiki.ubuntu.com/MozillaTeam/Bugs, or upload (as an attachment) the crash report from /var/crash/.

Also, please answer these questions:
Is this crash reproducible? If so, which are the steps that lead to it?
Which flash package do you have installed?
Which Java package do you have installed?
Which firefox extensions do you have installed?

This will greatly aid us in tracking down your problem.

Changed in firefox:
assignee: nobody → wray-justin
status: New → Incomplete

The crash happens every time I try to start firefox

Thank you Søren Bredlund Caspersen for submitting this report.

Could you please try to obtain another backtrace by installing the
missing debug symbol packages; from your retrace [1] those missing
packages seem to be:

...
gtk2-engines-ubuntulooks-dbgsym
libcairo2-dbgsym
libglib2.0-0-dbgsym
...

You can get them from pitti's repo:

...
deb http://people.ubuntu.com/~pitti/ddebs gutsy main universe
...

Finally please indicate which extensions/plugins do you have enabled;
and if this crash is always reproducible describe the steps that lead to
it (it is very important for us to have a test case for each crash).

This will greatly aid us in tracking down your problem.

Thanks in advance.

H. Montoliu

[1] http://launchpadlibrarian.net/8882381/gdb-firefox.log

description: updated
Changed in firefox:
assignee: wray-justin → mozilla-bugs
importance: Undecided → Medium

It is a fresh install, so I have installed no extensions / plugins that are not installed by default.

The crash happens every time I start firefox. I don't have to do anything 'special' for it to happen.

Hope the attatched file helps you further, else pleas let me know if there is anything else I can do.

On Mon, 2007-08-20 at 13:47 +0000, Søren Bredlund Caspersen wrote:

> Hope the attatched file helps you further, else pleas let me know if
> there is anything else I can do.

Thank you Søren Bredlund Caspersen we are going to process your report.
If you have any additional info please indicate at any time.
--
Hilario J. Montoliu <email address hidden>

description: updated
Changed in firefox:
importance: Medium → High
description: updated
anders (launchpad-20-nky) wrote :

And I forgot to add the log of course.. ;P

Thank you anders.

Can you describe the exact behavior, does it crash always before starting as happens to Søren?

Marking this report as confirmed.

Marked confirmed because of anders' report.

Changed in firefox:
status: Incomplete → Confirmed
description: updated
anders (launchpad-20-nky) wrote :

Yes, it crashes semi-instantly.

I see the window show up for half a second (plain window, no child windows/buttons/whatever), then it dumps.

Niranjan (niranjansivakumar) wrote :

For further corroboration, I'm having the same issue on a recent upgrade from Feisty to Gutsy Tribe 5. Firefox segfaults as soon as I try to start it. I also see the window up for a second and then it segfaults.

Niranjan (niranjansivakumar) wrote :

Something in the last set of updates partially fixed this problem for me, however, firefox still immediately segfaults if I try to open it on my second monitor. See: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/139095. I'm not sure if there's any relation between the two. Firefox is now able to start without a problem on my primary display.

Tenko20XX (tenko20xx) wrote :

I have also been having the same problem, though mine started very randomly. First off, my firebug plugin just stopped working one day. After a while, if I opened Firefox via the program menu, I would see it show up in the panel and say "Starting Firefox..." and then it would crash, but sometimes it would load, often if I tried opening 2 or more instances, though only one would ever load at a time. Then, I decided to reinstall Firefox and afterwards, it stopped opening at all. This is when I tried opening it through the terminal and noticed the segfault. Now, I recently found out that if I open Firefox by doing a "sudo firefox" it runs perfectly fine! I don't understand it at all, but I just thought I would throw that information out there for anyone who's interested.

The first time I launch firefox after a fresh boot it loads without any problems. Unfortunately, if I close Firefox then it segfaults every time I try to load it again... until I reboot.

After a hint on IRC I tried changing graphics drivers.

It would seem that the bug disappears if I load the restricted graphics drivers for my NVIDIA G70 [GeForce Go 7600].

So, the bug appears with the un-restricted driver and not with the restricted ones.

Hope this helps you all produce a fix to this bug.

Regards
Søren

James Henstridge (jamesh) wrote :

If the proprietary nvidia drivers hide the problem, it is probably because of differences in the extensions or visuals/pixel formats supported by the two drivers.

In a number of cases, Cairo provides fallbacks if the X server doesn't support a particular feature. So it is likely that different code paths are being executed when run under the different drivers.

For reference, I am seeing the same crash on my AMD64 system which has an ATI Radeon 9200 SE (using the Free drivers).

James Henstridge (jamesh) wrote :

After noticing the ubuntulooks_draw_progressbar_trough() call in Søren's stack trace, I tried switching to another theme.

While the "Human" control theme causes Firefox to crash on startup, Firefox runs without problems with the Clearlooks and ClearlooksClassic control themes (which ubuntulooks is based on).

So the problem most likely exists in one of the differences between clearlooks and ubuntulooks.

Niranjan (niranjansivakumar) wrote :

I can confirm that changing the theme to Clearlooks from Human fixes the segfaulting on my machine.

Matti Lindell (mlind) wrote :

probably a dupe of bug #123646 which is also about ubuntulooks_draw_progressbar_trough() and blows in libcairo2's fbFetch_x8r8g8b8

James Henstridge (jamesh) wrote :

Another data point: I was running my X server in 16-bit graphics mode. If I switched to 24-bit, the Firefox loads correctly with the Human theme. My x86 laptop has no problems in either 16-bit or 24-bit depths.

So the requirements to reproduce seem to be:
 * x86-64
 * 16-bit depth
 * Human control theme (== ubuntulooks theme engine)

Does that match anyone else's observations?

James Henstridge (jamesh) wrote :

Attached is a patch against the ubuntulooks engine's ubuntulooks_progressbar_create_cell() to create a Cairo surface of the same type as the target rather than an RGB24 image surface. With this patch applied, Firefox runs starts fine with the Human theme.

The RGB24 image surface was what tipped me off to try different bit depths above. By making the pattern match the target surface's format, the composite fallback routine should be avoided.

It is worth noting that while this patch cleared up the crash for me, the bug probably still exists in Cairo's fallback compositing routines. Hopefully there is enough information here to produce a simpler test case though.

Sean T murray (smurray1-nycap) wrote :

Just a note to verify other results. I am having what appears to be the same issue on a AMD64 with NVIDIA GeForce 7025 Video. When I was running firefox from the console (which uses the NVIDIA drivers I downloaded from NVIDIA), firefox ran fine. When I ran firefox while using vnc (which was using the open source driver), it seg faulted on start. Changing the theme to "clearlooks" stops the seg fault.

Sebastien Bacher (seb128) wrote :

Thank you for the patch James

Changed in ubuntulooks:
importance: Undecided → Low
status: New → Triaged
Sebastien Bacher (seb128) wrote :

ubuntulooks (0.9.12-7) gutsy; urgency=low

  * debian/patches/01_progressbar-fix.patch:
    - patch from James Henstridge to fix a firefox crasher on amd64 gutsy
      (LP: #133124)

 -- Sebastien Bacher <email address hidden> Thu, 04 Oct 2007 11:33:21 +0200

Changed in ubuntulooks:
status: Triaged → Fix Released
Alexander Sack (asac) on 2007-10-16
Changed in firefox:
status: Confirmed → Invalid
Chris H. (ahmshaegar) wrote :

Hello,

I'm new here so please let me know what I need to do next. I'll start by posting as much information as I can. Right now, I'm using Swiftfox, as that seems to work.

I upgraded to Ubuntu 7.10 from Ubuntu 7.04 using the alternate CD in combination with Update Manager.

I have the latest Adobe Flash beta plugin (I believe it was released on the 1st of October?)

My other Firefox extensions are: Adblock Plus 0.7.5.3 with Adblock Filterset.G Updater, DOM Inspector, DownThemAll! 1.0b2, Fasterfox 2.0.0, Mozilla XForms, Stop Autoplay 0.6.4, Tabbrowser Preferences 1.3.1.1, and YesScript 1.1

I am currently using iFox Graphite 2.5 as my theme.

It seems many people are having problems with Nvidia graphics hardware; however, I am using an ATI Mobility Radeon X1400 on a Dell E1505, and I am using fglrx 8.40.4, which I downloaded from ATI's website (I didn't install it from Add/Remove Programs.)

Firefox crashes on startup and I do not even get to see the window. When I launch it from the terminal it gives me the complaint about some font and cairo, but when I use "sudo firefox" (I know that's a bad idea, which is why I'm using Swiftfox right now), it works fine.

I am installing the debugging tools right now, and I will post the logs in a few minutes. Right now, Swiftfox has taken over, so when I try to launch Firefox, it will launch Swiftfox instead. I will remove Swiftfox for the time being to get the logs. I hope this helps you guys improve Ubuntu and Firefox. Once again, please let me know if you need more information.

Chris H. (ahmshaegar) wrote :

Okay, I followed the directions at https://wiki.ubuntu.com/MozillaTeam/Bugs so here's the file

James Henstridge (jamesh) wrote :

Chris: looking at the stack trace, your crash looks like a different bug.

The first few stack frames look similar to bug 103880 though.

Felipe Jaekel (fkjaekel) wrote :

Firefox crashes on my machine too. It's an AMD 32 bit, fresh install. It only happens with some websites

Console output:

$ firefox

(gecko:6375): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'Tahoma 12'
Segmentation fault (core dumped)

Jordan Erickson (lns) wrote :

I can also verify, on a new Gutsy AMD64 install with all updates applied as of 2007/10/29, Firefox will crash semi-instantly (you can see the window appear, and then close out, with a "Segmentation fault (core dumped)" message on the console.

Switching Gnome theme from "Human" to "Glossy" causes Firefox to load normally. This is with VESA video drivers loaded.

Felipe Jaekel (fkjaekel) wrote :

Removing the Tahoma font solved my problem

R Moore (rc-moore) wrote :

I fixed this problem:
(gecko:6375): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'Tahoma 12'
Segmentation fault (core dumped

(for me it was an Arial font though)

by changing permissions to 755 on all directories in /user/share/fonts.

Sebastien Bacher (seb128) wrote :

the issue was due to ubuntulooks and has been fixed in gutsy

Changed in libcairo:
importance: Undecided → Medium
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers