getUserMedia doesn't work in Firefox/Unity in Ubuntu 13.10

Bug #1217091 reported by Remco on 2013-08-26
94
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
In Progress
Medium
firefox (Ubuntu)
Medium
Unassigned

Bug Description

Firefox doesn't ask for permission to use my camera or microphone when calling getUserMedia. Instead, it just does nothing. None of the tests here work: http://mozilla.github.io/webrtc-landing/

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: firefox 23.0+build2-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-3.8-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic x86_64
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
BuildID: 20130807180628
Channel: Unavailable
Date: Mon Aug 26 22:35:55 2013
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.0.1 dev eth0 proto static
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.104 metric 1
Locales: extensions.sqlite corrupt or missing
MarkForUpload: True
MostRecentCrashID: bp-3081eb08-2163-454d-b541-5572f2121104
Plugins:
 Gnome Shell Integration - /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so (gnome-shell)
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 Shockwave Flash - [HomeDir]/.mozilla/plugins/libflashplayer.so
PrefSources:
 prefs.js
 /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/<email address hidden>/defaults/preferences/001ubuntu-gnome-mods.js
 [Profile]/<email address hidden>/defaults/preferences/preferences.js
 [Profile]/<email address hidden>/defaults/preferences/zoteroOpenOfficeIntegration.js
Profiles: Profile0 (Default) - LastVersion=23.0/20130807180628 (In use)
RelatedPackageVersions:
 gnome-shell 3.8.4-0ubuntu1
 rhythmbox-mozilla 2.99.1-0ubuntu1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: firefox
SubmittedCrashIDs:
 bp-3081eb08-2163-454d-b541-5572f2121104
 bp-3ab5a053-9a78-4948-a5ca-a56372121010
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: Upgraded to saucy on 2013-06-17 (70 days ago)
dmi.bios.date: 09/28/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.3
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 785GM-E51 (MS-7596)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.3:bd09/28/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7596:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rn785GM-E51(MS-7596):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7596
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

Remco (remco47) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Rocko (rockorequin) wrote :

I can confirm that the call to getUserMedia under FF 23 and Ubuntu 13.10 never returns. FF never prompts for permission and top shows that one CPU is stuck at 100%. This happens whether I run FF in safe-mode or normally.

It *does* work under FF 23 in Ubuntu 13.04, however, and it also works fine in Chrome 29.0.1547.62 in Ubuntu 13.10, so it seems to be an issue with the FF/Unity integration.

summary: - getUserMedia doesn't work
+ getUserMedia doesn't work in Firefox/Unity in Ubuntu 13.10
Rocko (rockorequin) wrote :

Perhaps this is related to http://support.mozilla.org/en-US/questions/967768? That points to an alsa-lib issue in snd_device_name_hint reported as bug #1008600. There is apparently a fix for that resolves the issue. But bug #1008600 is only flagged as fix-committed, not fix-released.

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1685.0 Safari/537.36

Steps to reproduce:

Using AppRTC example page https://apprtc.appspot.com try to make a call to another browser.

Actual results:

The media permissions request pop-up is not shown

Also discussed in https://groups.google.com/forum/#!msg/discuss-webrtc/lJ39A2TT1VI/l3kqtsYW0ZYJ

Expected results:

Some panel or pop-up for permissions request

Hello,

I have the same problem under Ubuntu Saucy.
If you need tests or something else, tell me.

Regards,

Simon Eisenmann (longsleep) wrote :

I can confirm that this is stil a problem with FF 25 on Ubuntu 13.10.

In , j^ (j) wrote :

This is fixed in recent nightly builds.

Daniel Vispo (vaisp) wrote :

Confirmed, this bug appears in some computers with FF 25 on Ubuntu 13.10.

Confirmed, this problem occurs in 25.0.1 and is fixed in nightly 28.0.a1 2013-11-17

Please check bug 938361 - it might be related or the same bug related to libasound on that distro

Also, the logs will tell you very little (other than signaling:5 logs) for webrtc unless you run a debug build (from the mozilla ftp server - http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/)

Since it happens in 25.0.1 (is that from mozilla's servers, or is that a distro build?) and not in nightly, could you try Aurora/27 and Beta/26?

If it is fixed in nightly, and not in Aurora, we may be able to uplift it if I find out soon. It's too late for Beta/26 since that will go out RSN.

Please see comment 4 for the info needed, thanks

In , j^ (j) wrote :

Testing on Ubuntu 13.10 64bit with 64bit builds:

Both Aurora 27.0a2 (2013-11-25) [1] and Beta 26.0b7 [2] are broken and do not show the media permissions request pop-up.
Nightly 28.0a1 (2013-11-25) shows the popup and getUserMedia works.

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/firefox-27.0a2.en-US.linux-x86_64.tar.bz2
[2] https://download.mozilla.org/?product=firefox-26.0b7&os=linux64&lang=en-US

I confirme, it's fixed in firefox-trunk amd64 28.0~a1~hg20131121r156520-0ubuntu1~umd1
Thanks :)

But, what about all users since Firefox 24 ?
This mean all our developpement in WebRTC can't works for Firefox version before version 28 ? Or do you plan to make a fix on previous versions ?

Testing on Kubuntu 13.10 64bit with 64bit (3.11.0-13-generic) builds:

I also confirm that is working in nightly, in my case, 28.0a1 (2013-11-21), installed from PPA => http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu )

I also confirm same issues of @Jan Gerber (comment 6)

@Guillaume Lecanu, I'm not sure, but @Randell spoke about Beta 26 so this is not yet an "end user" version, so that should not be a problem.

@Randell I also have the same libasound version (1.0.27.2-1ubuntu6) from the bug that you referred bug 938361

In all the tests I made and which are described in my last comment 8 the CPU gets near 100% (except the 28.0a1)

Ok, what is happening is the libasound bug from bug 938361.

Examining the changes in audio_device_alsa_linux.cc I don't see any differences worth noticing. Perhaps the change is in a higher level, but I don't see anything there either. See the stacks in that bug - none of those functions changed in any way I can see between 27 (webrtc.org 3.34) and 28 (3.43)

I suspect either it's a threading/locking issue in libasound, or a compiler bug in libasound (given the reports in the upstream bug that recompiling libasound by hand fixes it)

Patrick: can you try the "recompile" workaround from the upstream bug?

Created attachment 8338571
strace of "libasound thread"

Created attachment 8338572
gdb backtrace

Randell: I tried to debug the firefox consuming the 100% CPU and do some debug. The thread consuming all the CPU is dealing with libasound (is possible to do some backtrace with and see lots of calls), but I din't find any pattern (I'll attach one of them). A also tried with strace the I saw lots of calls to SNDRV_CTL_IOCTL_PCM_*

I hope this can help

pmarques (patrickfmarques) wrote :

As far as I can see this still a problem with recent FF 26 on Ubuntu 13.10.

@Randell: bug 938361 was closed and it seems to be fixed in alsa-lib (https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1217091) should we also close this one?

I'm going to morph this into a bug to track the upstream and any possible workarounds (since the user might not have the upstream fix).

Since we didn't change anything in 28 to fix this (though we did update webrtc in general), it may be tough to isolate what we changed that helped things. (I suspect something about how it iterates through all possible sound devices.) The alsa interface code itself in 28 didn't change in any interesting way, as I noted above. And just because it happens to work in 28 doesn't mean that it won't fail randomly under different stress or on a different machine, given the description of the Alsa root bug.

:jesup sorry didn't get back to this very promptly. Since I'm a month late, do you still need someone with Ubuntu 13.10 to try this on Beta/26 and Aurora 27?

26 is now release; beta is now 27. No chance for 26 changes, limited chances for 27, but avoiding this sort of bug would likely qualify *if* there's a way to avoid it, which I don't think there is

gugaiz (gugaiz) wrote :

I tested on firefox beta 27 on Ubuntu 13.10 and still not working

Changed in firefox (Ubuntu):
importance: Undecided → Medium
Thijs Triemstra (collab) wrote :

I tested with firefox-trunk on 13.10 and it works there, unfortunaly (still) not in Firefox 26. Never had any problems in Ubuntu 12.04 and any Firefox version. Dissapointing to see that such a neat feature is broken in the latest stable release of Ubuntu, making a fallback to the Flash Player necessary in our web app.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → In Progress
Daniel Vispo (vaisp) wrote :

In beta 28 on Ubuntu 13.10 now it works ok.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.