VLC plugin crashes browser Firefox

Bug #117640 reported by Robert Persson on 2007-05-29
4
Affects Status Importance Assigned to Milestone
Mozilla Firefox
New
Undecided
Unassigned
VLC media player
Fix Released
Unknown
firefox (Ubuntu)
High
Mozilla Bugs
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

... http://awakeningmind.org crashes firefox

When I go to http://awakeningmind.org, firefox (feisty version) crashes before the page loads.

If I go to the same page in seamonkey, the page does load (along with the annoying music), but the application crashes as soon as I click on any of the links around the big graphic in the centre.

The plugins folder in my seamonkey installation is a symlink to the one in the firefox installation. I don't know if that makes any difference, or even if a plugin is involved at all. I'm also not sure which plugin is supposed to do what because I have ended up with both the vlc and mplayer plugins installed and managing plugins is a real pain.

Related branches

Thank you Robert Persson for submitting this report.

Could you please try to obtain a backtrace by following the instructions on
[1], or upload the crash report that probably was generated during the crash
and that should be located at /var/crash/ to [2].

Please indicate which extensions/plugins do you have enabled; and if this crash
is reproducible describe the steps that lead to it (it is very important for us
to have a test case for each crash).

This will greatly aid us in tracking down your problem.

Thanks in advance.

H. Montoliu

[1] https://wiki.ubuntu.com/MozillaTeam/Bugs
[2] https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/117640/+addcomment

description: updated
Changed in firefox:
assignee: nobody → hmontoliu
importance: Undecided → Medium
status: Unconfirmed → Needs Info

robert@zebedee:~$ ls /usr/lib/firefox/plugins
libflashplayer.so mplayerplug-in-qt.xpt mplayerplug-in-wmp.xpt
libjavaplugin.so mplayerplug-in-rm.so mplayerplug-in.xpt
libunixprintplugin.so mplayerplug-in-rm.xpt nphelix.so
libvlcplugin.so mplayerplug-in.so nphelix.xpt
mplayerplug-in-qt.so mplayerplug-in-wmp.so nppdf.so

crash report attached.

Let me know if you need anything else :)

Alexander Sack (asac) wrote :

can you try to remove your plugins one by one and see if problem goes away?

El mié, 30-05-2007 a las 04:01 +0000, Robert Persson escribió:

> crash report attached.
>
> Let me know if you need anything else :)
>
>
> ** Attachment added: "report from /var/crash"
> http://librarian.launchpad.net/7873433/_usr_lib_firefox_firefox-bin.1000.crash

Thank you Robert for your feedback,

notice that there is something wrong with the crash report, it is only
44Kb when it should be bigger (> 10Mb). Would you please check that the
your local copy is bigger and try to upload it again to [1]. If not,
remove it and try to force a new crash that generate a right report.

Thank you in advance.

[1]
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/117640/+addcomment

--
Hilario J. Montoliu <email address hidden>

I produced another crash, but the crash report (attached) is about the same length as the last.

Interestingly, this time there was a delay of several seconds before the crash. In this time the page loaded, insofar as the graphics appeared to be in the right place, but none of the links were active. Then firefox disappeared in a puff of logic as it did before.

I'll try renaming the plugins folder and restarting in a moment and let you know what happens.

Robert Persson (ireneshusband) wrote :

oops. forgot to attach the crash report.

Robert Persson (ireneshusband) wrote :

Disabled the VLC plugin and everything works properly in both firefox and seamonkey (including the annoying music and a little video in the top left corner).

I also tried re-enabling the vlc plugin and disabling the mplayer one, just to check that one wasn't messing the other up, but it crashed as before.

So it's the VLC plugin that's the problem.

Changed in firefox:
assignee: hmontoliu → mozilla-bugs
importance: Medium → High
Alexander Sack (asac) wrote :

we never saw a dupe on this and most likely its a vlc issue.

Changed in firefox:
status: Incomplete → Invalid
Changed in vlc:
status: New → Confirmed
Changed in vlc:
importance: Undecided → Unknown
status: New → Unknown
Changed in vlc:
status: Unknown → New
Georges (georgeskesseler) wrote :

I confirm this for mozilla-plugin-vlc on intrepid.
Firefox plays once a WAV as sound embed. The second time a WAV should be played, it crashes.

Removing mozilla-plugin-vlc solves the issue. Then the totem plugin is used which works fine.
=> it's a vlc issue.

Changed in vlc:
status: New → Fix Released

Bug #190013 seems to be a duplicate of this bug.

I confirm this bug on intrepid. Using mozilla-plugin-vlc, firefox crashes after display the webpage http://ce-soir-ou-jamais.france3.fr/index-fr.php?page=emission&id_rubrique=662 . Console output displays:

x11 video output error: X11 request 133.19 failed with error code 11:
 BadAlloc (insufficient resources for operation)
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 133 (XVideo)
  Minor opcode of failed request: 19 ()
  Serial number of failed request: 79
  Current serial number in output stream: 80

[1]+ Erreur de segmentation

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.0~rc2-1ubuntu1

---------------
vlc (1.0.0~rc2-1ubuntu1) karmic; urgency=low

  * New upstream version.
  * tighten build-dependencies on libschroedinger-dev, fixes FTBFS.
  * Following bugs have an associated and now closed upstream ticket in
    Launchpad: LP: #281295, #73449, #282567, #117640, #172938, #260918,
    #273685, #275043, #277834, #282394, #290753, #294136, #298925, #304265,
    #309728, #311742, #314038

vlc (1.0.0~rc2-1) experimental; urgency=low

  * New Upstream Release Candidate
    + Closes: #527010, #491441, #508618, #522824
  * Delete patches which were picked from upstream
  * Refresh patches
  * Remove vlc-plugin-esd and vlc-plugin-arts as they have been removed
    by upstream
  * SONAME change for libvlccore
  * Add new symbols for libvlc2
  * Fix static libs compile
  * Use vlc-wrapper manpage from upstream
  * vlc.install: add drawable and screen was renamed x11_screen
  * vlc-nox.install: Add and remove modules added/removed upstream
  * Point out in NEWS the modules renamed or splited
  * Add links to upstream NEWS and co in vlc-nox
  * Version the depedency of libvlcore2 on vlc-data
  * Remove unnecessary "Section:" in debian/control

vlc (0.9.9a-3) unstable; urgency=low

  * Correct typo in 0.9.9a-2 changelog entry
  * Disable more optimization with DEB_BUILD_OPTIONS=noopt
  * Cache the configure test results as we're running configure several
    times
  * Fix building as root
  * Fix the clean target
  * Remove unexistant config options
  * Better check commad line
  * Use all the procs on i386 and amd64
  * Build a version of libvlccore without altivec (Closes: #523035)
  * Fix typo (thanks to Salvatore Bonaccorso)(Closes: #528044)
  * Reword the command line to get full logs in bug/presubj (Closes: #527012)
  * Remove duplicate "extended Settings" entry in context menu
   (Closes: #526603) - thanks to Matt Kraai

 -- Reinhard Tartler <email address hidden> Fri, 05 Jun 2009 12:28:15 +0200

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.