Firefox 18 anti-aliasing does not render correctly some text

Bug #1097763 reported by Fabrizio Narni on 2013-01-09
106
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Some portion of text are not rendering correctly after upgrading to Firefox 18 in Ubuntu 12.04.1 amd64. I've attached a screenshot, please notice the red text on the right.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 18.0+build1-0ubuntu0.12.04.3
ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
Uname: Linux 3.2.0-35-generic x86_64
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu15.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: shiba 2252 F.... pulseaudio
 /dev/snd/controlC0: shiba 2252 F.... pulseaudio
BuildID: 20130107224849
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe028000 irq 22'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,1028020e,00100001'
   Controls : 39
   Simple ctrls : 19
Card1.Amixer.info:
 Card hw:1 'NVidia_1'/'HDA NVidia at 0xfbffc000 irq 16'
   Mixer name : 'Nvidia GPU 15 HDMI/DP'
   Components : 'HDA:10de0015,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
Channel: Unavailable
Date: Wed Jan 9 14:35:43 2013
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120309)
IpRoute:
 default via 192.168.0.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.102 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MarkForUpload: True
PciNetwork:

PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=18.0/20130107224849
RfKill:

RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/15/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.3
dmi.board.name: 0RY206
dmi.board.vendor: Dell Inc.
dmi.board.version: ���
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnDellInc.:bvr1.0.3:bd06/15/2007:svnDellInc.:pnInspiron531:pvr00:rvnDellInc.:rn0RY206:rvr:cvnDellInc.:ct3:cvrChassisVersion:
dmi.product.name: Inspiron 531
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.

Created attachment 699655
grayscale

xp, new profile

http://www.youtube.com/watch?v=SRKf7YLR52Q

it starts normal, after scrolling down, aa goes grayscale

present in 19.0b1

seems to be gone in 20.0a2 (2013-01-08)

confirmed!

windows 7
use hardware acceleration = NO (!)
gfx.font_rendering.cleartype_params.rendering_mode = 2 (!)

on gmail.com ClearType lost colors even without scrolling.
habrahabr.ru/post/107607/ lost colors only after scrolling.

Fabrizio Narni (shiba89) wrote :
description: updated

@CoolCmd: could you confirm it's fixed in FF21 as comment #1 claimed, please.
http://nightly.mozilla.org/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Nick Denry (nick-denry) wrote :

Confirm the same. Is there any workaround?

(In reply to Loic from comment #3)
Yes, in version 21a1 I don't see this bug.

*** Bug 828241 has been marked as a duplicate of this bug. ***

Fabrizio Narni (shiba89) wrote :

The nightly (21.0a1) seems to have the correct rendering.

Riccardo 'c10ud' (c10ud) wrote :

Affects me too, sample (gmail's side panel): http://imgur.com/FN2gT

I first see this in 18.0b4, only with acceleration off.
In 19.0b1, only the scrolling issue occurs, I can't reproduce the Gmail non-scrolling issue.
20.0a2 is fine.

Problem appears in nightly here:
Last good nightly: 2012-12-04
First bad nightly: 2012-12-05

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fa6e55a93b2&tochange=1942b4d64dc8

Fixed in nightly here:
Last good nightly: 2012-12-11
First bad nightly: 2012-12-12

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4dfe323a663d&tochange=634180132e68

Anyone able to confirm that regression range?

*** Bug 828032 has been marked as a duplicate of this bug. ***

Bug 828032 appears to be this same bug on OS X.

For pure entertainment value, go to http://caniuse.com/, give the Search field focus, then scroll the page down just enough to hide the search field… and watch the entire page of text toggle between smoothed and not, every half second. Coincides with the blink rate of the insertion point.

Didn't know if this would help with diagnostics, but it's just too awesome not to share. (Yes, I'm easily entertained.)

Haven't seen this on other pages yet…

*** Bug 829943 has been marked as a duplicate of this bug. ***

I can reproduce the problem twitter attachment 701462 in Firefox18.0 and Firefox 19beta, but not in Aurora20.0a2 and Nightly21.0a1.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/6fa6e55a93b2
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121204 Firefox/20.0a1 ID:20121204030754
Bad:
http://hg.mozilla.org/mozilla-central/rev/1942b4d64dc8
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121205 Firefox/20.0a1 ID:20121205030759
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fa6e55a93b2&tochange=1942b4d64dc8

Regression window(aurora channel)
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/fe20163490ec
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20121207 Firefox/19.0a2 ID:20121207042017
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/e8c2cb8c583f
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20121208 Firefox/19.0a2 ID:20121208042017
Pshlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=fe20163490ec&tochange=e8c2cb8c583f

Regression window(beta channel)
Good:
http://hg.mozilla.org/releases/mozilla-beta/rev/b5fab1c304d2
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20121207 Firefox/18.0 ID:20121207003552
Bad:
http://hg.mozilla.org/releases/mozilla-beta/rev/4e486ec47f47
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20121208 Firefox/18.0 ID:20121208005051
Pshlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=b5fab1c304d2&tochange=4e486ec47f47

in local build
Last Good: 735426e182ac
First Bad: b64693f63118
Triggered by:
b64693f63118 Matt Woodrow — Bug 810302 - When flattening layers together to avoid component alpha, attempt to pick the 'best' active scrolled root to minimize invalidation during scrolling. r=roc, a=lsblakk

And I also confirmed fixed range in comment#6.

I can confirm the patch of Bug 806099 fixes this problem.
(I applied the patch(https://hg.mozilla.org/mozilla-central/rev/1cc90ffcd6b6) of Bug 806099 to the current 19beta cset 2bb8638b277e, and build in locally)

*** Bug 830052 has been marked as a duplicate of this bug. ***

*** Bug 830054 has been marked as a duplicate of this bug. ***

Matt/Roc - we've seen a lot of duplicates of this bug filed for FF18. The user impact here does not seem severe (and there were no reports pre-release), so we're leaning towards fixing for the first time in FF19. Thoughts on the risk of uplifting bug 806099 to FF18?

(In reply to Alex Keybl [:akeybl] from comment #15)
> Matt/Roc - we've seen a lot of duplicates of this bug filed for FF18. The
> user impact here does not seem severe (and there were no reports
> pre-release), so we're leaning towards fixing for the first time in FF19.
> Thoughts on the risk of uplifting bug 806099 to FF18?

The impact may not be severe for the average user or those with certain monitor resolutions, but for those of us doing UI design, it's a bit of a PITA. I for one would love to see this fixed soonest.

But I'm not your flavor of developer so I certainly don't know what it will take to nail it. Thanks to all of you for your great work!

(In reply to Alex Keybl [:akeybl] from comment #15)
> Matt/Roc - we've seen a lot of duplicates of this bug filed for FF18. The
> user impact here does not seem severe (and there were no reports
> pre-release), so we're leaning towards fixing for the first time in FF19.
> Thoughts on the risk of uplifting bug 806099 to FF18?

It is not zero-risk, although the patch has been on trunk for a while and no regressions have been reported other than one isolated performance issue.

We should definitely uplift 806099 to beta though. Requested approval over there.

*** Bug 830198 has been marked as a duplicate of this bug. ***

Created attachment 702235
discrepancy between font display chrome/firefox

Same here.Fonts are very blurry on certain sites (gmail, lequipe.fr) as shown in attachment. Happened since updating to firefox 18. The loss of sharpness is very annoying visually.

*** Bug 830843 has been marked as a duplicate of this bug. ***

DEXTER (mydexterid) wrote :

Affecting me too (twitter screenshot): http://imgur.com/J8MH7
(top: chromium 23, bottom: firefox 18)

Daniil Ivanov (daniil-ivanov) wrote :

I've installed terminus-fonts and then set Terminus as a fonts to be used in Kate. All these resulted in the same colour aberration as in new Firefox 18. So this it is probably something with font rendering of specific fonts, rather than Firefox problem.

This is also an issue on Fedora 18 with Firefox 18, so I'd rather not think it is generally font rendering related. Fonts throughout the system (Gnome 3 / Gnome Shell with Droid Sans as default font) render correctly. The colour halos / aberration is only noticable within Firefox on certain web pages (e.g. FB and G+) in specific areas. Having the (system-wide correctly rendered) Droid Sans font set as default in Firefox with the "allow web pages to use other fonts" check box disabled also shows the incorrect rendering, so I'd rather regard this a Firefox issue.

Egmont Koblinger (egmont-gmail) wrote :

That the bug is about incorrect subpixel rendering, sometimes (on the most typical screen: horizontal RGB) the fonts are rendered approximately as if the screen was horizontal BGR.

The two screenshots linked so far were created on such systems, hence they exactly represent the problem for those looking at them on horizontal RGB panels. Those who have other systems (e.g. vertical monitors) might not get the same feeling for how it looks. It's recommended to examine the second screenshot (good and bad versions under each other) with a pixel-wise magnifying software, such as xmag.

The font looks so bad I just simply couldn't stand it, it really hurt my eyes, I reverted to an older firefox. In my opinion, this is a very severe bug.

Fabrizio Narni (shiba89) wrote :

Seems solved in Firefox 19.0b2

Changed in firefox (Ubuntu):
status: Confirmed → Fix Committed
DEXTER (mydexterid) wrote :

So we don't know what broke it, we don't know if it'll happen again, we know nothing, but you just set it to Fix committed state?

At least could you please write the mozilla's bugnumber here, IF they've fixed it?

Fabrizio Narni (shiba89) wrote :

@DEXTER
You're right, sorry. The bugzilla number is 828206 and is fixed by https://hg.mozilla.org/mozilla-central/rev/1cc90ffcd6b6 (which was originally intended for 806099).

DEXTER (mydexterid) wrote :

@Fabrizio
Thank you!

Just for you to know, Launchpad has a bug about this particular problem:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1097763

Bug 806099 was uplifted to FF19 on Beta. Should be resolved in that version.

Works fine on Firefox 19 beta 4, latest Nightly and Aurora. Can the status be changed to resolved? Or there is something to be added here?

Riccardo 'c10ud' (c10ud) wrote :

http://open.knome.fi/2013/02/05/fuzzy-fonts-in-firefox-18-no-more/

tl;dr
In about:config, edit keys in the following way:

    Set layers.acceleration.force-enabled to true
    Set layers.acceleration.disabled to false

Nick Denry (nick-denry) wrote :

@Riccardo 'c10ud' (c10ud)

Great! Thank's alot.
This settings are work for me.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed

Is it fixed in FF19?

Not for me - I can still see the effect e.g. on G+.

Created attachment 716501
Scrolling native widgets

It is not totally fixed.
Web pages looks good in FF 19 even after the scrolling; but text inside native widgets does not.
If you edit a long text in a field like the one im writing into and then scroll it; the subpixel antialiasing becomes gray after the scroll and after 2 or 3 seconds it automatically gets RGB antialias.
The same thing happens when i scroll the most viewed sites window with the awesome bar; 3 seconds delay.
If this can help to track the issue, i say that it does NOT happens in the history window.

My system is archlinux 32bit and i'm using firefox 19; see the attached video in a large window/fullscreen carefully.

hi, could my problem be related to this bug: https://bbs.archlinux.org/viewtopic.php?id=156456 ?
It was not present in ff17 but is present in ff18 and is still in ff19. It's really weird...

In , Peke (peke) wrote :

I'm Confirming this using FF19 Final and FF20b1 But I have found that for now it happens only if HW accel is enabled.

Additionally If I Zoom In/Out page (CTRL+Mouse Scroll) page is rendered correctly, looks like only default zoom is affected.

For Now I'm turning of HW Accel.

Haven't tested nightly for now.
As reference to Above archlinux page I'm using ATi HD 4890 and latest ATi Legacy Drivers 13.1

As peke said in comment #30: It's fixed in Firefox 19 (thanks!) but it can still happen when using hardware acceleration.

I turned on layers.acceleration.force-enabled today (Firefox 20 / Ubuntu 12.10 64-bit / nvidia 310.14) and started noticing the issue again.

I can see it clearly in gmail, and the strange thing is, that it's temporary: font hinting is strange when scrolling, and after you stop, in 2-3 seconds it jumps to being ok. I'm now attempting to record a screencast to show this.

Ah, my bad! No need to screencast, the issue is exactly what kokoko3k said in comment #28, but it doesn't need to be on a native widget (I see it on gmail).

I filed a bugreport for comment #29 https://bugzilla.mozilla.org/show_bug.cgi?id=847962
I don't know, maybe it's related..

@Comment #33: I'm not sure, I just tried to reproduce your issue and couldn't.
Have you tried it on another machine, just to be sure?

I did, it happens on both of my computers and even on Windows 7 (but isn't always *that* noticible). But maybe we should discuss this in the appropriate bugreport :)

In , Peke (peke) wrote :

Just note to my comment #30 that after upgrading to ATi Radeon HD 7950 and normal 13.1 driver I have no issues anymore, also FF version now is 19.0.2 will keep if issue reacure

This bug refers to an issue that could only occur *without* hardware acceleration.

Hardware acceleration is currently incomplete on linux, and is disabled by default for all users.

You're probably seeing bug 777170, which is because the component alpha (sub-pixel alpha text) support isn't completed.

Changed in firefox:
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) on 2014-03-07
Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.