Crash when switching apps back to Firefox (may be Firebug related)

Bug #1035305 reported by Stuart Langridge on 2012-08-10
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Firebug
Unknown
Unknown
firefox (Ubuntu)
Critical
Chris Coulson
Natty
Critical
Unassigned
Oneiric
Critical
Unassigned
Precise
Critical
Unassigned
Quantal
Critical
Chris Coulson

Bug Description

When switching apps (with alt-tab, or clicking the Launcher) *to* Firefox, Firefox crashes.

This does not occur for a while after reboot. However, once the first crash has happened, a restarted Firefox will reliably continue to crash every time it is switched *to*. So, starting Firefox works; restoring the previous session works; navigating around, choosing different tabs, adding new tabs works. Switching away from Firefox works. However, switching back to Firefox causes it to crash every time.

A reboot cures the problem (until it starts again).

Crash report sent to Mozilla (about a zillion times) and should be therefore attached to this bug by apport, but if not: https://crash-stats.mozilla.com/report/index/bp-dbbaef36-287e-4e2b-85bd-4ef8e2120810

Disabling Firebug seems to have cured the problem.

[SRU justification]
Looking through Mozilla's crash database, we're currently responsible for about 1500 crash reports per week (taking in to account the different variations of this trace), second only to Flash

See some comments from our very unhappy users -

https://crash-stats.mozilla.com/report/index/03c68f08-14ed-42ab-bb12-db4212120811 :
"browser keeps crashing as soon as i run it. cant do anything"

https://crash-stats.mozilla.com/report/index/fc95cd37-cdc9-458b-b373-d6a2d2120815 :
"Firefox keeps crashing everytime I open it, unless I open in safe mode."

https://crash-stats.mozilla.com/report/index/010be177-7e91-446d-b823-845442120813 :
"Just starting gives me a crash"

https://crash-stats.mozilla.com/report/index/3b04c9ab-0884-4205-a301-ca4132120811 : "Again I just start Firefox and it does not stay for one second, before he kill himself..."

https://crash-stats.mozilla.com/report/index/c8ee0432-befe-427e-bdad-c67b62120811 :
"This happened at startup. The firefox window didn't ever appear yet."

https://crash-stats.mozilla.com/report/index/8d608496-2b03-48c8-822e-1b5762120808 :
"I think it is problem with any extension and the fucking menu of Ubuntu."

https://crash-stats.mozilla.com/report/index/febca548-7260-4ded-a5ee-7ba172120810 :
"I just started this crap browser..."

https://crash-stats.mozilla.com/report/index/50ff5801-0660-4172-bd96-5d8542120810 :
"Fucking cock, firefox sucks as usual."

https://crash-stats.mozilla.com/report/index/feb0791f-98e9-484c-a74b-074a32120810 :
"It's like an endless loop of shit.

https://crash-stats.mozilla.com/report/index/7eaf6c36-1479-44cf-8b1c-7924a2120810 :
"now it's enaugh!! fuck firefox - i take google chrome "

https://crash-stats.mozilla.com/report/index/bf6a81cc-ca2b-4399-9fdf-5cae82120812 :
"it's now not opening."

[Test case]
- Update Firefox, perform whatever steps were necessary to trigger the crash before (this could be opening the HUD, opening the menus, switching focus to Firefox or just starting it - this really depends on which way the wind is blowing) and verify it doesn't crash

[Regression Potential]
- None, it's just a null pointer check and another small change to ensure that menus are disposed of fully to avoid leaving duplicated (and orphaned) entries in the Firebug menu

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: firefox 15.0~b2+build1-0ubuntu0.12.04.1~mfn1
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: aquarius 2505 F.... pulseaudio
BuildID: 20120726160848
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e00000 irq 49'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa5003,00100000 HDA:80862805,17aa5003,00100000'
   Controls : 25
   Simple ctrls : 12
Channel: Unavailable
CheckboxSubmission: 4d186c1dd89d3ba4cb89f5ee55713686
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Fri Aug 10 14:13:22 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111211)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.153 metric 2
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
MostRecentCrashID: bp-dbbaef36-287e-4e2b-85bd-4ef8e2120810
PrefErrors: Unexpected character 'g' before close parenthesis @ [Profile]/extensions/{e4a8a97b-f2ed-450b-b12d-ee082ba24781}/defaults/preferences/greasemonkey.js:4
PrefSources: prefs.js
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=15.0/20120726160848 (In use)
RelatedPackageVersions:
 google-talkplugin 3.2.4.0-1
 rhythmbox-mozilla 2.96-0ubuntu4.1
 totem-mozilla 3.0.1-0ubuntu21
RunningIncompatibleAddons: FalseSourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/21/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 56CN38WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U300s
dmi.board.vendor: LENOVO
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad U300s
dmi.modalias: dmi:bvnLENOVO:bvr56CN38WW:bd11/21/2011:svnLENOVO:pn1080:pvrLenovoIdeaPadU300s:rvnLENOVO:rnU300s:rvr1.0:cvnLENOVO:ct10:cvrLenovoIdeaPadU300s:
dmi.product.name: 1080
dmi.product.version: Lenovo IdeaPad U300s
dmi.sys.vendor: LENOVO

Stuart Langridge (sil) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

I'm hitting this now, since I got the Firebug 1.10.2 update

Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Critical
status: Confirmed → Triaged
deezer (deezerdeezer) wrote :

I am seeing this in Precise 12.04 with Firebug as well. Disabling Firebug prevents it from happening; enabling Firebug crashes Firefox every time on start

Changed in firefox (Ubuntu Quantal):
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

I've got fixes for the crashes that people see, but it also requires a Firebug change to make the menus work correctly afterwards (which should be in Firebug 1.10.3 - see the upstream bug)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 15.0~b4+build1-0ubuntu1

---------------
firefox (15.0~b4+build1-0ubuntu1) quantal; urgency=low

  * New upstream release from the beta channel (FIREFOX_15_0b4_BUILD1)

  * Update globalmenu-extension to 3.4 prerelease r435
    + Drop the edit UI workarounds
    + Fixes for LP: #1035305 - Crash when switching apps back to Firefox
      with Firebug installed
      - Keep the menu we export in sync with the document tree all of the
        time, rather than only when the menus are on screen. The HUD likes to
        open submenus without opening any of its ancestors, which can result in
        us handling events on menu nodes that are no longer in a document
        if an ancestor responds to a bubbled-up event by removing its
        children
      - Ensure we always null check the result of nsIDocument::GetCurrentDoc
    + When tearing down a menu, make sure that we empty out our DbusmenuMenuitem
      in case the parent reuses that item for another menu. Fixes a memory leak
      and an issue where Firebug menu items are duplicated indefinitely each
      time a menu is opened
 -- Chris Coulson <email address hidden> Sat, 11 Aug 2012 01:24:44 +0100

Changed in firefox (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in firefox (Ubuntu Oneiric):
importance: Undecided → Critical
Changed in firefox (Ubuntu Precise):
importance: Undecided → Critical
Changed in firefox (Ubuntu Natty):
importance: Undecided → Critical
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu Natty):
status: New → Confirmed
Changed in firefox (Ubuntu Oneiric):
status: New → Confirmed
Changed in firefox (Ubuntu Precise):
status: New → Confirmed

Hello Stuart, or anyone else affected,

Accepted firefox into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/firefox/14.0.1+build1-0ubuntu0.12.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in firefox (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Stuart, or anyone else affected,

Accepted firefox into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/firefox/14.0.1+build1-0ubuntu0.11.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in firefox (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in firefox (Ubuntu Natty):
status: Confirmed → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Stuart, or anyone else affected,

Accepted firefox into natty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/firefox/14.0.1+build1-0ubuntu0.11.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

SRU verification for Precise:
I have reproduced the problem with firefox 14.0.1+build1-0ubuntu0.12.04.1 in precise-updates and have verified that the version of firefox 14.0.1+build1-0ubuntu0.12.04.3 in -proposed fixes the issue.

I installed firebug, launched firefox, opened various application on different workspaces and switched between apps and workspaces.
With firefox from -updates it crashed after a few switched, with firefox from -proposed it didn't crash after numerous switches.

Marking as verification-done

tags: added: verification-done-precise
Chris Coulson (chrisccoulson) wrote :

Can anyone else verify this for the other releases? This really is quite urgent, we've left thousands of users across all releases completely unable to start their browser for 17 days now....

Ketil (ketil-froyn) wrote :

I'm running Ubuntu 12.04 with all updates applied, and I got this bug today. I fixed it by disabling the Global Menu Bar
Integration plugin.

Launchpad Janitor (janitor) wrote :
Download full text (7.1 KiB)

This bug was fixed in the package firefox - 15.0+build1-0ubuntu0.11.10.1

---------------
firefox (15.0+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (FIREFOX_15_0_BUILD1)
    - see LP: #1041620 for USN information

  * Update globalmenu-extension to 3.4
    + Drop the edit UI workarounds
    + Fixes for LP: #1035305 - Crash when switching apps back to Firefox
      with Firebug installed
      - Keep the menu we export in sync with the document tree all of the
        time, rather than only when the menus are on screen. The HUD likes to
        open submenus without opening any of its ancestors, which can result in
        us handling events on menu nodes that are no longer in a document
        if an ancestor responds to a bubbled-up event by removing its
        children
      - Ensure we always null check the result of nsIDocument::GetCurrentDoc
    + When tearing down a menu, make sure that we empty out our DbusmenuMenuitem
      in case the parent reuses that item for another menu. Fixes a memory leak
      and an issue where Firebug menu items are duplicated indefinitely each
      time a menu is opened
    + Fixes for LP: #1025011 - HUD search crashes Firefox when Firebug
      is installed
      - Provide our own binding for menupopup nodes which derives from the
        default binding and makes the "state" property work as if there
        were a frame
      - Make all menu nodes reference counted, and hold a strong ref when
        dispatching events, in case the event results in the removal of menu
        nodes
    + Fix LP: #813775 - Hitting an assertion in dbusmenu
    + Fix LP: #861565 - No buttons in the "Show All Bookmarks" dialog
    + Fix LP: #775305 - An empty menu appears when FFChrome is installed
    + Add a small delay when opening the menu with the keyboard, so that
      the additional items are added before the menu appears. Fixes an
      issue where keyboard focus isn't on the first item when opening the
      history menu with the keyboard
  * Add Acholi to the locale blacklist
  * Separate the package name from the application name in various places.
    This enables us to change the package name without having to modify the
    application or packaging (eg, to allow us to provide official branded
    versions of Firefox ESR using the package name "firefox-esr")
    - update debian/README.Debian.in
    - update debian/apport/source_firefox.py.in
    - update debian/build/get-orig-source.mk
    - update debian/control{,.in}
    - update debian/control.langpacks
    - update debian/control.langpacks.unavail
    - update debian/firefox-locale.preinst.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.postinst.in
    - update debian/firefox.postrm.in
    - update debian/firefox.preinst.in
    - update debian/firefox.sh.in
    - remove debian/patches/change-moz-app-name.patch
    - update debian/patches/series
    - update debian/rules
    - update debian/usr.bin.firefox.apparmor.*
  * Move parts of debian/rules that can be shared with Thunderbird to a
    new, common fi...

Read more...

Changed in firefox (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.1 KiB)

This bug was fixed in the package firefox - 15.0+build1-0ubuntu0.12.04.1

---------------
firefox (15.0+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_15_0_BUILD1)
    - see LP: #1041620 for USN information

  * Update globalmenu-extension to 3.4
    + Drop the edit UI workarounds
    + Fixes for LP: #1035305 - Crash when switching apps back to Firefox
      with Firebug installed
      - Keep the menu we export in sync with the document tree all of the
        time, rather than only when the menus are on screen. The HUD likes to
        open submenus without opening any of its ancestors, which can result in
        us handling events on menu nodes that are no longer in a document
        if an ancestor responds to a bubbled-up event by removing its
        children
      - Ensure we always null check the result of nsIDocument::GetCurrentDoc
    + When tearing down a menu, make sure that we empty out our DbusmenuMenuitem
      in case the parent reuses that item for another menu. Fixes a memory leak
      and an issue where Firebug menu items are duplicated indefinitely each
      time a menu is opened
    + Fixes for LP: #1025011 - HUD search crashes Firefox when Firebug
      is installed
      - Provide our own binding for menupopup nodes which derives from the
        default binding and makes the "state" property work as if there
        were a frame
      - Make all menu nodes reference counted, and hold a strong ref when
        dispatching events, in case the event results in the removal of menu
        nodes
    + Fix LP: #813775 - Hitting an assertion in dbusmenu
    + Fix LP: #861565 - No buttons in the "Show All Bookmarks" dialog
    + Fix LP: #775305 - An empty menu appears when FFChrome is installed
    + Add a small delay when opening the menu with the keyboard, so that
      the additional items are added before the menu appears. Fixes an
      issue where keyboard focus isn't on the first item when opening the
      history menu with the keyboard
  * Add Acholi to the locale blacklist
  * Separate the package name from the application name in various places.
    This enables us to change the package name without having to modify the
    application or packaging (eg, to allow us to provide official branded
    versions of Firefox ESR using the package name "firefox-esr")
    - update debian/README.Debian.in
    - update debian/apport/source_firefox.py.in
    - update debian/build/get-orig-source.mk
    - update debian/control{,.in}
    - update debian/control.langpacks
    - update debian/control.langpacks.unavail
    - update debian/firefox-locale.preinst.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.postinst.in
    - update debian/firefox.postrm.in
    - update debian/firefox.preinst.in
    - update debian/firefox.sh.in
    - remove debian/patches/change-moz-app-name.patch
    - update debian/patches/series
    - update debian/rules
    - update debian/usr.bin.firefox.apparmor.*
  * Move parts of debian/rules that can be shared with Thunderbird to a
    new, common fi...

Read more...

Changed in firefox (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.1 KiB)

This bug was fixed in the package firefox - 15.0+build1-0ubuntu0.11.04.2

---------------
firefox (15.0+build1-0ubuntu0.11.04.2) natty-security; urgency=low

  * New upstream stable release (FIREFOX_15_0_BUILD1)
    - see LP: #1041620 for USN information

  * Update globalmenu-extension to 3.4.1
    + Drop the edit UI workarounds
    + Fixes for LP: #1035305 - Crash when switching apps back to Firefox
      with Firebug installed
      - Keep the menu we export in sync with the document tree all of the
        time, rather than only when the menus are on screen. The HUD likes to
        open submenus without opening any of its ancestors, which can result in
        us handling events on menu nodes that are no longer in a document
        if an ancestor responds to a bubbled-up event by removing its
        children
      - Ensure we always null check the result of nsIDocument::GetCurrentDoc
    + When tearing down a menu, make sure that we empty out our DbusmenuMenuitem
      in case the parent reuses that item for another menu. Fixes a memory leak
      and an issue where Firebug menu items are duplicated indefinitely each
      time a menu is opened
    + Fixes for LP: #1025011 - HUD search crashes Firefox when Firebug
      is installed
      - Provide our own binding for menupopup nodes which derives from the
        default binding and makes the "state" property work as if there
        were a frame
      - Make all menu nodes reference counted, and hold a strong ref when
        dispatching events, in case the event results in the removal of menu
        nodes
    + Fix LP: #813775 - Hitting an assertion in dbusmenu
    + Fix LP: #861565 - No buttons in the "Show All Bookmarks" dialog
    + Fix LP: #775305 - An empty menu appears when FFChrome is installed
    + Add a small delay when opening the menu with the keyboard, so that
      the additional items are added before the menu appears. Fixes an
      issue where keyboard focus isn't on the first item when opening the
      history menu with the keyboard
  * Add Acholi to the locale blacklist
  * Separate the package name from the application name in various places.
    This enables us to change the package name without having to modify the
    application or packaging (eg, to allow us to provide official branded
    versions of Firefox ESR using the package name "firefox-esr")
    - update debian/README.Debian.in
    - update debian/apport/source_firefox.py.in
    - update debian/build/get-orig-source.mk
    - update debian/control{,.in}
    - update debian/control.langpacks
    - update debian/control.langpacks.unavail
    - update debian/firefox-locale.preinst.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.postinst.in
    - update debian/firefox.postrm.in
    - update debian/firefox.preinst.in
    - update debian/firefox.sh.in
    - remove debian/patches/change-moz-app-name.patch
    - update debian/patches/series
    - update debian/rules
    - update debian/usr.bin.firefox.apparmor.*
  * Move parts of debian/rules that can be shared with Thunderbird to a
    new, common fi...

Read more...

Changed in firefox (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.