Most recent URL dropdown not updating

Bug #499231 reported by AD5XJ on 2009-12-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Low
firefox-3.5 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.5

After storing 12 URL locations from history, the dropdown no longer updates the most frequently used URL's.

ProblemType: Bug
Architecture: i386
Date: Mon Dec 21 14:37:24 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: firefox-3.5 3.5.6+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-16-generic i686

AD5XJ (ad5xj) wrote :
Dave Walker (dogatemycomputer) wrote :

AD5XJ:

I just fired up a fresh installation of Kubuntu with Firefox and I cannot reproduce the problem. The steps I took to recreate the problem are listed below.

1 - Installed Firefox
2 - Created bookmarks to the following sites:

www.cnn.com
www.gmail.com
www.yahoo.com
www.msnbc.com
wwww.news.com
wwww.craigslist.org
www.coke.com
www.pepsi.com
www.whitehouse.gov
www.userfriendly.org
www.ubuntu.com
www.kubuntu.org
www.debian.org
www.nytimes.com
www.wsj.com

3 - Pressed CTRL-H to open the HISTORY tab.
4 - Clicked VIEW from the pulldown and selected "BY MOST VISITED"
5 - Began clicking on the sites and using a checklist (so I was sure how many times I clicked on each link) I began to tally what link should appear at the top of the list.
6 - The link clicked the most appeared at the top of the list.

(Please note I purposely mis-spelled Craigslist and occasionally typed the link into the address bar in hopes maybe there was a combination of sites that would cause the problem you describe.)

I did check my history found on my primary machine. I do not like the fact that

https://mail.google.com/mail/?shva=1#inbox

and

https://mail.google.com/mail/?zx=1sbl7njp5y8jp&shva=1#inbox

.. are considered different sites but I am not convinced this is a bug either. I think it just qualifies as poor design.

Is there something I am missing?

Thank you for taking the time to report this bug and helping to make Ubuntu better!

Changed in firefox-3.5 (Ubuntu):
status: New → Incomplete
AD5XJ (ad5xj) wrote :

I don't think I was completely clear. The history listings do sort in any order I select. However, I was referring to the most visited URL list on the address bar - not the history window. I have not found a way to update the items that appear in the dropdown list on the address bar. I hope this helps.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6

I am reporting this bug on behalf of:

https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/499231

Bug Description

Binary package hint: firefox-3.5

After storing 12 URL locations from history, the dropdown no longer updates the most frequently used URL's.

ProblemType: Bug
Architecture: i386
Date: Mon Dec 21 14:37:24 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: firefox-3.5 3.5.6+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-16-generic i686

Reproducible: Always

Steps to Reproduce:
1. Visit 12+ sites
2. Open History tab then sort by Most Visited
3. The history sort does not match the pulldown history

Actual Results:
The location bar pulldown fails to update with the most frequently visited location.

Expected Results:
The location pulldown should sort by most visited location or the most recently visited list of locations.

This may not be a bug but I also cannot find any documentation that describes what *should* appear in the location bar pulldown.

Dave Walker (dogatemycomputer) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:

https://bugzilla.mozilla.org/show_bug.cgi?id=537318

Changed in firefox-3.5 (Ubuntu):
status: Incomplete → Invalid
Dave Walker (dogatemycomputer) wrote :

AD5XJ:

I am sorry for not responding sooner. I was ill.

I cannot confirm this particular problem but I will agree the location bar is poorly documented so i'm not really sure what should appear in the pulldown AND what what does appear in the pulldown also does not appear to be very intuitive. For example.. I visit Gmail several times/day but appears #3 in the list while I have not visited Ebay in weeks but that appears #1 in the list.

Please be sure to update the bug with your comments so you are included in the conversation. Let me know if there is anything more I can do for you.

Changed in firefox:
status: Unknown → New

*** This bug has been marked as a duplicate of bug 537130 ***

Micah Gersten (micahg) on 2009-12-31
Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Changed in firefox:
status: New → Invalid
Changed in firefox:
importance: Unknown → Low
status: Invalid → Unknown
Changed in firefox:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.