Comment 22 for bug 486284

(From update of attachment 390343)
sr? for API change, this was added in 3.6 so there's no compat issues.