[MASTER] chrome error when viewing untrusted https site using firefox with some locales

Bug #429835 reported by Jan Claeys on 2009-09-15
180
This bug affects 36 people
Affects Status Importance Assigned to Milestone
langpack-o-matic
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by João Pinto
Karmic
Undecided
Unassigned
firefox-3.5 (Ubuntu)
High
Alexander Sack
Nominated for Lucid by João Pinto
Karmic
High
Alexander Sack

Bug Description

No more "me too" PLEASE !

/////////////////////

Binary package hint: firefox-3.5

When I use Firefox 3.5 in Dutch on karmic, I get a chrome error when accessing a site with an "untrusted" SSL certificate:

XML-parsefout: ongedefinieerde entiteit
Locatie: jar:file:///usr/lib/firefox-3.5.3/chrome/browser.jar!/content/browser/certerror/aboutCertError.xhtml
Regelnummer 241, kolom 34: <p id="introContentP1">&certerror.introPara1;</p>
---------------------------------^

(For those who don't understand Dutch, the message says that there is an XML parsing error because the "&certerror.introPara1;" entity found on line 241, column 34 is not defined.)

This error is not present when I start Firefox with LANG=C, so I guess the bug is in the translations somewhere...

David Planella (dpm) on 2009-09-15
Changed in firefox-3.5 (Ubuntu):
assignee: nobody → Ubuntu Dutch Translators (ubuntu-l10n-nl)
tags: added: l10n
Micah Gersten (micahg) wrote :

Triaged in Firefox awaiting review of translation team.

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → Triaged
tags: added: xpipo
Jan Claeys (janc) wrote :

Seems like all(?) translations are missing the following entry on top, so this is no translator issue:

<!ENTITY % brandDTD
    SYSTEM "chrome://branding/locale/brand.dtd">
  %brandDTD;

Changed in firefox-3.5 (Ubuntu):
assignee: Ubuntu Dutch Translators (ubuntu-l10n-nl) → Alexander Sack (asac)
David Planella (dpm) on 2009-09-15
tags: added: i18n
removed: l10n
Michal Matyska (michal-matyska) wrote :

The same happened to me with Czech translation....

Chyba parsování XML: Nedefinovaná entita
Adresa: jar:file:///usr/lib/firefox-3.5.3/chrome/browser.jar!/content/browser/certerror/aboutCertError.xhtml
Číslo řádku 241, sloupec 34: <p id="introContentP1">&certerror.introPara1;</p>
---------------------------------^

Micah Gersten (micahg) on 2009-09-15
summary: - chrome error when using firefox in Dutch ('nl', 'nl_NL', 'nl_BE') locale
- on karmic
+ chrome error when using firefox with non en-US locale on karmic

Moving to langpack-o-matic for triage.

affects: ubuntu-translations → langpack-o-matic
summary: - chrome error when using firefox with non en-US locale on karmic
+ [MASTER] chrome error when using firefox with non en-US locale on karmic
tags: added: metabug

I have the same error in german firefox:

XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: jar:file:///usr/lib/firefox-3.5.3/chrome/browser.jar!/content/browser/certerror/aboutCertError.xhtml
Zeile Nr. 241, Spalte 34: <p id="introContentP1">&certerror.introPara1;</p>
---------------------------------^

is there any workaround? in the moment we are using epiphany to access the firewall-system, but thats a disappointing situation because firefox is the standard browser...

Micah Gersten (micahg) on 2009-09-21
summary: - [MASTER] chrome error when using firefox with non en-US locale on karmic
+ [MASTER] chrome error when viewing untrusted https site using firefox
+ with non en-US locale on karmic

Error also occur, when going to "about:mozilla" (german locale).

XML-Verarbeitungsfehler: nicht wohlgeformt
Adresse: jar:file:///usr/lib/xulrunner-1.9.1.3/chrome/toolkit.jar!/content/global/mozilla.xhtml
Zeile Nr. 90, Spalte 1:
&mozilla.quote;
^

(xml parsing error: not well formed)

Jan Claeys (janc) wrote :

@P-Baumgart: there is a workaround, start Firefox from a terminal as follows (or create a little shell script that starts firefox like that):

LANG=C firefox

That will run Firefox in US English (the problem is with the translations).

@sunblade: that is not the same error of course, but maybe it's caused by the same or a similar bug in the system that converts Launchpad translations to Mozilla format translations...

laures (m-vovcu) wrote :

Hi,

I had the same problem (Karmic, german Firefox). I started firefox as Claeys mentioned, accepted the untrusted certificate, closed firefox and started it again (just "firefox", no "LANG=C firefox") and voila, it works.

Seems like the problem occurs only in case the certificate isn't accepted already.

Ciso (cisoprogressivo) wrote :

Same here with italian translation :S

Alexander Sack (asac) wrote :

cannot be fixed for beta as it involves a complete re-creation of all langpacks. will get it fixed right after beta.

Changed in langpack-o-matic:
status: New → Confirmed
Valombre (valombre-d) wrote :

Hi,
same problem here for french locale testing karmic Beta.

v0v04ka (v0v04ka) wrote :

Russian locale the same.
Karmic Beta clear setup.

Aether (aetherbeta) wrote :

Spanish does not work too...
Firefox manage to start with Jan's method...
Testing Karmic from online update.

Răzvan Sandu (razvan-sandu) wrote :

This bug affects me too...

I've tried to access a Linksys WAP4410N's https interface from Firefox, after I've upgraded my Ubuntu 9.04 to 9.10 beta.

Interface is in Romanian.

And I've got this:

Eroare la analiza XML: entitate nedefinită
Adresă: jar:file:///usr/lib/firefox-3.5.3/chrome/browser.jar!/content/browser/certerror/aboutCertError.xhtml
Număr linie 241, coloană 34: <p id="introContentP1">&certerror.introPara1;</p>
---------------------------------^

Mathieu Marquer (slasher-fun) wrote :

Please, if you just want to see "me too", there is a "this bug affects me too" option on https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/429835/+affectsmetoo

Thank you.

description: updated
Peter (pesto) wrote :

This bug is similar to #424746

Martin Pitt (pitti) wrote :

Alex says that this was a bug in the po2xpi script in langpack-o-matic. The bug was fixed, new langpacks will be uploaded today.

Changed in firefox-3.5 (Ubuntu Karmic):
status: Triaged → Fix Committed
Alexander Sack (asac) wrote :

should be fixed released. ww have bug 437545 open for the still existing langpack-o-matic/po2xpi bug wrt devmode. so invalidating that part of this bug too.

Changed in firefox-3.5 (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in langpack-o-matic:
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Reopening (sorry for reopening for both langpack-o-matic and firefox, since unsure). Still happens with Finnish, even on a fresh install, eg. when opening https://nm.debian.org/:

---
XML-jäsennysvirhe: määrittelemätön entiteetti
URL: jar:file:///usr/lib/firefox-3.5.3/chrome/browser.jar!/content/browser/certerror/aboutCertError.xhtml
Rivinumero 241, sarake 34: <p id="introContentP1">&certerror.introPara1;</p>
---------------------------------^

Changed in firefox-3.5 (Ubuntu Karmic):
status: Fix Released → Confirmed
Changed in langpack-o-matic:
status: Fix Released → Confirmed
Mathieu Marquer (slasher-fun) wrote :

Works fine with French language at least.

Mathieu Marquer wrote:

> Works fine with French language at least.

And with Croatian...

Changed title unless there are other locales with similar error still. Anyway, the error message is the same as in the original bug report.

summary: [MASTER] chrome error when viewing untrusted https site using firefox
- with non en-US locale on karmic
+ with fi-FI on karmic
Alexander Sack (asac) wrote :

finnish is struck by the still open langpack-o-matic part of this bug because its one of the few whitelisted for po2xpi ... i removed fi from whitelist for now in 9.10 ... once its fixed we will enable it again.

Changed in firefox-3.5 (Ubuntu Karmic):
status: Confirmed → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Kind thanks for the fix, whenever it will be released.

Tuukka Hastrup (tuukkah) wrote :

This seems to be fixed now. Thanks!

Alexander Sack (asac) on 2009-10-26
Changed in firefox-3.5 (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing

Same problem for Occitan.

João Pinto (joaopinto) wrote :

The problem is present on lucid's firefox, I am experiencing with LANG=pt_PT.UTF-8 .

summary: [MASTER] chrome error when viewing untrusted https site using firefox
- with fi-FI on karmic
+ with some locales

I have the problem with firefox-3.5.6 on lucid with cs_CZ.UTF-8 locales.
As workaround I can start firefox with C or en_US.UTF-8 locales, which shows expected page about certificate issue.

Arne Goetje (arnegoetje) on 2010-03-05
Changed in langpack-o-matic:
status: Confirmed → Fix Released
Jeremy Nickurak (nickurak) wrote :

Getting this with firefox 3.6.12+build1+nobinonly-0ubuntu0.10.04.1 from lucid-updates.

Jeremy Nickurak (nickurak) wrote :

Should add, this is with en_CA.UTF-8

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu Karmic):
status: New → Confirmed
Changed in firefox (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

karmic has seen the end of its life and is no longer receiving any updates. Marking the karmic task for this ticket as "Won't Fix".

Changed in firefox (Ubuntu Karmic):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers