Can't leave fullscreen, even after firefox restart

Bug #267857 reported by David Hugh-Jones on 2008-09-08
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Medium
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.0

1. after choosing View->Fullscreen, I have no way to leave fullscreen mode using the mouse. The menu bar is hidden. There is a grey strip of chrome at the top of the screen, and if I move the mouse there, the strip flickers, but I don't get the menu bar back. This problem just bit me rather badly - I had used System->Keyboard Shortcuts to assign F11 to "Move between windows with popup". As F11 usually toggles Firefox fullscreen, I now had no way to leave fullscreen mode without closing firefox.

2.... And, when I restarted firefox, I was back in fullscreen mode - though this time, the menu bar was present. Now if I choose View->Fullscreen again, instead of returning me to normal mode, it gets rid of the menu bar again!

After removing my unwise shortcut, I was able to return from fullscreen mode using F11. (So I won't be trapped with fullscreen mode forever.) But it would be nice if e.g. the right-click menu had a "show menubar" or "out of fullscreen" item.

ProblemType: Bug
Architecture: i386
Date: Mon Sep 8 19:37:38 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-2-generic i686

Aren't you just seeing the "auto-hide" feature from bug 240859? Does the address bar reappear if you move your mouse to the top edge of the screen? You can turn "auto-hide" off by right clicking the toolbar in this state.

I'm not sure it's a good idea to default "auto-hide" to on, it's confusing.

You moved the address bar to a bar that is not shown by default in fullscreen. Autohide didn't cause this, this has always been a problem.

Not sure how to fix this though. Maybe the first time we enter fullscreen we can find the toolbar parent of the address bar and dynamically add the "fullscreentoolbar" attribute to it?

Yeah, it's a bit of an odd thing I realise, I don't expect it to be fixed soon.

This problem became an issue when I had a friend trying Firefox 3 Beta 4 on Vista and he didn't like the way things were positions and finally decided to move them all to the menu bar (File, Edit, etc..), I then noticed the autohide feature hadn't made it to Beta 4, he tried full screen and found it a very weird experience.

Oh, duh. I missed step 1 in your original steps to reproduce.

Binary package hint: firefox-3.0

1. after choosing View->Fullscreen, I have no way to leave fullscreen mode using the mouse. The menu bar is hidden. There is a grey strip of chrome at the top of the screen, and if I move the mouse there, the strip flickers, but I don't get the menu bar back. This problem just bit me rather badly - I had used System->Keyboard Shortcuts to assign F11 to "Move between windows with popup". As F11 usually toggles Firefox fullscreen, I now had no way to leave fullscreen mode without closing firefox.

2.... And, when I restarted firefox, I was back in fullscreen mode - though this time, the menu bar was present. Now if I choose View->Fullscreen again, instead of returning me to normal mode, it gets rid of the menu bar again!

After removing my unwise shortcut, I was able to return from fullscreen mode using F11. (So I won't be trapped with fullscreen mode forever.) But it would be nice if e.g. the right-click menu had a "show menubar" or "out of fullscreen" item.

ProblemType: Bug
Architecture: i386
Date: Mon Sep 8 19:37:38 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-2-generic i686

Update: dammit! even after leaving fullscreen mode and quitting, firefox still restarts in fullscreen!

Dimitrios Symeonidis (azimout) wrote :

when in full-screen mode in firefox, if you bring your mouse pointer to the top of the screen, you should see the "navigation toolbar". there, on the right, you should see three buttons: minimize, restore and close. restore should bring you out of full-screen mode...

That doesn't work for me, see original bug description.

Dimitrios Symeonidis (azimout) wrote :

hehe, i like your using google to add queues to your video :-)

now seriously, your problem is basically that the navigation bar (not menu bar) does show in full-screen mode..

could it be your graphics? do you have special effects enabled? try disabling them and see if you can see the navigation bar in full screen

No, I tried setting Visual Effects to "None" in System->Appearance,
and it didn't make any difference. I also disabled all my firefox
extensions apart from the Ubuntu extension, but this did not make any
difference either.

Dimitrios Symeonidis (azimout) wrote :

david, can you upgrade to the latest version of firefox (3.0.3) and tell me if the problem still exists?

I have this version already, and the bug still exists. I have also
figured out the cause: I have no navigation toolbar, only the
bookmarks toolbar and some customizations to put the location bar and
buttons into my menu bar. (See my screencast.) If I make the
navigation toolbar visible, then this problem goes away: the
navigation toolbar pops up when I go to the top of the screen.

Dimitrios Symeonidis (azimout) wrote :

marking the bug as invalid. the problem was due to the user having hidden the navigation toolbar

Changed in firefox-3.0:
status: New → Invalid

hey, how does that make the bug invalid? being unable to exit
fullscreen is still a bug, and this shouldn't depend on my
configuration.

Dimitrios Symeonidis (azimout) wrote :

david, there are 2 ways to exit full screen mode: pressing f11 and clicking on the button in the navigation bar.

if you replace the keyboard shortcut and hide the bar, of course you will not be able to do the things that these options were providing you.

this is the designed behaviour. not a bug.

Well... I won't argue the toss, I still think that hiding the navbar
should not unexpectedly screw up fullscreen mode, but I accept it is
not the world's highest priority bug.

Michael Rooney (mrooney) wrote :

Since it only presents a problem if you explicitly map over the standard F11 shortcut, I agree it isn't a huge deal. However David, if you want to file a feature request upstream for another exit strategy (say right click), do so at https://bugzilla.mozilla.org/ and paste the link for the resulting bug here, and I'll link it and turn this into a feature request.

Dimitrios Symeonidis (azimout) wrote :

422005 seems more generic, covering a wider range of issues...
434895 describes more specifically the issue reported here...
mike, what do you think?
david?

I think 422025, it has more dev attention and is clearer.

Seems to me that the simplest thing would be "always show the nav bar in
FullScreen mode" - just ignore the user setting for this toolbar. This will
always have the restore button, which is the main thing one needs.

Michael Rooney (mrooney) wrote :

Thanks David, I used the second bug which seemed to be closer to your issue, and added a comment specifying the deeper problem if you re-map the F11.

Changed in firefox-3.0:
importance: Undecided → Low
status: Invalid → Triaged
Michael Rooney (mrooney) wrote :

Okay, I didn't check out the first one, so feel free to change it if
you both agree!

Dimitrios Symeonidis (azimout) wrote :

let's assign it to 422025, we'll see how it goes upstream...

Changed in firefox:
status: Unknown → Confirmed
Penguin1976 (quarkangel7) wrote :

Guys here is what works for me: I went to system--preferences--appearance (funny how people leave out the middle step, which is confusing to newer users) then i chose no effects. it went back to normal. When i chose the medium grade appearance, it worked normally again, no obnoxious full screen effect coming back no matter how madly i try to remove all trace of firefox!!!

Bottom line is its an Ubuntu bug. In my case it is intrepid 8.10s fault. I will call it a high priority bug..why?? BECAUSE ITS HELLATIOUSLY ANNOYING!!!!

That puts it at the top of my list. Further since my knowledge of Ubuntu is not super deep, I can only theorize that it is rebuilding some kind of config file in how the whole appearance should go, that something got corrupted.

Canonical, i continue to hope in the user friendliness of Ubuntu, this is the only thing that will make Ubuntu super competitive with windows. Otherwise geeks like me will be the only ones using it. It also couldnt hurt to make it have more support for various hardware in the US more drivers. But, lets face it. WIndows is perceived as A U.S. Brand product. Linux is european, at least until you go back to Unix...anyway...WIndows will do whatever is in its power to make sure there is no other competing OS. But linux file system is better, even for solid state drives! Especially for those.

Again, I dont want to pay 1 to 300 more bucks every time an OS is released. More power to Linux!

Another request: MORE VIDEO GAMING SUPPORT PLEASE!!!

Ok theres my rant, thanks all. I hoped my advice helped.

related to bug 291540?

Changed in firefox:
importance: Unknown → Medium

See also bug 171350 - [cust] allow customization or better control of full screen toolbars.

The address bar cannot be removed from the navigation toolbar since Firefox 29.

Changed in firefox:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.