Font sizes all wrong in Firefox and GDM at 1920x1080

Bug #236949 reported by Lee Revell on 2008-06-02
2
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Unknown
firefox-3.0 (Ubuntu)
Medium
Unassigned

Bug Description

When using 1920x1080 resolution, the font sizes in Firefox and GDM are all wrong. Some pages display OK, but on many others the fonts are either way too small or way too big.

GDM has the problem (login/password are displayed in HUGE font) as well as Firefox. Opera seems to behave sanely.

I have attached a screenshot of Launchpad which shows the problem. Firefox renders it terribly, Opera does OK.

lee@dualcore:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

In , Kliu (kliu) wrote :

*** Bug 434257 has been marked as a duplicate of this bug. ***

In , Kliu (kliu) wrote :

Could you get a regression range?

Sorry, I was sick.

Scaling worked including version
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008033105 Minefield/3.0pre

It is broken since
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040106 Minefield/3.0pre

I hope that helps!

In , Kliu (kliu) wrote :

Probably the result of bug 394103

--> Core::GFX/Thebes, I don't think this is a Firefox 3 blocker, but we'll want to fix it in one of the dot-dot updates, probably.

I'm a little worried that this is going to come down to a choice between addressing the concerns of those who filed bug 394103 or this one, though in that case, I think since those running into bug 394103 were hitting it due to kookiness in their Linux configs, this bug is gonna win.

In , Kliu (kliu) wrote :

I had marked bug 424822 as a dependency, as that would allow users to override the behavior added in bug 394103. Alternatively, the new behavior in bug 394103 could be reverted, and bug 424822 could be used to allow Linux users to hack around their problem. Either way, we'll need bug 424822.

I think at this point I'm more about reverting bug 394103, but again, I can wait until after we ship, I think.

Vlad believes that we should #ifdef MOZ_WIDGET_GTK2 the change from bug 394103, since the misrepresentation of DPI appears to be limited to Linux, and that's the conservative play. I have no reason to doubt him.

I guess whiteboard isn't one of the fields that bugzilla lies about in the mid-air message. ;(

Roc: can you implement the fix from comment 8 and put it up for review ASAP? Thanks!

Created an attachment (id=322574)
fix

(From update of attachment 322574)
Sure, add a comment at least referencing this bug number? (Or explaining what's going on, if you understand what the underlying issue is)

You mean something like
   // be more conservative about activating scaling on GTK2, since the dpi
   // information is more likely to be wrong
?

perfect :)

(From update of attachment 322574)
a=beltzner, please land on cvsroot asap

mozilla/gfx/src/thebes/nsThebesDeviceContext.cpp 1.78

...and the comment:
mozilla/gfx/src/thebes/nsThebesDeviceContext.cpp 1.79

Lee Revell (rlrevell) wrote :

When using 1920x1080 resolution, the font sizes in Firefox and GDM are all wrong. Some pages display OK, but on many others the fonts are either way too small or way too big.

GDM has the problem (login/password are displayed in HUGE font) as well as Firefox. Opera seems to behave sanely.

I have attached a screenshot of Launchpad which shows the problem. Firefox renders it terribly, Opera does OK.

lee@dualcore:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

Lee Revell (rlrevell) wrote :
Lee Revell (rlrevell) wrote :
Nick Ellery (nick.ellery) wrote :

Package set to firefox-3.0.

On Tue, Jun 03, 2008 at 12:53:29AM -0000, Launchpad Bug Tracker wrote:
> You have been subscribed to a public bug:

Please give me your DPI like:

  $ xdpyinfo | grep reso

thanks.

 status incomplete

 - Alexander

Changed in firefox-3.0:
status: New → Incomplete
Lee Revell (rlrevell) wrote :

$ xdpyinfo | grep reso
  resolution: 305x305 dots per inch

I don't think it's a Firefox specific issue, as I mentioned the GDM login screen has the same problem.

Alexander Sack (asac) wrote :

will be available when RC2 hits the archive

Changed in firefox-3.0:
status: Incomplete → Fix Committed
Alexander Sack (asac) wrote :

you have quite a high resolution. What kind of system/screen do you have?

Changed in firefox-3.0:
importance: Undecided → Medium
Changed in firefox:
status: Unknown → Fix Released
Lee Revell (rlrevell) wrote :

Samsung 4661. It's a 46" LCD HDTV. That DPI is clearly wrong; I think it's actually about 48DPI.

Lee Revell (rlrevell) wrote :

More info:

I tried setting DPI to 96 in gdm.conf. Now GDM fonts look great, but Firefox fonts are way too small on some pages, like Launchpad. If I zoom in twice with Ctrl-+ it looks perfect.

When I set DPI to 48 (which I confirmed is the actual DPI of the screen) in gdm.conf, the Firefox Launchpad font looks the same as with 96DPI, but now the GDM login font is tiny.

On Tue, Jun 03, 2008 at 01:59:24AM -0000, Lee Revell wrote:
> More info:
>
> I tried setting DPI to 96 in gdm.conf. Now GDM fonts look great, but
> Firefox fonts are way too small on some pages, like Launchpad. If I
> zoom in twice with Ctrl-+ it looks perfect.
>
> When I set DPI to 48 (which I confirmed is the actual DPI of the screen)
> in gdm.conf, the Firefox Launchpad font looks the same as with 96DPI,
> but now the GDM login font is tiny.
>

firefox 3 wont support DPIs considerably smaller than 96 for
technical reasons.

 affects ubuntu/firefox-3.0
 status wontfix

 - Alexander

Changed in firefox-3.0:
status: Fix Committed → Won't Fix
Lee Revell (rlrevell) wrote :

Ok, but the fonts are still way too small when I set DPI to 96, unless I zoom in two levels.

this is still an issue on windows xp with 144 dpi. firefox 3.5 worked just great. i upgraded to 3.6.b3 and suddenly the gui collapsed. screenshots with 3.5 and 3.6b3:

http://clip2net.com/page/m0/2714596 (3.6b3) TOO SMALL
http://clip2net.com/page/m0/2714709 (3.5) SLIGHTLY TOO LARGE, BUT IT'S MUCH MORE CONFORTABLE TO THE EYE, working 8 hours a day at 37' from 2 meters distance

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.