Comment 42 for bug 197781

"Binary package hint: firefox" that is why i said firefox-2 the package would be firefox-3.0 if it was ff3 changing to be correct.
This sounds like something more on pc than a bug. can you please try with a clean profile see https://wiki.ubuntu.com/MozillaTeam/Bugs and see if you can still reproduce it.
At this moment i am unable to reproduce this bug.