file-roller crashed with SIGSEGV in memmove()

Bug #399172 reported by Nicolò Chieffo on 2009-07-14
784
This bug affects 156 people
Affects Status Importance Assigned to Milestone
File Roller
Confirmed
Critical
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Karmic by David Nielsen

Bug Description

Binary package hint: file-roller

it happens when using right click, create archive from nautilus when a filename has a space

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Jul 14 10:13:45 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/file-roller
Package: file-roller 2.27.2-0ubuntu1
ProcCmdline: file-roller --default-dir=file:///home/username --add file:///home/username/Canzoniere%202009.doc
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-2.17-generic
SegvAnalysis:
 Segfault happened at: 0x7fee9ffeebf0 <memmove+336>: mov %al,(%rbx)
 PC (0x7fee9ffeebf0) ok
 source "%al" ok
 destination "(%rbx)" (0x7feea1c491f2) in non-writable VMA region: 0x7feea1897000-0x7feea1cde000 r-xp /usr/lib/libgtk-x11-2.0.so.0.1704.0
SegvReason: writing VMA /usr/lib/libgtk-x11-2.0.so.0.1704.0
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 memmove () from /lib/libc.so.6
 IA__g_strchug (string=0x7feea1c491f2 "")
 ?? ()
 IA__g_closure_invoke (closure=0x2831a50,
 signal_emit_unlocked_R (node=0x2352eb0,
Title: file-roller crashed with SIGSEGV in memmove()
Uname: Linux 2.6.31-2-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nicolò Chieffo (yelo3) wrote :

StacktraceTop:?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in file-roller (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete

Pedro, simply without running valgrind, I found a strange thing in the
crash report:
ProcCmdline: file-roller --default-dir=file:///home/username --add
file:///home/username/Canzoniere%202009.doc

my home is /home/yelo3, not /home/username..

Nicolò Chieffo (yelo3) wrote :

Anyway executing it with the correct path and compressing to ZIP will always cause the same results, so I run valgrind.

Changed in file-roller (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=589920

Changed in file-roller (Ubuntu):
status: Confirmed → Triaged
visibility: private → public
Changed in file-roller:
status: Unknown → New

It occurs when you trying to create ZIP archive too. Im not sure why. I have all required libraries etc.

File roller can't compress anything, but it can read anything that it supports through the libraries. Karmic and Jaunty bugs.

Niels Egberts (nielsegberts) wrote :

I ran into this with Karmic trying to .zip a folder without spaces.

Same here, compressing some files without spaces to .zip crashes reproducibly. The same files as .tar.gz works normally.

ditto #10 and #11

Pedro Villavicencio (pedro) wrote :

this has been fixed upstream now, thanks for reporting.

Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Sergey Sedov (serg-sedov) wrote :

I have same problem

karmic 9.10 with latest updates

Angel Guzman Maeso (shakaran) wrote :

When this bug will be released on Karmic?

Pedro Villavicencio (pedro) wrote :

probably next week, and please do not re, re, confirm the issue, we know is there. If there's another new release of file-roller and you're still getting the issue then please say it, otherwise please don't, it only generate bug mail noise.

xtknight (xt-knight) wrote :

I think they're confused about this: status: Triaged → Fix Committed

However, Fix Committed means it was updated in the upstream source code. Only once it is "Fix Released" will it be in Ubuntu. That's important to understand.

PaulW (paulw) wrote :

Having this issue, but slightly different...

Right-click a folder, choose Compress, and it crashes out when you hit continue.

9.10 Karmic here, updated about 3 hours ago...

Sergey Sedov (serg-sedov) wrote :

The problem still remains

After latest update I can compress my files with ".tar.gz", but with other formats (zip, etc) it crashes

Matthew Woerly (nattgew) wrote :

Getting this today when trying to make a .zip... what version can we expect the fix in?

Alex Ivasyuv (industral) wrote :

Confirm, issue still exist. BTW, why status is "Fix Committed"?

Reiner Jung (prefec2) wrote :

Definitely this problem still exists.

Changed in file-roller (Ubuntu):
status: Fix Committed → Incomplete
zordsdavini (zordsdavini) wrote :

problem still exist. created zip archive from directory. no spaces in name. tar.bz2 OK

Changed in file-roller (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

changing back to fix commited which means the bug has been fixed in GNOME git not in ubuntu yet

Changed in file-roller (Ubuntu):
status: Confirmed → Fix Committed
Pedro Villavicencio (pedro) wrote :

Some news (bad ones though), the bug is not fixed with that commit[1] (which is already on file-roller 2.27.92 available on Ubuntu), just tested it and it crashes anyways, will re open the upstream bug. Thanks all.

1- http://git.gnome.org/cgit/file-roller/commit/?id=1e38c5df005ec2d54ac05b3028ab7c56a09ad082

Changed in file-roller (Ubuntu):
milestone: none → ubuntu-9.10-beta
status: Fix Committed → Triaged
Boblemur (boblemur) wrote :

for me File-roller still crash's trying to make a zip file with no spaces in any filenames.

Sergey Sedov (serg-sedov) wrote :

With file-roller 2.28.0 I can compress my files with .zip format, but the files in .zip archive damaged

Pedro Villavicencio (pedro) wrote :

this is now fixed with file-roller 2.28.0-0ubuntu1 ; Sergei you might want to open a new bug for that error since it's not the same problem we describe here. thanks.

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released
Changed in file-roller:
status: New → Confirmed
Changed in file-roller:
importance: Unknown → Critical
To post a comment you must log in.