Comment 3 for bug 237543

After a bit more looking around, it seems that it is the "file-roller" package which has the problem.

To determine this, I executed the following command in the console when reproducing the bug :
xprop | grep WM_CLASS

I then clicked on the dialogs, which gave me this output :
WM_CLASS(STRING) = "file-roller", "File-roller"

Also, I tried to reproduce the bug using the "zip" program in a console, and I could not reproduce
the bug. Here is what I tried to reproduce the bug at the command line :

------------------------------------------
yves@Belzebuth:~/Music$ ls -l
total 8
-rw-r--r-- 1 yves yves 18 2008-06-05 13:36 auie
-rw-r--r-- 1 yves yves 0 2008-06-05 13:36 auie~
-rw-r--r-- 1 yves yves 20 2008-06-05 13:36 eiau
-rw-r--r-- 1 yves yves 0 2008-06-05 13:36 eiau~
yves@Belzebuth:~/Music$ zip example.zip eiau auie
  adding: eiau (stored 0%)
  adding: auie (stored 0%)
yves@Belzebuth:~/Music$ zip example.zip eiau auie example.zip
updating: eiau (stored 0%)
updating: auie (stored 0%)
yves@Belzebuth:~/Music$ rm example.zip
yves@Belzebuth:~/Music$ touch example.zip
yves@Belzebuth:~/Music$ zip example.zip eiau auie example.zip
 zip warning: missing end signature--probably not a zip file (did you
 zip warning: remember to use binary mode when you transferred it?)

zip error: Zip file structure invalid (example.zip)
yves@Belzebuth:~/Music$
------------------------------------------