File-roller can't create new archives in mounted samba/ftp shares

Bug #1071759 reported by Alessandro Lazzari on 2012-10-26
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Low
Unassigned

Bug Description

I have a large directory, almost 50Gb and 45.000 files shared by samba on ubuntu 12.04.1 LTS server.
When trying to add some files to an archive, file roller reports insufficient permissions.
It can't add new files to an existing archive either, only the extraction of files is permitted.

Steps to reproduce:
- mount the shared directory;
- select any file, or group of files;
- right click on the selection and choose "Compress..."
- click on "Create".

What happens: File-roller reports insufficient privileges.
What should happen: a new archive containing the selected files is created in the remote directory.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: file-roller 3.6.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Fri Oct 26 15:39:55 2012
InstallationDate: Installed on 2012-10-22 (4 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: file-roller
UpgradeStatus: No upgrade log present (probably fresh install)

Also, trying to create a new local archive from files resident on a samba share, i.e. on the desktop, results in an empty archive.

Bug still persist in version 3.6.1.1.

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in file-roller (Ubuntu):
importance: Undecided → Low
Changed in file-roller (Ubuntu):
status: New → Triaged

As suggested by a file-roller developer, I tried to create new archives in the samba share from other applications. It showed that Nautilus has no problems in creating new folders and files from templates.
Then, I also tried saving a new file directly from Libreoffice Writer, Calc and Impress, Gimp, Eye of Gnome, Evince, Shotwell, Firefox, Thunderbird and PDFmod all from Quantal repositories.
Only saving from Shotwell and Evince worked. All others returned an I/O error, like file-roller does. Mozilla Firefox, Thunderbird and PDFmod report that they can't use a remote directory instead.

So, if the bug is not really in file-roller, I'm going to file a new bug here. I just don't really know which package to refer, I only understand that it might be related to gvfs or samba.

Sebastien Bacher (seb128) wrote :

Note sure, does it work better if your use the gvfs-fuse ~/.gvfs directories to access the shares? it would be worth testing maybe a KDE applications or something else than GNOME...

I tried saving from The Gimp, Libreoffice and Mozilla applications directly to /run/user/<username>/gvfs/<share> and it worked.

I also installed the Calligra suite and tried saving from the various Flow, Stage and Sheets applications to the share using their share browser and it worked.

Then, I tried saving an archive from file-roller to /run/user/<username>/gvfs/<share> and... it didn't work. Same I/O error as before.

Changed in file-roller:
importance: Unknown → Medium
status: Unknown → New
Adam Niedling (krychek) wrote :

I have the same problem on Ubuntu 13.04.

summary: - Can't create new archives in mounted samba shares
+ File-roller can't create new archives in mounted samba shares
Adam Niedling (krychek) on 2013-10-14
tags: added: saucy
Doudz (sebastien-ramage) wrote :

I have the same problem since Ubuntu 13.04 and still here in Ubuntu 14.04.

It's a big issue for me since I planned to deploy Ubuntu 14.04 in enterprise.

Another thing, I can't create archive on sftp share too but in this case file-roller simply crash.

Adam Niedling (krychek) on 2014-05-04
tags: added: trusty
Doudz (sebastien-ramage) wrote :

still here in Ubuntu 14.10 Utopic...

Adam Niedling (krychek) wrote :

Still the same problem in Ubuntu 15.10 on an FTP share.

tags: added: wily
summary: - File-roller can't create new archives in mounted samba shares
+ File-roller can't create new archives in mounted samba/ftp shares
bitboy (zeus557) wrote :

I've played around a bit and i think there are at least two different issues.

First, it looks like the gvfs backend didn't set file attributes.
The check if (! g_file_info_get_attribute_boolean (parent_info, G_FILE_ATTRIBUTE_ACCESS_CAN_WRITE)) in file fr-new-archive-dialog.c will fail because of that. It gets (NULL) instead of TRUE.
BUT if you specify /run/user/$user/gvfs/.... as folder, checking the attribute returns TRUE as it should. (This is strange, maybe i did a mistake during testing)

Then i commented out that check and recompiled.
I was now able to create an archive with files from my destop on the share.
BUT it is not working the otherway. If i want to create an archive on my desktop with files from the share it only looks like it is working (no error popping up, progressbar is shown) but the archive isn't created at all. So even if this check is skipped, it still fails if your source files are on a share.

Luca (luca-vercelli-to) wrote :

I have the same problem. I guess that file-roller il looking at the wrong locations, as I pointed out here https://github.com/linuxmint/nemo/issues/1085

Changed in file-roller:
status: New → Confirmed
Changed in file-roller:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.