Xorg freeze

Bug #987153 reported by Hansen on 2012-04-23
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Desktop 12.04 AMD64.
Proprietary AMD driver causes random freezes or lock'ups on Lenovo Ideapad s205 AMD E-450

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,move,mousepoll,resize,place,gnomecompat,session,compiztoolbox,wall,imgpng,vpswitch,regex,unitymtgrabhandles,animation,expo,workarounds,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Mon Apr 23 09:50:49 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.960, 3.2.0-23-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a week
GpuHangReproducibility: Seems to happen randomly
GpuHangStarted: Since before I upgraded
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6320] [1002:9806] (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:397b]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120417)
JockeyStatus:
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 kmod:rt3090sta - rt3090sta (Free, Enabled, In use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: LENOVO 1038D4G
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-23-generic root=UUID=2783a6f6-3e30-42b5-9c74-cf6aa99f53f0 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/10/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 4BCN24WW
dmi.board.asset.tag: Base Board Asset Tag Unknown
dmi.board.name: Inagua
dmi.board.vendor: LENOVO
dmi.board.version: 109-B78210-00A
dmi.chassis.asset.tag: Chassis Asset Tag Unknown
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Chassis Version Unknown
dmi.modalias: dmi:bvnLENOVO:bvr4BCN24WW:bd08/10/2011:svnLENOVO:pn1038D4G:pvrIdeapadS205:rvnLENOVO:rnInagua:rvr109-B78210-00A:cvnLENOVO:ct10:cvrChassisVersionUnknown:
dmi.product.name: 1038D4G
dmi.product.version: Ideapad S205
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Hansen (moteprime) wrote :
Bryce Harrington (bryce) on 2012-04-24
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Ildefonso Camargo (icamargo) wrote :

Greetings,

I seem to be having the same problem. While using 11.10 (ie, before updating) this problem used to happen under two situations:

1. If I used a low-latency kernel (ie: fully preemptive). I switched to voluntary preemption.
2. If I enabled V-Sync + "Escritorio libre de fragmentaciones" (I don't get why ATI control center is in Spanish in my system, whereas the rest of the system is in English... I'll try to get the English name later).
3. You leave the desktop alone (ie: idle).

However, now on 12.04, this just happaned, only V-Sync was enabled, I tried to disable V-sync, and I'm waiting if that helped.

By the way, the freeze applies only to X server (that ends up using 100% CPU), I was able to ssh to my machine and reboot it.

Anyway, from last X freeze, I got this on Xorg.log:

[ 29349.258] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 29349.258]
Backtrace:
[ 29349.353] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7fb8355ad856]
[ 29349.354] 1: /usr/bin/X (mieqEnqueue+0x263) [0x7fb83558df33]
[ 29349.354] 2: /usr/bin/X (0x7fb835425000+0x62924) [0x7fb835487924]
[ 29349.354] 3: /usr/lib/xorg/modules/input/evdev_drv.so (0x7fb828831000+0x5d88) [0x7fb828836d88]
[ 29349.354] 4: /usr/bin/X (0x7fb835425000+0x8adf7) [0x7fb8354afdf7]
[ 29349.354] 5: /usr/bin/X (0x7fb835425000+0xb0d3a) [0x7fb8354d5d3a]
[ 29349.354] 6: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fb83474b000+0xfcb0) [0x7fb83475acb0]
[ 29349.354] 7: /lib/x86_64-linux-gnu/libc.so.6 (ioctl+0x7) [0x7fb8336a9d27]
[ 29349.354] 8: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0x1b1890a) [0x7fb82afef90a]
[ 29349.354] 9: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0x1b0fcc1) [0x7fb82afe6cc1]
[ 29349.354] 10: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0xedef77) [0x7fb82a3b5f77]
[ 29349.354] 11: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0xee02b6) [0x7fb82a3b72b6]
[ 29349.354] 12: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0x3d3c71) [0x7fb8298aac71]
[ 29349.354] 13: /usr/lib/dri/fglrx_dri.so (0x7fb8294d7000+0xf1a05f) [0x7fb82a3f105f]
[ 29349.354] 14: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so (0x7fb8326df000+0x1d8d7) [0x7fb8326fc8d7]
[ 29349.354] 15: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so (0x7fb8326df000+0x16e33) [0x7fb8326f5e33]
[ 29349.354] 16: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so (0x7fb8326df000+0x1e967) [0x7fb8326fd967]
[ 29349.354] 17: /usr/bin/X (0x7fb835425000+0x4e791) [0x7fb835473791]
[ 29349.355] 18: /usr/bin/X (0x7fb835425000+0x3d6aa) [0x7fb8354626aa]
[ 29349.355] 19: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fb8335e076d]
[ 29349.355] 20: /usr/bin/X (0x7fb835425000+0x3d99d) [0x7fb83546299d]
[ 29349.355] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
[ 29349.355] [mi] mieq is *NOT* the cause. It is a victim.

Ildefonso Camargo (icamargo) wrote :

Greetings,

Even more information:

I turned off vsync, and the freeze happened again, this happens after some time idle (maybe related to power management).

On other information, now I tried from the ssh session to kill X server and kdm (yes, I'm using kde), first with signal 15, then with signal 9. The processes went down, but even though keyboard seemed to start working, I had no video. I tried to start kdm again, and now the machine crashed.

Around the crash time I found a related message on the logs, in addition to the ones on Xorg.0.lo:

May 9 15:02:35 machine kernel: [30439.945854] [fglrx] IRQ 55 Disabled

Also, Xorg.0.log

Find attached Xorg.0.log file (where other interesting messages are).

Hansen (moteprime) wrote :

Hi Ildefonso Camargo.
Sorry not to have replied earlier.
To me this bug has been going through 11.10 on to 12.04, it started after one of the upgrades of Catalyst Centre, (I think around 12.1). Now i have tried with the proprietary drive offered in Jockey and it's still locking up 2-3 times a day.
I have not been able to determine what causes the lockups, but if I un-install the proprietary drive and uses the opensource Radeon drive the lockups stops.
Are your using a E-450 with Radeon HD 6320 ?

Ildefonso Camargo (icamargo) wrote :

Hi Hansen,

No, my CPU is A8-3850 (no external video card, just the included HD 6550D). Also, I have to inform that after almost 7 hours idle the machine didn't crashed. I disabled power management (ie, left only the screen saver, but screen is never put to sleep).

Also, before the update to 12.04 turning off V-sync would cure the problem for me (also, avoiding fully preemptive kernel, ie: forced preemption enabled would cause a certain freeze). My kernel right now has voluntary preemption (one of the attempts to fix the problem was to use a custom kernel, right now I'm using a custom-built 3.2.16 kernel).

If the machine doesn't freeze for the rest of the day, I'll reboot and switch to Ubuntu kernel to test there too.

Ildefonso.

Ildefonso Camargo (icamargo) wrote :

Greetings,

Another update: almost 3 hours after moving again to Ubuntu kernel, with disabled display power management, the system is working just fine.

I think the problem shows itself when the video card goes into energy save mode.

Ildefonso.

Raman Gupta (rocketraman) wrote :

I have the same issue with the propietary ATI driver on Fedora 16. I created a bug report for ATI here:

http://ati.cchtml.com/show_bug.cgi?id=530

If you think its the same issue, feel free to add all of the relevant information at the ATI report.

Raman Gupta (rocketraman) wrote :

Slight correction on the above... the report isn't for ATI as its an unofficial bug tracker... but its a common place to aggregate information about the ATI driver.

Hansen (moteprime) wrote :

@Raman Gupta
I reported the Bug there a long time ago, i don't think anybody checks on those bug reports ever.
Also wrote to AMD support, they told me to clean my windows registry!! >:-/
Tried the support form at fglrx download page several times, never received any answer.

Ildefonso Camargo (icamargo) wrote :

Greetings,

People, have any of you verified if it fixes the issue for you to disable power management? ...... I know it is not a *fix*, specially for a laptop (battery life would suffer a lot), but I just want to know if we are having the same issue.

Ildefonso.

Raman Gupta (rocketraman) wrote :

For the problem I am having, I don't have any issue if my monitors do not go to sleep i.e. I turn off the KDE option to turn off the monitors when the system is idle (I think KDE is turning off DPMS in the background).

I also do not have any issue if I turn off KDE desktop effects before the monitors go to sleep, so it appears to be something related to Xorg being in a mode that uses the 3D part of the video driver i.e. OpenGL etc.

One last point -- I think you are right about the root cause being the video card going into power save mode, since if the monitors go to sleep but I wake them up within a few seconds, there is no issue. It is only if I wake them up after some time that the EQ overflows.

Does anyone know how to configure the ATI driver to not put the video card in powersave mode, even if the monitors are off?

Hansen (moteprime) wrote :

To me the freezing seems to happend completely at random, but only when using the laptop.

Raman Gupta (rocketraman) wrote :

I'm on a desktop so I suspect the only time the power saving stuff kicks in is when the monitors go to sleep... I'm guessing that for a laptop the driver may try to manage the power consumption more aggressively, and so cause this to happen more often.

ubu4 (supergaga76) wrote :

I had some problems with my laptop hp dv-5 with radeon 3400hd -Freezing was totally random.Anyway sometime happened when i plug-off Ac-power so probably had some to do with power-saving . I speak on past because i had to downgrade to "linx" (i had stability problems also in 11.10) i hope will get good news soon !!

-funny error get from browser when i tried to view video on line (ex: youtube) browser begun to looking for a nvidia drivers and all system got stuck in few minute

kenorb (kenorb) wrote :
Hansen (moteprime) wrote :

@kenorb
Thanks for looking into this bug.
I have read through the bugs you suggested.
for 966744 My bug does not relate to suspend if i suspend with ATI proprietary driver installed the computer locks up completely.
As for 988008 it is only sometimes that the mouse cursor are able to move, most times the computer just freezes.
In 1007904 i'm on kernel 3.2.0-27 and still have freezes.

Are there anything i can do to to help getting this bug fixed?

Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.