Comment 24 for bug 642518

Note that the original patch was proposed by Evan Broder.

I just indicated how to apply it more easily.

For safety, it is possible to lock the version of the fglrx packages until the patch is added to the usual update.

In principle, the patch makes the difference between the preceding and following kernels CVE-2010-3081 (2.6.32-24.43).

For the problem reported by Philippe Lefebvre, it is possible that DKMS can not correctly compile the new module fglrx because the files from the old version are still present.

Note that Catalyst overwrites or diverts some libraries with proprietary versions (Troubleshooting when -fglrx Interferes with -radeon Driver - https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver ).

Check DKMSBuildLog.

Check version numbers.