Comment 10 for bug 642518

New version of the patch. General idea is the same, but this one detects at build-time whether it's running on a pre-CVE-2010-3081 or post-CVE-2010-3081 kernel, and chooses between compat_alloc_user_space and arch_compat_alloc_user_space appropriately.

(As an extra feature, if you're on a pre-CVE-2010-3081 kernel, fglrx will now be shielded from the vulnerability at that particular call site)