Ubuntu

[HD 3400] Jaunty: Display doesnt work for ATI Mobility Radeon HD 3470

Reported by Janaka Perera on 2009-04-05
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Janaka Perera

Bug Description

I have a ATI Mobility Radeon HD 3470 graphics card in my Toshiba a305 laptop. I upgraded to janty today. When i boot with 2.6.28-11 developer kernel from the boot menu after the startup console output ends i dont get the login screen. (I get some kind of a scrambled graphics in the LCD). but everything works well with the 2.6.27-11.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
     Subsystem: Toshiba America Info Systems Device [1179:ff1c]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
     Subsystem: Toshiba America Info Systems Device [1179:ff1c]

affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi janakaclk,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Janaka Perera (janakaclk) wrote :

I haven't done any costomizations to the xorg.conf file. But I am anyway attaching it. I also tried to fix it using the recovery boot mode. but didn't help. (btw this is original file)

Janaka Perera (janakaclk) wrote :

I haven't done any customizations to the xorg.conf file. But I am anyway attaching it. I also tried to fix it using the recovery boot mode. but didn't help. (btw this is original file)

Janaka Perera (janakaclk) wrote :

both xorg.conf file are same. sorry for duplicating the message.

Janaka Perera (janakaclk) wrote :

Xorg log from a failed 2.6.28-11 kernel boot is attached

Janaka Perera (janakaclk) wrote :

lspci-vvnn output attached.

Janaka Perera (janakaclk) wrote :

Also I noticed that when booting from 2.6.28-11 , fglrx 8.60 fails. I was not able to get the dmesg output since the system crashed when I tried to change the run level. anyway couldn't find the appropriate(fail) messages in /var/log/messages as well. Let me know if that helps too. I'll try more.

Bryce Harrington (bryce) on 2009-04-09
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Changed in fglrx-installer (Ubuntu):
status: Incomplete → Confirmed
Janaka Perera (janakaclk) wrote :

I removed the fglrx driver. Booted in the recovery mode of the 2.6.28-11 kernel. installed the driver again using "apt-get upgrade". On the next boot up it worked (I actually did so many things before but this made it work).

summary: - Janty: Display doesnt work for ATI Mobility Radeon HD 3470
+ Jaunty: Display doesnt work for ATI Mobility Radeon HD 3470

OK, I have upgraded again to jaunty.

X hung because it still used the radeon driver but tried to load some fglrx extensions.
Forcing it to use fglrx results in error message that states that no supported devices are found. (X1600 mobility is not that old...)

Running RadeonHD now...

According to http://wiki.ubuntuusers.de/Grafikkarten/ATI/fglrx the Radeon Mobility X1600 should be supported :-/

Patrick: You could try the newest fglrx driver from the AMD's sites.
It's fglrx 9.4.

However, this driver as well doesn't work for me in jaunty, it causes
hard hang after a screen corruption when leaving splash screen and
launching GDM.

When I tried fglrx 9.3 (which was latest on 2009-04-10) did not work for me for for both kernels 2.6.27-11 and 2.6.28-11

Janaka Perera (janakaclk) wrote :

Lukáš Chmela: It's ATI Catalyst™ Display Driver version which is 9.4. ATI Catalyst 9.4 has only fglrx version 8.593 which is older than 8.600 (what comes with ubuntu).

Janaka: Ah, yes. Sorry for my mistake.

But you are wrong.
Fglrx 8.593 comes from the Catalyst 9.3, the actual Catalyst 9.4 comes
with fglrx 9.602, which is newer than the one in jaunty repository.

It was released just yesterday.

That's too bad. It's a shame that the fglrx drivers are so "fragile"...
The radeonHD works at least, but I have no 3D acceleration.

Don't understand why it's that hard for Ati to deliver working drivers for his customers.

Janaka Perera (janakaclk) wrote :

Lukáš Chmela: Sorry about it. I have referred to the Catalyst 9.3 release notes. I think the version you have mentioned in the last post is fglrx 8.602. Is 9.4 working fine in your PC? 8.600 is working fine with me.. Do you think I should upgrade? Anything major in the latest version?

Catalyst 9.4 release notes
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_94_linux.pdf

Yes, I talked about the 8.602 version.

It doesn't work for me in jaunty, as well as the version from its
repository (8.600). As I said, I always get screen corruption with those
drivers when starting up and then it freezes. So that's why I can't
accurately tell you what has changed.

If you're not experiencing this, it may be a bug specific for my
platform, the version of jaunty I am using is RC x86_64. Or just an
upgrade problem? I'm upgrading my testing jaunty copy from alpha 5, I
think. Not sure.

However, I tried the new driver also in intrepid. It worked well, video
(including also tvtime, audio visualization in totem, 3d games, etc.) no
more flickers with composite enabled, but the performance with composite
is very, very poor. At least 4x slower (according to my glxgears test).
And finally, video in totem is not stretched to the window size (if not
in fullscreen) but it's cropped. And if I try to toggle fullscreen, my
screen goes dark, then the numlock and capslock LEDs on my keyboard
blink simultaneously (which means kernel panic, I think) and PC becomes
unresponsive. Sometimes it doesn't happen on the first attempt, but
that's exactly what I was experiencing with the Catalyst 9.3, so no
improvement here. That's why I decided to stay with my tested Catalyst
8.12.

Really sad that they can't make fully working drivers after so much time
(4 months from 8.12), as Patrick said. But maybe you'll have more luck.

Same here. Same screen corruption: you can't drop to a shell, it's a nightmare. I also tried 8.602 which was even messier (I installed it directly from the .bin and it was _really_ hard to undo).

I am using an onboard Radeon HD 3200 on a Foxconn A7GM-S MObo, in the latest Jaunty 32 bit.

Janaka Perera (janakaclk) wrote :

Leo Milano: Did you try booting up in the recovery mode and to use apt-get or some other package manager to remove the installed driver. Also you could try fix display option in the recovery mode(it wont fix but it may make things easy if it resets the xorg.conf to use a default driver so that you can uninstall driver in the UI mode).

Leo Milano (lmilano) wrote :

Hi Janaka, yes, I tried all that:

* In recovery mode you can only fix broken packages I think, and I tried. I tried reconfiguring X but it would still pickup the binary driver. I tried dropping to a shell in a root account, but it would ask for the root passwd. This could be my fault, maybe I configured this in the past and couldn't remember it, not sure. But that option was useless. The only thing that worked was [Alt+F2], then login very quickly in a console and "sudo killall -9 gdm", and I had to bit gdm at it on a phenom x3, which took me several boots! After that, yes, I did sudo an uninstalled fglrx, and that did it.

* With the binary 8.602 vanilla from ATI it was a lot worse, because it overwrote some GL libs, and I had to fool around reinstalling xserver packages until I could use the radeon driver.

I think the "fix-x" option in rescue mode should do a bit more (it should show you possible drivers to use), but this is not the place to file that proposal, anyone knows what ubuntu package is related to that?

Also: I Catalyst 94/fglrx 8.602 should be compatible with the latest xorg and in general with Ubuntu 9.04 (it is stated as "early look" in the release notes):

http://www2.ati.com/drivers/linux/catalyst_94_linux.pdf

Leo Milano (lmilano) wrote :

I know the release is around the corner, but shouldn't the upgrade tool revert users to the opensource driver? We can warn them that they will need to add it later, but at least the upgrade will complete successfully. And hopefully the "hardware drivers" tool will not recommend to install fglrx until it's ready to support 9.04.

This is a serious bug for the upgrade, for most users it would mean a need to restart from a CD and wipe out the current, borked installation. And that's assuming they burned an install CD before trying the upgrade.

The upgrade tool warned me that fglrx won't be available and after the installation the xorg.conf was configured to radeon. So I don't think that's a problem. My problem is just that I'd like to have my accelerated driver back :-)

Leo Milano píše v Po 20. 04. 2009 v 15:36 +0000:
> I know the release is around the corner, but shouldn't the upgrade tool
> revert users to the opensource driver? We can warn them that they will
> need to add it later, but at least the upgrade will complete
> successfully. And hopefully the "hardware drivers" tool will not
> recommend to install fglrx until it's ready to support 9.04.
>
> This is a serious bug for the upgrade, for most users it would mean a
> need to restart from a CD and wipe out the current, borked installation.
> And that's assuming they burned an install CD before trying the upgrade.
>

Hm, I'm not very sure which release are you exactly talking about,
Catalyst 9.4 with fglrx 8.602 has been released just two days ago, I
think.

However, it's good idea to don't recommend installing fglrx drivers even
from the hardware drivers in jaunty. I'm just not very sure whether the
fglrx 8.600 driver, which is actually included in jaunty repository as I
know, installs automatically or not.

And a last thing.
If you read the Release Notes for Catalyst 9.4 (fglrx 8.602), they say,
Jaunty IS newly supported by the driver (with notice "early look" in
brackets).

--
Lukáš Chmela <email address hidden>
IRC: <email address hidden>, ICQ: 202077459
514D 3C69 8498 E400 0ACE 90F2 00E3 CACA A5BA ECC7

Patrick: interesting. When did you updgrade? The upgrade tool definitely didn't revert me to the radeon driver. I upgraded from 8.10 this Saturday 18. Or maybe different hardware gets treated differently? (xome cards may be blacklisted, etc)

Lukáš: I had fglrx installed in 8.10 (and working perfectly) and over the upgrade it was kept (or upgraded to a newer version, I am not sure about that). This is what broke _my installation. I also mentioned 9.4/8.602. That was a second attempt at getting fglrx running. Because I read @ Phoronix [1] that the latest release of glrx would support Ubuntu 9.04, I downloaded the installer from ATI's site. You can just install the binaries directly [2] or create and install .deb's with one simple command. Again, this failed miserably for me ;-)

Cheers,
-- Leo

[1] http://www.phoronix.com/scan.php?page=article&item=amd_catalyst_94&num=1
[2] This is the wrong way to install, but I realized later on that you could create the .debs

Leo: Yes, the same for me. I installed using .debs. I just realized, the
fglrx drivers were kept, only updated to the repositary version 8.600.
Both, 8.600 and 8.602 don't work for me. I always get artefacts when
loading GDM (after the bootsplash) and then my PC freezes.

I'm using Ubuntu Jaunty RC, x86_64

--
Lukáš Chmela <email address hidden>
IRC: <email address hidden>, ICQ: 202077459
514D 3C69 8498 E400 0ACE 90F2 00E3 CACA A5BA ECC7

Bryce Harrington (bryce) on 2009-04-20
description: updated
Leo Milano (lmilano) wrote :

The release is out and there is no comment on the issue of the fglrx driver crash ... is it too late to edit these notes? I think users should know!

Leo: I think so too. But, maybe other users don't have this issue?

--
Lukáš Chmela <email address hidden>
IRC: <email address hidden>, ICQ: 202077459
514D 3C69 8498 E400 0ACE 90F2 00E3 CACA A5BA ECC7

Ah, that's a biggie, Lukáš. Good point, maybe the driver itself is ok but when one upgrades some library is linked incorrectly, etc. Is that possible, Bryce? (he got the latest driver in use directly from AMD, it is _supposed_ to be working):

https://lists.ubuntu.com/archives/ubuntu-x/2009-March/000442.html

I am thinking we should give a shot at the liveCD from final in our hardware (all of us having this issue, assuming we find some time) , and see if it runs with the binary driver. Makes sense? If it does, it means something needs to cleaned up, and maybe this is a start:

https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver

Cheers, and congrats everybody for one more fantastic release!

Leo Milano (lmilano) wrote :

Ok, trying with the liveCD is not easy because after "enabling" the fglrx driver you are supposed to reboot! I will try installing to a USB drive over the weekend and see what happens.

Hi all,
Not sure this will be entirely helpful (I'm no expert) but this all sounds like the trouble I ran into during the upgrade (I waited for the official release) so here's how things went for me:
I was running Intrepid on my desktop, for video I'm using an AMD Firestream 9250 with the fglrx driver, with few problems (compiz froze every now and then).
Upgrade went fine until rebooting, the Usplash showed up OK, then a few error messages popped up (too quickly for me to read) and then I wound up at a black screen, with a (non-blinking) cursor. Had to reset, booted in recovery mode, tried the repair graphics option - that got me a garbled screen instead of a black one - not much improvement.
After a few Google searches (using lynx - what fun!) I decided fglrx was the problem; it seemed fglrx was still there, but the open source drivers too. I purged fglrx, removed the open source drivers, and then reinstalled xserver-xorg-video-ati.
That did (most of) the trick - I got a login screen finally, and the desktop, but without compositing. Then I was able to run synaptic, remove the open source driver and install the 8.600 fglrx from the repositories, and all appears to be running smoothly.
Thanks for all the great work guys!

Janaka Perera (janakaclk) wrote :

what Sean Fitzpatrick has done is mostly similar to what I did to fix my problem.

AFAICS this is not definitely a driver issue. Also this ticket is created for the driver installer. As some of us mentioned in this ticket this does not seem to be a problem with every ATI user. may be we installed it when the scripts were broken or incompatible with the kernel version or incompatible with some other factor(config file may be) which was there in the OS only few of us unlucky people.

If it's just few of us who have this problem, most probably this will not get fixed very soon. Or it could be that the fix is available in the installer but it doesn't correct the corrupted situation that we have. I am not sure if steps worked for Sean Fitzpatrick and me will work for everyone else, but if anyone is trying with that option I can help out.

Leo Milano (lmilano) wrote :

Janaka: good points. Let's clean things up a bit:

* Both you and Sean could get your cards to work with flgrx after the cleanup you and Sean mentioned (and this is a bug in the installer as you mentioned). You cards are AMD Firestream 9250 and ATI Movility Radeon HD 3470.

* There is a similar, but "reverse" bug affecting the installer. That other bug is about running the -ati (radeon, opensource) driver after having had fglrx. The root is the same, a bug in the installer where both drivers overlap:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/285603

* Cleanup notes here:
https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver

* However, other people are not able to run the fglrx driver, even after the cleanup. That includes Patrik (Radeon Mobility X1600) and myself (on board Radeon HD3200). Yesterday I tried a clean install on a USB stick, to make sure I didn't have remnant issues from my upgrade, and same thing. No way to get fglrx going, neither from the repositories, nor from the latest ATI Catalyst release (9.4). I did follow the clean up steps.

Ok, I hope this helps clear things up. Should Patrick and I file different bug reports for our graphics cards? Or should we report this upstream to the gflrx team? Do they accept bug reports? There is little that Ubuntu can do with a closed driver.

Janaka Perera (janakaclk) wrote :

I agree.

bug tracker for ati:
https://bugs.launchpad.net/bugs/bugtrackers/ati-linux-bugs

Other option is, probably "Bryce Harrington" would be able to give a better explanation of the actual situation and what we should really do to make things faster. But I dont know to find a way to directly contact him.

Lukáš Chmela (lukaschmela) wrote :

OK, I have just installed a fresh version of Jaunty 32bit final from the
CD I requested.

The fglrx driver 8.600 works great, with better performance than on my
intrepid (fglrx 8.564 - Catalyst 8.12). So in my case the hard hang
after bootsplash was probably due to upgrading jaunty from alpha 6 to
the latest one (although the version I used for testing pre-release
versions was 64bit and the one from CD is 32bit - this shouldn't matter,
the same thing happened to a person with 32bit jaunty which upgraded
from jaunty alpha 6 as well).

The only problem I found is with the totem player. When I switch to
fullscreen, my computer screen gets dark and pc freezes. This bug is
related to the fglrx driver - the same thing happened on intrepid with
the catalyst 9.3 and then also with 9.4 (which is included in jaunty) -
that's why I still have 8.12 installed on my intrepid.

End of my info, hope you'll find it useful.
--
Lukáš Chmela <email address hidden>
IRC: <email address hidden>, ICQ: 202077459
514D 3C69 8498 E400 0ACE 90F2 00E3 CACA A5BA ECC7

Guys, thanks to some heroic help from the community I got this solved:

http://forum.compiz-fusion.org/showthread.php?t=6794

In my case, the issue was randr1.2. I wrote a script that does this:

sudo rm /etc/ati/amdpcsdb
sudo aticonfig --initlal -f --overlay-type=Xv
sudo aticonfig --set-pcs-str="DDX,EnableRandr12,FALSE"
ssudo aticonfig --dtop=horizontal

This fixed my problems both in 32 bit (upgrade) and 64 bit (clean install). The author of that thread says that there were many issues with randr1.2 lately, I am wondering if it would be nice to add this in the installer of the fglrx driver ...

tags: removed: needs-lspci-vvnn

Leo Milano solution did not work for me :(
Now, at login screen, instead of getting the two upper ghost logos I get them plus a gray box under them...

Leo Milano (lmilano) wrote :

Rafael: thanks for reporting. What driver version are you using? I installed successfully Catalyst 9.5 from AMD's site, and now I upgraded to 9.6. I built the Ubuntu/9.04 drivers and then installed them all (you can pass --help to the installer and it explains how to build packages for your distro). HTH!

Hi Leo. Thanks for helping me... Let me tell my whole story,lol... I was using jaunty and yesterday trying to make my resolution output to 1360x768 so i could better use my lcd tv.

Then, for other reasons, I enabled proposal updates and did an update... So when I restarted gdm it crashed. At that time I had not read the threads explaining the bug, so i thought it had to do with missconfiguring xorg... After restoring previous config I saw the problem was not my 1360 modlines.

I them did a upgrade to karmic, thinking this would solve my problem with the new kernel version. It did not... Them, through lynx I saw the reports on this bug and purged fglxr. So i could access my desktop again.

Trying to reinstall the drivers through apt repeated the crash. Today I entered in ADM website, downloaded and installed Catalyst 9.6, but I did not choose the build package option (I wonder if it makes any difference), instead the direct install again the bug returned...

 So I found this thread and tried what you suggested (removed amdpcsdb, and the three aticonfig lines). Then I crashed with the gray box added bellow the two ghost ubuntu logos...

So here I am now using ati free driver.

Is just me now? or anyone else with this bug? Should I file a bug in karmic package?

Leo Milano (lmilano) wrote :

Hi Rafael: sorry the workaround didn't help. You might be close to fixing you issue though. For support, please try the Ubuntu forums and/or the forum I suggested above (feel free to send me a private email if you ask for help on a forum, I'll try to help). Here we are trying to help fix a bug, if any, on the _installer_ of fglrx. Keep in mind that the driver is binary only, so we can't report driver bugs here. I was thinking that something along the lines of the workaround I posted above could be added to the installer, but now your experience is not very encouraging, so thanks for posting.

There is an unofficial bugzilla here: http://ati.cchtml.com/ . Bug reports get sent to email addresses in ATI, but I didn't get a response to my bug report: http://ati.cchtml.com/show_bug.cgi?id=1565 . It's probably a bit too early to post a bug in fglrx in Karmic I guess, they will move to Kernel 2.6.31 soon, and there will be some newer fglrx releases pluged in closer to the release, I would wait until 1 month before release or so and try the default installer again if you want to help development.

BTW, I assume your card is a 3470?

Bryce Harrington (bryce) on 2009-06-26
summary: - Jaunty: Display doesnt work for ATI Mobility Radeon HD 3470
+ [HD 3400] Jaunty: Display doesnt work for ATI Mobility Radeon HD 3470
Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Janaka,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 355495

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 355495 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/355495

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

For all those except Janaka, please file separate bug reports if this issue still exists in Ubuntu Maverick Meerkat (10.10) using "ubuntu-bug fglrx-installer" in a terminal. You may add a comment to your own report referencing this bug 355495.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.