Comment 415 for bug 351186

This bug also affects me with Ubuntu 9.10 and Radeon HD 2400.
See here for technical details:
https://bugs.launchpad.net/bugs/559943

The fix described above with the PPA doesn't work for me. I tried adding the PPA, but the directory where the files supposedly reside doesn't exist (only a lucid/ subdir exists in http://ppa.launchpad.net/info-g-com/xserver-xorg-1.7.6-gc/ubuntu/dists/ ).
When I manually add the software source with the lucid/ subdir, I can install the patch but nothing changes.

How can I install this patch in Ubuntu 9.10 ? Thank you !