[HD 3650] fglrx versions newer than 8.543 cause system hang and panic

Bug #314600 reported by Dana Goyette on 2009-01-07
90
This bug affects 15 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned
Nominated for Karmic by mclaud2000
Declined for Lucid by Bryce Harrington

Bug Description

I am currently using Jaunty with the latest 2.6.28-4-generic #8-Ubuntu x86-64 kernel, and any time I try to use fglrx 8.552 or 8.561 (apt-pinned to Intrepid X server and libdrm2), I get the system hanging at a black screen when I try to start X, followed by a kernel panic after I try pressing a few keys. See attached logfile for a serial-console stacktrace.

Interestingly enough, fglrx reports itself as version 8.56.4, which seems a bit mismatched from the package version number 8.561. In addition, using the official ATI installer to buildandinstallpkg Ubuntu/intrepid within the Intrepid LiveCD gives the same result.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
     Subsystem: Hewlett-Packard Company Device [103c:30e7]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3650 [1002:9591]
     Subsystem: Hewlett-Packard Company Device [103c:3604]

Dana Goyette (danagoyette) wrote :
Dana Goyette (danagoyette) wrote :

This is NOT a duplicate: "apt-pinned to Intrepid X server and libdrm2" and "In addition, using the official ATI installer to buildandinstallpkg Ubuntu/intrepid within the Intrepid LiveCD gives the same result." -- and the symptoms are different, too.

Bryce Harrington (bryce) wrote :

It is the same root cause though. We await a new build of -fglrx from ATI, and it is not expected to work until then.

This is standard whenever we go into a new development version of Ubuntu. After we've updated xserver and/or the kernel, both -fglrx and -nvidia break until we receive new compatible builds. Different people see the symptoms in different ways, but they're all the same issue underneath.

Dana Goyette (danagoyette) wrote :

It also happens on the Intrepid LiveCD, though -- don't tell me that the new X server in Jaunty causes that. I've also tried the leaked 8.750 (with INTREPID X server and INTREPID libdrm2!) and it still happens. Video card is the FireGL equivalent of the Mobility Radeon HD3650.

Bryce Harrington (bryce) wrote :

Hi danagoyette,

Please attach the output of `lspci -vvnn` too.

[This is an automated message. If this script has reached you erroneously, please accept our apologies; any reply to this message will be sufficient to prevent it from doing further automated processing.]

Changed in fglrx-installer:
status: New → Incomplete
Dana Goyette (danagoyette) wrote :

Sure can do.

Bryce Harrington (bryce) on 2009-01-16
description: updated

I had nearly the same problem with a fresh installation of Intrepid and fglrx from the repositories and with the current version available at the amd/ati site. My grafic card is a HD3450.

The driver did work immediately after installation by only restarting gdm but did hang after reboot. I didn't much typing so i didn't see any kernel panics. I only tried to get into another console and to kill X which doesn't work and did a hard reset to reboot the machine into rescue mode. I finally managed to get fglrx back into life without reinstalling by overwriting the file /etc/ati/amdpcsdb with /etc/ati/amdpcsdb.default. I traced back my steps after installing the driver and what i did just before the final reboot and found that aticccle caused the problem which i used to position and resize the visible screen image. I was able to reproduce the failure by using aticccle the named way but changing the TV output (just for testing, a TV is connected) from the default setting to PAL-B didn't cause a problem.

May be this information fits to this problem (I'm not quite shure) and is of any use.

regards

   M.Baehr

Dana Goyette (danagoyette) wrote :

Hmm, I just tried booting the 64-bit Intrepid (8.04.1) ISO (on a USB drive); the same thing happens there. I believe there must be something wrong with the newer versions of the driver (in this case, the just-released Catalyst 9.1). Some time this weekend, I can make a spare full-install of Intrepid to be sure it's not just a header mismatch issue. I'll also be willing to try the 32-bit version, and grab a stacktrace from each. With a fresh install, the amdpcsb is most likely not a factor.

Dominik Grafenhofer (dpjg) wrote :

I experience the very same problems under (k)ubuntu 8.10. The fglrx driver comming with ubuntu is works, but not perfect (e.g. the performance is mediocre). When I install newer version of the driver from the ati website (8.12 or 9.1) I experience a crash of the X server and a blank screen on startup. I experience the same problem on a freshly installed openSUSE 11.1.

A few more details can be found on a post of mine on the phoronix forums:
http://phoronix.com/forums/showthread.php?p=60873

Dominik Grafenhofer (dpjg) wrote :

I forgot to mention that I use a Mobility Radeon 3650 HD chipset on a HP Elitebook 8530p notebook. I will add an xorg logfile for the 8.12 driver.

Dana Goyette (danagoyette) wrote :

Seems pretty confirmed to me.

Changed in fglrx-installer:
status: Incomplete → Confirmed
Dominik Grafenhofer (dpjg) wrote :

The problem is still there with the new 9.2 version of catalyst. I tested it under kubuntu 8.10 32-bit and opensuse 11.1 64-bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1

---------------
fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low

  * New upstream release. (Closes LP: #313027, #314600)
    - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
      #288620, #289628
  * README.Debian: Update the update procedure a bit

 -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42 -0700

Changed in fglrx-installer:
status: Confirmed → Fix Released
Dana Goyette (danagoyette) wrote :

This is still broken for me in the just-uploaded fglrx 8.600 driver for Jaunty -- I still get a kernel panic. Note that this is on the 2.6.28-10-generic amd64 kernel.

Another related bug report: https://bugs.launchpad.net/fglrx/+bug/288620

Dana Goyette (danagoyette) wrote :

Note on that "8.750": that's a typo; should be 8.570.

Dana Goyette (danagoyette) wrote :

Not fixed -- still panics on Jaunty with fglrx 8.600 (amd64).

Changed in fglrx-installer:
status: Fix Released → Confirmed
Dominik Grafenhofer (dpjg) wrote :

I can confim the crash on Jaunty (32-bit) reported by Dana Goyette on a HP Elitebook 8530p (Mobility Radeon HD 3650). See lspci output of this machine above.

KeithCu (keithcu) wrote :

I also get this with the latest and greatest bits as of today. And doing a safe mode boot and selecting xfix doesn't fix the problem either.

Fabian A. Scherschel (fabsh) wrote :

I can confirm this on Mythbuntu Intrepid. Rescue boot & xfix works for me but as soon as I use Jockey to load the fglrx driver, the system will hang at the next reboot before loading GDM with a black screen, totally unresponsive system and my monitor telling me it detected an unsupported video mode.

If I use Synaptic to roll back to 8.543 or try an older kernel, the same thing happens. I can only use the Radeon driver at this point. Funnily, I did the update weeks ago including reboot and all was fine. This problem appeared out of thin air two nights ago on the running Mythbox. I did not reboot or even log out of X. I have now rolled back the fglrx driver, the kernel module, depmod and even Xorg itself to the versions that came with Intrepid and I still get the same symptoms.

System is a Dell XPS 210 with Radeon X1300 card and a Dell 22" monitor.

Problem persists with fglrx version 9.3 released today. See https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/346372 for my bug report which apparently is the same than the problem described here.

Fabian A. Scherschel (fabsh) wrote :

I figured out why even rolling back to the older version of fglrx didn't work for me: looks like my card is fried, at least the 3D functions do not seem to work at all. From the scorching around the GPU area, it looks like it massively overheated (it is a passively-cooled X1300). Not sure if this is just a coincidence or if the driver somehow caused the card to heat up so much...

Dominik Grafenhofer (dpjg) wrote :

It seems that there exists a workaround for this problem, which involves running

aticonfig --acpi-services=off

after "aticonfig --initial".

I have tested this on ubuntu 8.10 (32-bit, catalyst 9.3) and ubuntu 9.04 post-beta (64-bit, catalyst pre-9.4).

May be this bug is hardware/chipset dependend. I did a fresh dual boot install of Intrepid on my windows pc equipped with a HD4850 and did activate fglrx via hardware manager which installed the repository version (9.3 I think). No such problem up to now.

FYI lspci output attached

mfg

     M.Baehr

I can say the bug is still alive, at least with my X1300 on Ubuntu/8.10

It is interesting that the Xlog file does not show any error at all. But the X hangs just before giving the login gdm window.

I tried all the suggestions posted here (included the "--acpi-services=off") without success.

At the moment, the only way I found to make the X work is to uninstall fglrx and choose the ati driver.

It is even more interesting that this bug appears to me only recently, after one of the upgrades. I mean that when I installed Ubuntu/8.10 fglrs worked great. I could use 9.2 ati-driver version. But at some point, for unknown reasons, this hang-behavior started appearing, and now I am stuck.

It is depressing not to use the card at its best.

Only solution for now for me at the moment is: either to wait for at/ubuntu fix or to reinstall Ubuntu/8.04.

The post that this happens also in Suse makes me feel it is not just an Ubuntu problem.

fermulator (fermulator) wrote :

Apparently this is an incompatibilty from ATI (fglrx) with the latest xserver? The move from Ubuntu 8.04 to 8.10 has a newer version of xserver, which is incompatible with ATI's latest 9.3 Catalyst. The worst part is, that I just noticed that ATI recently announced the following cards as "Legacy":
ATI Radeon 9500 Series
ATI Radeon 9550 Series
ATI Radeon 9600 Series
ATI Radeon 9700 Series
ATI Radeon 9800 Series
ATI Radeon X300 Series
ATI Radeon X550 Series
ATI Radeon X600 Series
ATI Radeon X700 Series
ATI Radeon X800 Series
ATI Radeon X850 Series
ATI Radeon X1050 Series
ATI Radeon X1300 Series
ATI Radeon X1550 Series
ATI Radeon X1600 Series
ATI Radeon X1650 Series
ATI Radeon X1800 Series
ATI Radeon X1900 Series
ATI Radeon Xpress Series
ATI Radeon X1200 Series
ATI Radeon X1250 Series
ATI Radeon X2100 Series

Any of these above cards will not see a newer Linux driver release past Catalyst 9.3.

Are we screwed?

@fermulator.

Indeed, I thought something could be wrong with the latest patch of Ubuntu/8.10 xserver.

My card is an X1300.

Yes, indeed we are screwed.

For several reasons:

1) Staying with fglrx (even if it worked), woudl mean renounce to new releases of Ubuntu/Linux

2) Choosing the ati driver I noticed about 1/2 frames per second with respect to fglrx. It is not bad but the card works half it could.

3) I tried to install Ubuntu/8.04: the problem is still there with 9.3. I tried Ubuntu/8.10 with 9.3, 9.2, 9.1, 8.12, but none of this seems to work. For a moment 9.1 gave me some hope, for a moment only.

4) Having found no way to make fglrx working (of course I haven't tried all the permutations/fixes--just a simple ati driver install), I see no other way that to stick to the ati driver.

5) The ati driver behaves not badly, but worse than fglrx. A possibility is that the legacy drivers will go open source--I really hope so. If not, we need to wait some saint hacker who keeps opening the way to a perfect opensource ati driver.

Luca Maranzano (liuk001) wrote :

After upgrading from 8.10 to 9.04 64 bit on my HP EliteBook 8530p with ATI HD 3650, I can confirm that fglrx 8.600 provided by Jaunty is not working.
The machine is hanging with Black Screen of Death.
The Xorg.0.log is not reporting anything useful. I was not able to catch any other message from the kernel.
Tryed even with previous kernel 2.6.27-11 from 8.10, same black screen of death.
Even tryed with fglrx 8.602 downloaded from ATI site and installed from sources following this guide:
http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide

With 8.10 the fglrx driver was working fine.

Bad thing unfortunately.

Cheers,
Luca

lucag73 (luca-giuzzi) wrote :

I also have a 8530p; I can attest that the workaround with aticonfig does not work.
My Xorg.log is slightly different from the one attached to the bug, since it appears that the card is
properly initialised (but still I cannot see anything). I attach the relevant file.

There is no trace of kernel oops in the syslog, though and while there are errors, it appears they are not fatal.
 the relevant messages are the following:

May 6 21:55:00 poseidon kernel: [ 16.479318] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
May 6 21:55:00 poseidon kernel: [ 16.492932] [fglrx] Maximum main memory to use for locked dma buffers: 3667 MBytes.
May 6 21:55:00 poseidon kernel: [ 16.493255] [fglrx] vendor: 1002 device: 9591 count: 1
May 6 21:55:00 poseidon kernel: [ 16.493691] [fglrx] ioport: bar 4, base 0x7000, size: 0x100
May 6 21:55:00 poseidon kernel: [ 16.496791] [fglrx] Driver built-in PAT support is enabled successfully
May 6 21:55:00 poseidon kernel: [ 16.496910] [fglrx] module loaded - fglrx 8.60.40 [Mar 14 2009] with 1 minors
May 6 21:55:04 poseidon kernel: [ 75.473737] fglrx_pci 0000:01:00.0: irq 2295 for MSI/MSI-X
May 6 21:55:04 poseidon kernel: [ 75.483127] [fglrx] Firegl kernel thread PID: 4151
May 6 21:55:04 poseidon kernel: [ 75.507124] [fglrx] Gart USWC size:1849 M.
May 6 21:55:04 poseidon kernel: [ 75.507126] [fglrx] Gart cacheable size:60 M.
May 6 21:55:04 poseidon kernel: [ 75.507128] [fglrx] Reserved FB block: Shared offset:0, size:1000000
May 6 21:55:04 poseidon kernel: [ 75.507130] [fglrx] Reserved FB block: Unshared offset:fc34000, size:3c7000
May 6 21:55:04 poseidon kernel: [ 75.507131] [fglrx] Reserved FB block: Unshared offset:fffb000, size:5000
May 6 21:55:05 poseidon kernel: [ 75.912601] [fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* interrupt source ff000066 is not supported on this hardware (return code = 1)
May 6 21:55:09 poseidon kernel: [ 80.653035] fglrx_pci 0000:01:00.0: irq 2295 for MSI/MSI-X
May 6 21:55:09 poseidon kernel: [ 80.672499] [fglrx] Firegl kernel thread PID: 4215
May 6 21:55:09 poseidon kernel: [ 80.674812] [fglrx] Gart USWC size:1849 M.
May 6 21:55:09 poseidon kernel: [ 80.674814] [fglrx] Gart cacheable size:60 M.
May 6 21:55:09 poseidon kernel: [ 80.674817] [fglrx] Reserved FB block: Shared offset:0, size:1000000
May 6 21:55:09 poseidon kernel: [ 80.674818] [fglrx] Reserved FB block: Unshared offset:fc34000, size:3c7000
May 6 21:55:09 poseidon kernel: [ 80.674819] [fglrx] Reserved FB block: Unshared offset:fffb000, size:5000
May 6 21:55:10 poseidon kernel: [ 80.865052] [fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* interrupt source ff000066 is not supported on this hardware (return code = 1)

[I then forced a shutdown]

Best,
 lg

Georges Jamieson (jamiesons) wrote :

So if I understand correctly, many ATI chipsets will no longer be supported by the fglrx driver under Ununtu and some other distributions of Linux. No atempt will be made by AMD to maintain support for even relatively recent chipsets and using the fglrx driver is really just gambling. This means Ubnuntu users need to switch to NVIDIA cards. I have been strugling with this bug/problem for several weeks and am ready to give up. Am I understanding this correctly?

Georges,

How is this related to the bug? Just for the record, the mobility radeon 3650 mentioned in the initial posting is not one of the "older" cards not supported anylonger since fglrx 9.4. However, these cards are supposed to be supported by the open source driver - the efforts AMD has done to release documents to improve those drivers is remarkable.

Dominik Grafenhofer (dpjg) wrote :

Under openSUSE 11.1 (64bit) it seems that with catalyst 9.5 the problem is gone (I am using an ATI Mobility Radeon HD 3650). The X server starts up just fine without using "aticonfig --acpi-services=off". (This also solves a problem with the HDMI output (hot-plug) recognition.)

I am sorry, that I cannot test this under Ubuntu at the moment. As the problem seems to be rather distribution independent, this information might be valuable anyway.

Hi Dominik,
good to know, thank you.
Please can you provide the following info:
- Xorg version provided by OpenSUSE
- Kernel version provided by OpenSUSE
- Exact version of flgrx driver provided by OpenSUSE

I really cannot understand what is causing the kernel BUG with my
combination of ATI HD3650, Xorg 1.6.0, fglrx 8.612 (built from Catalyst
9.5), Kernel 2.6.28-12 (tryed also 2.6.27-11).

Cheers,
Luca

On Wed, Jun 10, 2009 at 11:41 AM, Dominik Grafenhofer <
<email address hidden>> wrote:

> Under openSUSE 11.1 (64bit) it seems that with catalyst 9.5 the problem
> is gone (I am using an ATI Mobility Radeon HD 3650). The X server starts
> up just fine without using "aticonfig --acpi-services=off". (This also
> solves a problem with the HDMI output (hot-plug) recognition.)
>
> I am sorry, that I cannot test this under Ubuntu at the moment. As the
> problem seems to be rather distribution independent, this information
> might be valuable anyway.
>
> --
> fglrx versions newer than 8.543 cause system hang and panic
> https://bugs.launchpad.net/bugs/314600
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “fglrx-installer” source package in Ubuntu: Confirmed
>
> Bug description:
> I am currently using Jaunty with the latest 2.6.28-4-generic #8-Ubuntu
> x86-64 kernel, and any time I try to use fglrx 8.552 or 8.561 (apt-pinned to
> Intrepid X server and libdrm2), I get the system hanging at a black screen
> when I try to start X, followed by a kernel panic after I try pressing a few
> keys. See attached logfile for a serial-console stacktrace.
>
> Interestingly enough, fglrx reports itself as version 8.56.4, which seems a
> bit mismatched from the package version number 8.561. In addition, using
> the official ATI installer to buildandinstallpkg Ubuntu/intrepid within the
> Intrepid LiveCD gives the same result.
>
> [lspci]
> 00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset
> Memory Controller Hub [8086:2a40] (rev 07)
> Subsystem: Hewlett-Packard Company Device [103c:30e7]
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility
> Radeon HD 3650 [1002:9591]
> Subsystem: Hewlett-Packard Company Device [103c:3604]
>
>

@Liuk: Sure! Here is the info:

- Xorg version provided by OpenSUSE
X.Org 7.4 (also X.Org X Server 1.5.2)

- Kernel version provided by OpenSUSE
2.6.27.23 (Likely to be heavily patched by OpenSUSE; exact name kernel-default 2.6.27.23-0.1.1)

- Exact version of flgrx driver provided by OpenSUSE
The Catalyst Control Center claims: 8.61.2

Did turning acpi-services=off workaround solve the crash for you in the first place [because this worked for me under 8.10 (32-bit, catalyst 9.3) and ubuntu 9.04 (64-bit, catalyst pre-9.4)]; see:
http://phoronix.com/forums/showthread.php?t=15215

Best,
Dominik

Luca Maranzano (liuk001) wrote :

Great Dominik! A BIG thank you! I was getting crazy about this, you avoided me a downgrade to 8.10 :-)

Turning acpi-services=off it seems to work!

Ctrl-Alt-F1 switch to VC works
Suspend and resume works
Compiz works
VMware Workstation 3D acceleration works

I've only a message like this from the kernel:
[fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* interrupt source ff000066 is not supported on this hardware (return code = 1)

but for the moment it seems harmless

And, not less important, now my laptop is back to a normal temperature!
Look at this:

liuk@spock:~$ acpi -t
     Battery 0: Full, 100%
     Thermal 0: ok, 16.0 degrees C
     Thermal 1: ok, 38.0 degrees C
     Thermal 2: ok, 46.0 degrees C
     Thermal 3: ok, 34.3 degrees C
     Thermal 4: ok, 40.0 degrees C
     Thermal 5: ok, 30.0 degrees C

Please note that after the upgrade to Jaunty with the radeonhd driver, the Thermal 2 values was always between 56 and 62 degrees!!! and my battery duration dropped down from 3 hours to less than 2 hours!

Thanks again.
HTH to others with the same issue.
Cheers,
Luca

Georges Jamieson (jamiesons) wrote :

Mathais,

I do not mean in any way to disparage anyone's efforts in writing drivers for graphics cards. My comment was simply an attempt to summarize the situation with respect to getting a graphics card to work under X based on what I read in the bug reports. I upgraded from an ATI 9600 to an ATI 2400 HD and from a one Viewsonic monitor to a newer Viewsonic monitor. I finally got the vesa driver to work yesterday but still have no 3D acceleration.

I started with Linux (Slackware) around 1993. Getting X to work has always been a pain. In spite of much progress in auto detecting cards, monitors etc, I seem to always have a combination of hardware and software that requires hours of effort to make X work and it has recently been getting worse instead of better. I have an ASUS motherboard a Viewsonic monitor and ATI graphics cards, hardly no name manufacturers. Lately, none of the live Linux distributions I've tried work on any of my computers (two desktops, Acer and Compaq laptops and an Apple Macbook Pro running Parallels). In each case the issue is X.

Bryce Harrington (bryce) on 2009-06-26
summary: - fglrx versions newer than 8.543 cause system hang and panic
+ [HD 3650] fglrx versions newer than 8.543 cause system hang and panic
Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Dana Goyette (danagoyette) wrote :

Hmm, the issue still happens for me with 8.620, on Karmic (2.6.30-10-generic); I haven't yet tried it on Jaunty. the aticonfig --acpi-services=off workaround still works.

Bryce Harrington (bryce) on 2009-07-06
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
phiamo (phiamo) wrote :

Hello,
I have an thinkpad t500 with switchable grafics, an intel and an 3650 ati:
lspci| grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650

first attemts to get ati driver working have not been successful. i tried some different howtos but have not been abled to get it working.
i needed to work and simply switched to intel, but had poor performance. so i followed the guide on http://www.ubuntugeek.com/intel-graphics-performance-guide-for-ubuntu-904-jaunty-users.html

So currently i am using
2.6.30-020630-generic #020630 SMP Wed Jun 10 09:04:38 UTC 2009 x86_64 GNU/Linux
on jaunty with
X.Org X Server 1.6.0
Release Date: 2009-2-25

Now i would need to have some accelerated 3d in some cases and was wondering how far your work advanced.
I would like to help further testing the current development status.

could you please recommend how to do and which drivers to use at this moment ?
which would be the correct repository to get fglrx drivers from , i am a little bit confused, cause i testet so many different for intel and ati drivers, so i am not sure where we are at the moment.

regards philipp

Marc Kaplan (marc-kaplan) wrote :

While further attempts to patch this issue are undertaken, is there any way, other than removing the card and accessing shell through the onboard video to implement the test/install/make changes? I often get tired of taking the card in and out to test updates and would wlecome a workaround just to be able to access a command prompt without the kernel panic, I'm using the machine as a server, but eventually want to use the card so I can have a gui desktop interface.

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Alberto Milone (albertomilone) wrote :

Can you see if you can still reproduce the problem with the latest driver in Ubuntu Karmic, please?

Luca Maranzano (liuk001) wrote :

Hi,

I faced the fglrx bug on my Jaunty upgrade with my EliteBook 8530p and ATI HD 3650.
I solved it with the Catalyst version 9.5 and 9.6 (8.620) which seems quite stable (the --acpi-services=off was still necessary) downloaded from the ATI site.

I've also tryed the Catalyst 9.7, 9.8 and the latest 9.9. But:
- 9.7 and 9.8 have an annoying black flickering when paging up and down (for example inside a Gnome Terminal at full screen, or in Firefox)
- 9.9 is IMHO completely broken, just after the installation I got a Kernel NULL pointer error

Obviously I'm sticking to 9.6 :-)

So my question is: which version of Catalyst are you using for Karmic?

Thanks.
Luca

Alberto,

As requested, I checked the status on karmic, and unfortunately, the bug persists (2:8.660-ubuntu2 and a fully updated, fresh install of karmic beta.)

However, --acpi-services=off is still applicable as workaround.

Regards
Matt

Jammy Zhou (jammy-zhou) wrote :

Hi,
This platform specific issue may be caused by some potential system BIOS bug. Can anyone dump the DSDT table of the system BIOS on HP EliteBook 8530p with ATI Radeon HD 3650?

Regards,
Jammy

Jammy Zhou (jammy-zhou) wrote :

And could you please have a try to disable the BIOS option "Fan always ON on AC Power" under "System Config" -> "Device Config" and then verify this issue again?

Regards,
Jammy

Jammy,

I'm attaching a dump of the DSDT on my EliteBook 8530p. On a side note, I'm interested in what you will do to check whether a BIOS bug may be responsible for the issue. Can you maybe outline your procedure?

As for the "Fan aways ON" setting, I keep that one disabled anyway.

Regards and thank you
Matt?field.comment=Jammy,

I'm attaching a dump of the DSDT on my EliteBook 8530p. On a side note, I'm interested in what you will do to check whether a BIOS bug may be responsible for the issue. Can you maybe outline your procedure?

As for the "Fan aways ON" setting, I keep that one disabled anyway.

Regards and thank you
Matt

Blu (blutack) wrote :

I am experiencing a similar but possibly unrelated issue on a Toshiba A300-1K5, which contains an ATI HD3650. With the ATI driver installed as normal, a standard boot will cause a kernel panic. However, booting in recovery mode, then going to init 5 and running startx does not cause a kernel panic and the graphics work correctly. If any more information would help, please let me know.

Many Thanks
--G

stricjux (luka-birsa) wrote :

Bug persists on Karmic Koala final (upgraded from beta to: 2.6.31-14-generic x86_64 SMP)

I tried:
aticonfig --initial
aticonfig --acpi-services=off

and I keep getting the black screen of death no matter what.
xorg-driver-fglrx version: 2:8.660-0ubuntu4

If needed I can provide log files (even if they don't report any errors).

lucag73 (luca-giuzzi) wrote :

In my case, everything seems to work properly (provided acpi-services is disabled).
I upgraded directly from 9.04. Just in case, I include my xorg.conf (which is minimal) as well as a copy of
/etc/ati/amdpcsdb which might be more helpful.

lg

lucag73 (luca-giuzzi) wrote :

Here there is amdpcsdb

Dana Goyette (danagoyette) wrote :

I've just discovered something interesting, after some time experimenting in Karmic -- somehow, I managed to catch a line about "failed to connect to acpid" just before the crash.

Apparently, the acpi-services part of the fglrx driver explicitly depends on having acpid up and running by the time Xorg starts, or else it fails rather inelegantly, as this bug report discusses.

I've managed to fix the problem on my system, by adding an explicit upstart dependency of 'acpid' for gdm.
I've edited /etc/init/gdm.conf as follows:

start on (filesystem
   and started hal
   and started acpid <=== Add this line.
   and tty-device-added KERNEL=tty7
   and (graphics-device-added or stopped udevtrigger))
stop on runlevel [016]

Dana Goyette (danagoyette) wrote :

Another new discovery: with acpi-services on, I save more power than with acpi-services off, even if both Battery and AC-Power are set to "low power usage" in amdccle. However, in exchange, having acpi-services enabled makes suspend fail -- system hangs even before going into suspend.

Peter Pettersen (gyathaar) wrote :

I can confirm that adding the line to /etc/init/gdm.conf allows turning on acpi-services

Dana Goyette (danagoyette) wrote :

I noticed that, as quickly as the change to gdm fixed it, the next upgrade of fglrx (not sure which version) re-broke it even after the init tweak.

Peter Pettersen (gyathaar) wrote :

the change to /etc/init/gdm.conf is still working with the latest driver (catalyst 10.1) is still working for me

Bryce Harrington (bryce) wrote :

[This bug was nominated for lucid, but no evidence exists in bug report that it still affects lucid, so the nomination is not acceptable at this time. A lucid compatible version of -fglrx was added just recently, so this needs retested.]

madmed (medbelh) wrote :

tested the beta 1 with no success :-(

Martin Rehn (minpost) wrote :

Still the case in the current Lucid. The system locks up hard the moment X tries to start, but only when the fglrx driver is selected in xorg.conf. AMD64 here. Please un-decline the nomination for lucid.

Alberto Milone (albertomilone) wrote :

Can you try to reproduce the problem in Lucid by installing the driver from Jockey, please?

Then (if X crashes), boot in recovery mode and:
1) save your logs:
cp /var/log/Xorg.0.log /home/$your_user_name_here/
cp /var/log/Xorg.0.log.old /home/$your_user_name_here/

2) disable the driver from jockey by typing:
jockey-text -d fglrx

3) Reboot by typing "reboot"

and attach the logs.

Schmankerl (schmankerl) wrote :

i installed fglrx via jockey and the result was the same.
xorg stopps with:

(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
dlopen: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: UpdateSpriteForScreen
(EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (loader failed, 7)
(EE) No drivers available.

Dana Goyette (danagoyette) wrote :

Interestingly enough, I've found that the fglrx version in Lucid no longer gets this panic, even without disabling acpi-services or modifying GDM's upstart settings. However, the 8.720 driver also has other regressions, in things such as suspend/resume support. If anyone still DOES have the issue (and has it fixed with the acpi-services=off command, specifically), then we can say the bug still exists.

That "undefined symbol" is an entirely different bug.

Schmankerl (schmankerl) wrote :

Sorry, wrong and outdated xorg.conf.

Last time I got:

(II) LoadModule: "fglrx"
(WW) Warning, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(EE) No drivers available.

I installed fglrx and could modprobe fglrx manually but not with xorg.conf

Alberto Milone (albertomilone) wrote :

@Schmankerl
are you sure that you're not experiencing the problem described in bug #554191 ?

Schmankerl (schmankerl) wrote :

In bug https://bugs.launchpad.net/bugs/554191 xorg is loading fglrx, but in my case its impossible to load that module (see #61). I tried installing driver via jockey again, but it doesn't recognize my 'ati mobility hd3650' anymore.

Schmankerl (schmankerl) wrote :

my solution: reinstall complete system and now it works fine. if you are using developer ubuntu you should reinstall after final. windows starting with minimal delay but I think thats normal.

Alberto Milone (albertomilone) wrote :

I think we can close this bug report as the problem reported by Dana can no longer be reproduced.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers