Comment 88 for bug 1424491

Joschi (joschi-a) wrote :

I switched to proposed and was able to install fglrx-updates without problems. After a reboot my .Xauthority file was owned by root causing me to be stuck at the login screen with poor screen resolution. I was able to fix the .Xauthority file:

sudo rm .Xauthority

The file got re-created a few times with root ownership (which should not be the case?) but after:

sudo /etc/init.d/lightdm stop
sudo /etc/init.d/lightdm start

it seemed to be recreated with user ownership so I SHOULD be able to login. However that was not the case.
Running

sudo Xorg -configure

gave the following error message:

******************************************************

X.Org X Server 1.16.0
Release Date: 2014-07-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-70-generic x86_64 Ubuntu
Current Operating System: Linux OO7-laptop 3.16.0-36-generic #48~14.04.1-Ubuntu SMP Wed Apr 15 13:11:28 UTC 2015 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-36-generic root=UUID=9ad1f2a0-562f-46da-82c0-4e0e403d7fbc ro quiet splash vt.handoff=7
Build Date: 12 February 2015 11:11:26PM
xorg-server 2:1.16.0-1ubuntu1.2~trusty2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.30.2
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 19 15:03:54 2015
List of video drivers:
 mga
 savage
 fglrx
 intel
 radeon
 neomagic
 sisusb
 tdfx
 trident
 vmware
 openchrome
 r128
 nouveau
 mach64
 siliconmotion
 ati
 cirrus
 vesa
 fbdev
 modesetting
(++) Using config file: "/home/user/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] drm report modesetting isn't supported.
(EE)
(EE) Backtrace:
(EE) 0: Xorg (xorg_backtrace+0x48) [0x7f90200beed8]
(EE) 1: Xorg (0x7f901ff1a000+0x1a8f19) [0x7f90200c2f19]
(EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f901e09a000+0x36d40) [0x7f901e0d0d40]
(EE)
(EE) Segmentation fault at address 0x0
(EE)
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE)
(EE)
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.

******************************************************

any ideas what i can do about that?