Comment 231 for bug 1068404

naught101 (naught101) wrote :

I'm hitting this bug, and I can't get any of the workarounds to work. I'm on Kubuntu Saucy, and I've tried fglrx, fglrx-updates, fglrx from x-edgers (https://launchpad.net/~xorg-edgers/+archive/ppa?field.series_filter=saucy), and three versions of the AMD binary driver (13.4, 13.9, and 13.11 beta). Nothing works, I get segfaults with everything, straight after it tries to load GLX (the segfault byte identifier is different each time, but I guess that could be because of un-related code changes). I didn't try the andrikos version (https://launchpad.net/~andrikos/+archive/ppa) because it's not available for saucy. Any ideas what else I can try?

$ lspci -v|grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (prog-if 00 [VGA controller])

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

$ uname -a
Linux naught101-chronos 3.12.0-031200rc6-generic #201310191635 SMP Sat Oct 19 20:36:43 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The attached Xorg.1.log is for the binary version, but I get basically the same error with the xedgers version.