fglrx-installer-updates are always outdated, better update management is *really* needed

Bug #1022898 reported by MC Return on 2012-07-10
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
High
Alberto Milone

Bug Description

Currently, on Quantal, fglrx-updates has the version 2:9.000-0ubuntu3, while AMD already has released 2:9.010-0ubuntu1, which is as far as I know, the only version running with xserver-xorg 1.13.

More speed regarding fglrx updates would really be nice.

The fglrx-installer package is not updated once a version of Ubuntu is released. That is what fglrx-installer-updates is for.

affects: fglrx-installer (Ubuntu) → fglrx-installer-updates (Ubuntu)
Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-08-23
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - fglrx-installer 2:8.960-0ubuntu5 is outdated
+ fglrx-installer-updates 2:8.960 needs updated to 8.980
Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
summary: - fglrx-installer-updates 2:8.960 needs updated to 8.980
+ fglrx-installer-updates 2:8.960 needs updated to 8.982
description: updated
description: updated
summary: - fglrx-installer-updates 2:8.960 needs updated to 8.982
+ fglrx-installer-updates 2:8.960 needs update to 8.982

I tried fglrx-updates_8.982-0ubuntu0.1_amd64.deb from precise-proposed today and the installation failed with: "Error! Application of patch fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch failed". No fglrx_updates.ko was build:

| $ uname -srvmpio
| Linux 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:52:48 UTC 2012
| x86_64 x86_64 x86_64 GNU/Linux
|
| $ vim /etc/apt/sources.list
| ...
| deb http://archive.ubuntu.com/ubuntu/ precise-proposed restricted
| main multiverse universe
| ...
|
| $ apt-get update
|
| $ apt-get install fglrx-updates
| ...
| Building only for 3.2.0-30-generic
| Building for architecture x86_64
| Building initial module for 3.2.0-30-generic
| Error! Application of patch
| fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch failed.
| Check /var/lib/dkms/fglrx-updates/8.982/build/ for more information.
| update-initramfs: deferring update (trigger activated)
| Processing triggers for bamfdaemon ...
| Rebuilding /usr/share/applications/bamf.index...
| Setting up fglrx-amdcccle-updates (2:8.982-0ubuntu0.1) ...
| Processing triggers for initramfs-tools ...
| update-initramfs: Generating /boot/initrd.img-3.2.0-30-generic
| Processing triggers for libc-bin ...
| ldconfig deferred processing now taking place
|
| $ ls -1 /lib/modules/3.2.0-30-generic/updates/dkms
|
| $ ls -1 /var/lib/dkms/fglrx-updates/8.982/build
| ...
| firegl_public.c
| firegl_public.c.rej
| ...
|
| $ ls -1 /var/lib/dkms/fglrx-updates/8.982/build/patches
| fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch
| replace-do_mmap-and-do_munmap-with-vm_mmap-and-vm_mu.patch
| replace-for_each_cpu_mask-with-for_each_possible_cpu.patch
| replace-global-lock-with-a-driver-specific-mutex.patch

Removing the patch from the archive solves the problem:

| $ dpkg-deb -x fglrx-updates_8.982-0ubuntu0.1_amd64.deb fglrx-updates
|
| $ dpkg-deb -e fglrx-updates_8.982-0ubuntu0.1_amd64.deb
| fglrx-updates/DEBIAN
|
| $ rm fglrx-updates/usr/src/fglrx-updates-8.982/patches/fix-build-
| issue-on-i386-where-TS_USEDFPU-is-no-longe.patch
|
| $ vim fglrx-updates/usr/src/fglrx-updates-8.982/dkms.conf
| ...
| #PATCH[0]="fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch"
| ...
|
| $ dpkg-deb -b fglrx-updates fglrx-updates_8.982-0ubuntu0.1.1_amd64
| .deb
|
| $ dpkg --install fglrx-updates_8.982-0ubuntu0.1.1_amd64.deb
|
| $ ls -1 /lib/modules/3.2.0-30-generic/updates/dkms
| fglrx_updates.ko

I have the same error on my pc

2012/9/9 Clemens Fuchslocher <email address hidden>

> I tried fglrx-updates_8.982-0ubuntu0.1_amd64.deb from precise-proposed
> today and the installation failed with: "Error! Application of patch
> fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch failed". No
> fglrx_updates.ko was build:
>
> | $ uname -srvmpio
> | Linux 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:52:48 UTC 2012
> | x86_64 x86_64 x86_64 GNU/Linux
> |
> | $ vim /etc/apt/sources.list
> | ...
> | deb http://archive.ubuntu.com/ubuntu/ precise-proposed restricted
> | main multiverse universe
> | ...
> |
> | $ apt-get update
> |
> | $ apt-get install fglrx-updates
> | ...
> | Building only for 3.2.0-30-generic
> | Building for architecture x86_64
> | Building initial module for 3.2.0-30-generic
> | Error! Application of patch
> | fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch failed.
> | Check /var/lib/dkms/fglrx-updates/8.982/build/ for more information.
> | update-initramfs: deferring update (trigger activated)
> | Processing triggers for bamfdaemon ...
> | Rebuilding /usr/share/applications/bamf.index...
> | Setting up fglrx-amdcccle-updates (2:8.982-0ubuntu0.1) ...
> | Processing triggers for initramfs-tools ...
> | update-initramfs: Generating /boot/initrd.img-3.2.0-30-generic
> | Processing triggers for libc-bin ...
> | ldconfig deferred processing now taking place
> |
> | $ ls -1 /lib/modules/3.2.0-30-generic/updates/dkms
> |
> | $ ls -1 /var/lib/dkms/fglrx-updates/8.982/build
> | ...
> | firegl_public.c
> | firegl_public.c.rej
> | ...
> |
> | $ ls -1 /var/lib/dkms/fglrx-updates/8.982/build/patches
> | fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch
> | replace-do_mmap-and-do_munmap-with-vm_mmap-and-vm_mu.patch
> | replace-for_each_cpu_mask-with-for_each_possible_cpu.patch
> | replace-global-lock-with-a-driver-specific-mutex.patch
>
> Removing the patch from the archive solves the problem:
>
> | $ dpkg-deb -x fglrx-updates_8.982-0ubuntu0.1_amd64.deb fglrx-updates
> |
> | $ dpkg-deb -e fglrx-updates_8.982-0ubuntu0.1_amd64.deb
> | fglrx-updates/DEBIAN
> |
> | $ rm fglrx-updates/usr/src/fglrx-updates-8.982/patches/fix-build-
> | issue-on-i386-where-TS_USEDFPU-is-no-longe.patch
> |
> | $ vim fglrx-updates/usr/src/fglrx-updates-8.982/dkms.conf
> | ...
> | #PATCH[0]="fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch"
> | ...
> |
> | $ dpkg-deb -b fglrx-updates fglrx-updates_8.982-0ubuntu0.1.1_amd64
> | .deb
> |
> | $ dpkg --install fglrx-updates_8.982-0ubuntu0.1.1_amd64.deb
> |
> | $ ls -1 /lib/modules/3.2.0-30-generic/updates/dkms
> | fglrx_updates.ko
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1022898
>
> Title:
> fglrx-installer-updates 2:8.960 needs update to 8.982
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1022898/+subscriptions
>

Changed in fglrx-installer-updates (Ubuntu):
milestone: none → precise-updates
MC Return (mc-return) on 2012-11-03
summary: - fglrx-installer-updates 2:8.960 needs update to 8.982
+ fglrx-installer-updates are always outdated, better update management is
+ *really* needed
MC Return (mc-return) on 2012-11-03
description: updated
description: updated

Hello MC, or anyone else affected,

Accepted fglrx-installer-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:9.000-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

As I understand original report - this is Quantal problem, not only Precise. So newer package in precise-proposed not much help fot fglrx users on Quantal.

tags: added: verification-failed
removed: verification-needed
Steve Langasek (vorlon) wrote :

The purpose of requesting verification of the SRU is to get confirmation that the new package works in the suite that it's been published to. Marking the bug 'verification-failed' because it doesn't fix anything in a release it wasn't uploaded to is counterproductive.

tags: added: verification-done
removed: verification-failed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:9.000-0ubuntu0.1

---------------
fglrx-installer-updates (2:9.000-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream release (LP: #1032672, LP: #1022898).
  * debian/dkms.conf.in:
    - Do not apply any kernel patch (LP: #1048142)
  * debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.
    - Make sure that all binaries in /usr/bin are executable.
    - Correct the path to Qt libraries on i386.
  * Merge fixes from the upstream installer:
    - Fix openCL issues running x86 binaries on x86_64.
    - Make sure that dh_shlibdeps doesn't complain about missing qt
      libraries.
  * Switch to dpkg-source 3.0 (quilt) format (as it's not
    a native package).
 -- Alberto Milone <email address hidden> Wed, 17 Oct 2012 07:55:03 +0200

Changed in fglrx-installer-updates (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers