Ubuntu

New fglrx 8.42.3 to Gutsy

Reported by Giovanni Lovato on 2007-10-23
52
Affects Status Importance Assigned to Milestone
fglrx-driver (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.22 (Ubuntu)
Wishlist
Unassigned

Bug Description

The new fglrx 8.42.3 is out. It claims to support AIGLX and other important improvements, please backport it to Gutsy!

sticks (orawas) wrote :

I second that!!

Filip Milivojevic (zekica) wrote :

This is very important thing to all those > R300 ATI users, not only because of AIGLX but because of "huge" speed improvements for OpenGL application.

Please backport it.

whasssaaa (whasssaaa-gmail) wrote :

Let me be the next person to ask for this one big favor,

to add, i don't think it's going to happen real soon because the driver needs to be tested of course

Me to! This is a big improvement for all Ati/Amd-Users. Don't leave us out in the rain! ;)

Any word if this fixes the suspend/resume issues with the existing Gutsy fglrx package?

Changed in fglrx-driver:
status: New → Invalid
gerbalblaste (gerbalblaste) wrote :

suspend/resume problem is not fixed, aiglx works but not as well as glx, and boot time is substantially increased. These are my experiences, ymmv.
Very likely my system configuration is not optimized for this new driver.

Antonio Sampaio (antls) wrote :

Please, please, please, please!

André Klitzing (misery) wrote :

Thanks for report! But no more "me too" and "please do it" posts, please. Everyone knows the huge interest in ati's AIGLX support. It would only make this bug-report unreadable. :-)

By the way... there is a bug for amd64 in the new version.
Info: http://phoronix.com/forums/showthread.php?t=5947

*snipp*
Michael:
For those with Ubuntu 64-bit problems, below is a link to the updated Ubuntu packaging scripts done by Aric Cyr, which will be found in fglrx 8.43 (along with other updates I imagine). It fixes the 64-bit problem.

http://www.michaellarabel.com/downloads/fglrx-8.42-ubuntu+debian-2.tar.bz2

Extract it to /etc/ati/custom-package and then with the 8.42 package run --buildpkg custom-package/7.10 (or 7.04 for Feisty)

---

aoanla:
I've posted about this on the Ubuntu forums.
Basically, though, you can unpack the installer into another directory by doing:
./ati-driver-installer-8.42.3-x86.x86_64.run --extract name-of-directory
then extract the other archive that Michael linked to into the same directory (choosing to replace files)
then, Cd into that directory and type

sudo ./ati-installer.sh 8.42.3 --install
(or ./ati-installer.sh 8.42.3 --buildpkg Ubuntu/gusty
if you're following the Ubuntu wiki HOWTO)
*/snip*

Davim (davim) wrote :

I think this is very important for the composite by default and it would solve the problem with wacom tablets and XGL :) please backport this driver.

Giovanni Lovato (heruan) wrote :

I think we can wait a better release or buy a graphic card other than AMD/ATI.
This fglrx 8.42.3 supports AIGLX but it's 50% slower than XGL.
I'm turning back to 8.37.6 + XGL!

Bryce Harrington (bryce) wrote :

Due to popular demand, I've packaged this fglrx up for Gutsy testers:

  http://people.ubuntu.com/~bryce/Testing/fglrx-8.42.3-Gutsy/

From the comments from testers so far, sounds like the performance is poor here so I'm doubtful we'll incorporate it for Hardy, let alone backport for Gutsy. (Fwiw, as far as I know we've never done l-r-m backports.) But I'll host the deb's at this location at least until the next fglrx for those wishing to play with it.

Changed in linux-restricted-modules-2.6.22:
importance: Undecided → Wishlist
status: New → Fix Committed
hobhinio (sebashome) wrote :

I think we MUST wait for a much beter relase. I tested it and it works horrible.

John Dong (jdong) wrote :

HEADS UP:

This release is not "perfect" and may be a regression from previous releases. Phoronix reports mixed success, not to mention xorg.conf needs to change a bit (un-disable composite extensions), video flickering in Compiz, and Compiz needing backporting.

Please be careful and get plenty of feedback before doing this as a Gutsy LRM update...

Bryce Harrington (bryce) wrote :

I don't think we normally backport linux-restricted-modules since it is so invasive. In any case, we would not backport a fglrx that is not regression-free, and since it's closed source we have no mechanism for us to fix the regressions from our side. Thus, I'm closing this as WONTFIX. Thanks everyone that tested this.

I'll leave the debs on my site for a while, if others wish to test it out themselves, but this looks like another dud fglrx.

Changed in linux-restricted-modules-2.6.22:
status: Fix Committed → Won't Fix
John Smith (jsprojects) wrote :

I'm going to have to say nay to this, even though I am an ATI user. This version does bring AIGLX support, but the downside now is that it does not work with the new 2.6.23 kernel. I say when 8.43 comes out with the new ABI support in the 2.6.23 kernel, then it deserves something like fglrx-new in the Ubuntu Repositories.

leonya (leonya) wrote :

Actually, I have one good reason why I couldn't stay with the 8.37 - when used with the new xorg, it doesn't properly support multiple monitors with different resolutions. Once I upgraded to Gutsy, I had to upgrade to fglrx 8.42 to get the dual monitors to work correctly (which they did using Ubuntu 7.04 and fglrx 8.37). So, for me, staying with 8.37 was just not an option.

Giovanni Lovato (heruan) wrote :

The fglrx versione 8.42.3 is on Hardy repositories.
For all those who want to run AIGLX-enables 8.42.3 fglrx driver on Gutsy, here is the how-to:

Create a new file in /etc/apt/sources.list.d, for example /etc/apt/sources.list.d/hardy.list, and add hardy repositories:
deb http://it.archive.ubuntu.com/ubuntu/ hardy main restricted universe multiverse

Then create /etc/apt/preferences with the following contents:

Package: *
Pin: release a=gutsy
Pin-Priority: 600

Package: linux-restricted-modules-*
Pin: release a=hardy
Pin-Priority: 650

Package: xorg-driver-fglrx
Pin: release a=hardy
Pin-Priority: 650

Package: *
Pin: release a=hardy
Pin-Priority: 300

Now do an apt-get update/dist-upgrade to install the new fglrx!

Giovanni Lovato (heruan) wrote :

I noticed that the wildcard "*" works only for the meaning of "all packages" and not as "all packages that begins with..." so the line:
Package: linux-restricted-modules-*
should be changed to:
Package: linux-restricted-modules-2.6.22-14-generic
or with your current kernel version (run "uname -r" to find out which).

This hardy driver adds the infamous testing release logo, which I managed to get rid of by adding a /etc/ati/signature file with "29b717420cc341b8075342c73157b5f5:119923713fee718f366272fe507a85c01c8f22734fee00ec4e7371f0066185c5:18862e7b3ef07689343527a206668d931a8121703bf127dd326375a60962d6c518d42f243ef1768b333527a20167d0961dd220713bf22788376574f60962d6c0"
This string was obtained by downloading ATI's driver, and doing 'head -n 300 ati-driver-installer-7-11-x86.x86_64.run | egrep "signature="'.

Spoke to soon. Adding the signature doesn't remove the idiotic logo, only the "testing part" of it. Now I have a "Unsupported hardware" logo in the right hand corner.

Generating and installing the deb files from the ati-driver-installer-7-11-x86.x86_64.run gets rid of the logo, but gives a error that DRI is available only for xorg > 7.1.0.0 in Xorg.0.log.

Some googling lead me to http://www.phoronix.com/scan.php?page=news_item&px=NTkyMg. I extracted the ati-driver-installer package, and copied ("sudo cp ./common/etc/ati/control /etc/ati/") the control file. That got rid of the "unsupported hardware" logo. My question is, shouldn't these two files be included in the hardy fglrx* packages?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers