Ubuntu

fails to playback ogv produced by recordmydesktop

Reported by Adam Buchbinder on 2008-12-04
88
This bug affects 13 people
Affects Status Importance Assigned to Milestone
FFmpeg
Fix Released
Unknown
ffmpeg (Ubuntu)
Medium
Unassigned

Bug Description

Consider the attached Ogg file, with Theora video and Vorbis audio, produced with recordmydesktop. (The sound track is silent.)

The following command works, and produces the correct output--an Ogg file containing only the Vorbis stream from the original input.

$ ffmpeg -i theora-vorbis-sample.ogg -vn -acodec copy out.ogg

However, the following produces the following, and the output doesn't contain the video; ogginfo reports that the stream, which should be Theora-only in an Ogg package, has "Warning: EOS not set on stream 1".

$ ffmpeg -i theora-vorbis-sample.ogg -an -vcodec copy out.ogg
FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Oct 3 2008 22:40:31, gcc: 4.3.2
[theora @ 0xb7ebc2f0]Theora bitstream version 30201
[theora @ 0xb7ebc2f0]560 bits left in packet 81
[theora @ 0xb7ebc2f0]7 bits left in packet 82
Input #0, ogg, from 'theora-vorbis-sample.ogg':
  Duration: 00:00:12.6, start: 0.000000, bitrate: 204 kb/s
    Stream #0.0: Invalid Codec type -1
    Stream #0.1: Video: theora, yuv420p, 304x304 [PAR 1:1 DAR 1:1], 15.00 tb(r)
    Stream #0.2: Audio: vorbis, 22050 Hz, stereo, 171 kb/s
Output #0, ogg, to 'out.ogg':
    Stream #0.0: Video: libtheora, yuv420p, 304x304 [PAR 0:1 DAR 0:1], q=2-31, 15.00 tb(c)
Stream mapping:
  Stream #0.1 -> #0.0
Press [q] to stop encoding
frame= 0 fps= 0 q=-1.0 Lsize= 3kB time=10000000000.0 bitrate= 0.0kbits/s
video:0kB audio:0kB global headers:0kB muxing overhead inf%

The issue is not with the output container format; I get truncated AVI, MOV and MKV files as well. It appears that ffmpeg is not copying the Theora video correctly.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: ffmpeg 3:0.svn20080206-12ubuntu3
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: ffmpeg-debian
Uname: Linux 2.6.27-7-generic i686

Changed in ffmpeg:
status: Unknown → New

I can reproduce this with ffmpeg SVN r16005 compiled myself. Filed upstream.

Reinhard Tartler (siretart) wrote :

thanks for forwarding it upstream

Changed in ffmpeg-debian:
status: New → Confirmed
Changed in ffmpeg:
status: New → Confirmed
affects: ffmpeg-debian (Ubuntu) → ffmpeg (Ubuntu)
Changed in ffmpeg (Ubuntu):
importance: Undecided → Medium

Lucid alpha 3: recordmydesktop ogv files can only be decoded using gstreamer: ffmpeg, vlc and kdenlive fails to decode video. PiTiVi loads ogv just fine.

Changed in ffmpeg:
status: Confirmed → Fix Released
summary: - ffmpeg outputs truncated files from ogv input.
+ fails to playback ogv produced by recordmydesktop
Ulrik Mikaelsson (rawler) wrote :

Will the upstream fix be pushed to Ubuntu before Lucid?

Reinhard Tartler (siretart) wrote :

I did have a look but didn't find the exact change that fixed this. If someone manages to create a minimal backport of this fix, then it can be included for lucid. otherwise I fear not.

Ivan Surzhenko (i-surzhenko) wrote :

Hi guys,

You may find a patch on this page:
https://roundup.ffmpeg.org/issue1723

I did review the source of the ffmpeg package from lucid: it is same.

So you can try to use this patch "as is". I can't test this one at work because I currently use koala.

I tried this patch, but it doesn't fix the issue, neither the original
attached ogv file, nor files created by recordmydesktop.

possibly this patch is party of the solution, but surely not sufficient.

Ivan Surzhenko (i-surzhenko) wrote :

Hm.. Which player did you use?

Reinhard Tartler (siretart) wrote :

I tested with ffplay

Usama Akkad (damascene) wrote :

I wonder if this is related.

OGV files not transcoded properly
http://www.google.pl/support/forum/p/youtube/thread?tid=7b9148c46c6b6f90&hl=en

I tried a record form recordmydesktop with this command
$ ffmpeg -i video.ogv video.avi

and got similar to this result:
http://www.youtube.com/watch?v=joAzMsP_2Zs

I tried it my self actually so I figured this staff

any way using the guide here fixed my problem as suggested in #ffmpeg @freenode

HOWTO: Install and use the latest FFmpeg and x264
http://ubuntuforums.org/showthread.php?t=786095

and I was able to convert video again and upload it successfully and the same file with corrupted output worked after converting

if this isn't related please tell me so I can copy this report to a new bug
thanks

Reinhard Tartler (siretart) wrote :

this is eseentially a request to update the ffmpeg package to a new svn
release. I'll won't do so before maverick opens, so no need to file yet
another report about this.

Alan Pope ㋛ (popey) wrote :

Will the update to ffmpeg be delivered as an SRU for Lucid?

Reinhard Tartler (siretart) wrote :

no; that would break otherwise unrelated packages.

Usama Akkad (damascene) wrote :

dose that mean that Lucid users who want to upload screen-cast to
youtube won't be able to?

              في Mon، 19-04-2010 عند 05:18 +0000 ، كتب Reinhard Tartler:
> this is eseentially a request to update the ffmpeg package to a new svn
> release. I'll won't do so before maverick opens, so no need to file yet
> another report about this.
>

Alan Pope ㋛ (popey) wrote :

It breaks anything that uses ffmpeg underneath to do video transcoding. OpenShot video editor is also exhibiting this bug.

Reinhard Tartler (siretart) wrote :

if someone can propose a fix (in form of a focused bugfix, not a request
that includes hundres of other unrelated changes), we can SRU this bug.

not ideal, but the workaround for posting recordMyDesktop videos to YouTube is to losslessly remux the ogg from recordmydesktop into .mkv using mkvtoolsnix and then upload

i.e.,

$ sudo aptitude install mkvtoolnix
$ mkvmerge -o theora-vorbis-sample.mkv theora-vorbis-sample.ogg
$ gnome-open http://upload.youtube.com/my_videos_upload
$

Follow the usual upload procedure using the .mkv as input.

Successfully results in http://www.youtube.com/watch?v=1dhz97zwO8Y

Dark Shikari (darkshikari) wrote :

Most likely the problem lies here:

r18986 | conrad | 2009-05-29 14:43:22 -0700 (Fri, 29 May 2009) | 1 line
Support block-level quantization in Theora

Lucid has apparently updated the Theora encoder library without updating the decoder to support the new features, resulting in obvious problems.

Of course, another obvious solution is to just use a better screen capture program, as described in http://verb3k.wordpress.com/2010/01/26/how-to-do-proper-screencasts-on-linux/ .

Usama Akkad (damascene) wrote :

I've tried this guide
http://verb3k.wordpress.com/2010/01/26/how-to-do-proper-screencasts-on-linux/

this gave the same problem:
ffmpeg -f alsa -i pulse -f x11grab -r 30 -s 1024x768 -i :0.0 -acodec pcm_s16le -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.mkv

but converting to avi solved it:
ffmpeg -i output.mkv output.avi

Dark Shikari (darkshikari) wrote :

@Usama

The guide tells you to compress the file when you're done with it and gives you guidelines for doing so ;). So that's intentional.

tags: added: patch
Doug Holton (edtechdev) wrote :

I'm using Ubuntu 10.04.

Those fixes like in comment #19 don't work when you upload the video to a site like Youtube. Converting the ogv to mkv first or avi first doesn't fix the issue.

There are many examples on youtube of videos that didn't convert because of this issue:
http://www.youtube.com/watch?v=kPiRak0aDAQ
http://www.youtube.com/watch?v=CQ9L6kk_vPU
http://www.youtube.com/watch?v=1wIsJLWZPco

On this youtube support page someone suggested that youtube might have an out of date version of ffmpeg or theora or whatever:
http://www.google.com/support/forum/p/youtube/thread?tid=7b9148c46c6b6f90&hl=en&fid=7b9148c46c6b6f90000484c1f228af9a

Is there anyway to down-convert an ogv file created by gtk-recordmydesktop (or cheese or whatever) to an older version of theora or whatever so that youtube can properly convert it and display it?

Or is there a ppa for the older version of theora or whatever.

Reinhard Tartler (siretart) wrote :

On Mon, Apr 19, 2010 at 18:33:29 (CEST), Hernando Torque wrote:

> I've applied the patch mentioned in #20 to the 0.5.1-1ubuntu1 sources
> and ogv files now play fine via ffplay. Patch attached (origin:
> https://git.ffmpeg.org/?p=ffmpeg;a=blobdiff;f=libavcodec/vp3.c;h=1646dd9dd43165e856cbe3d52445fac8a4b3459f;hp=9f7dfb62d7dfc6a22e4d3aed1c91c20308e9abff;hb=bab197002b561fb53abfa6e24def881f6ec86c9b;hpb=04d44987795c79f18ab428b9f93cacb2c18bd2da).

aha, this means that recordmydesktop uses a newer feature of ogg (block
level quantization). I've skimmed over the patch, but I don't consider
myself qualified to argue about its potential of regression. I'm
therefore inclined to reject this patch for ffmpeg 0.5.2 and therefore
the ubuntu package.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Nigel Babu (nigelbabu) wrote :

Based on siretart's comments and the current Ubuntu Reviewers Team policy, I'm tagging this patch as 'patch-rejected', please feel free to change the tag to 'patch' if you have another patch for review.

tags: added: patch-rejected
removed: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.6~svn20100505-1ubuntu1

---------------
ffmpeg (4:0.6~svn20100505-1ubuntu1) maverick; urgency=low

  * merge from debian/experimental. remaining changes:
    - don't disable encoders
    - don't build against libfaad, libdirac and libopenjpeg (all in universe)

ffmpeg (4:0.6~svn20100505-1) experimental; urgency=low

  * update to new upstream. Closes: #569727
    - fixes various segfaults and other minor feature improvements
      Closes: #374931, #522449, #501891, #559712, #420231, #369127, #538082,
              #298095, #294422, #561553, #525385, #495274, #420230
      LP: #305286, #457106, #529200, #301723, #305315, #336479, #420230,
          #412063, #428912, #432181, #440591, #453732, #453732, #453732,
      #514259, #515243, #521472, #530186, #530186, #197842, #483317,
     #483317, #539407, #280098, #331255, #566107, #569823, #570305,
     #573190
  * Fixup lintian overrides for new upstream snapshot
  * Bump Standards-Version to 3.8.4
  * Many upstream changes, see upstream Changelog for details
 -- Reinhard Tartler <email address hidden> Wed, 26 May 2010 00:01:17 +0200

Changed in ffmpeg (Ubuntu):
status: Confirmed → Fix Released

Is there any chance to get an update/bugfix for lucid?

My issue with ffmpeg: https://bugs.launchpad.net/ubuntu/+source/ffmpeg/+bug/589385
My Problem with this issue: https://bugs.launchpad.net/ubuntu/+source/ffmpeg/+bug/589385/comments/5

Because Lucid is an LTS-Version, IMHO there should be a Bugfix for the Version 0.5.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.