ffplay shows video-color-mismatch

Bug #589385 reported by kaputtnik on 2010-06-03
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ffmpeg

Hello,

i've made some sample files with recordmydesktop. ffplay shows only color-mismatch, while dragon-player and vlc-mediaplayer shows correct videos.

Using: Kubuntu 10.04, kde 4.4.2,

Output from ffplay:
ffplay out-2.ogv
FFplay version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2003-2009 Fabrice Bellard, et al.
  configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
  libavutil 49.15. 0 / 49.15. 0
  libavcodec 52.20. 1 / 52.20. 1
  libavformat 52.31. 0 / 52.31. 0
  libavdevice 52. 1. 0 / 52. 1. 0
  libavfilter 0. 4. 0 / 0. 4. 0
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0
  built on Mar 4 2010 12:35:30, gcc: 4.4.3

Screenshot: Left window=Dragon-player, right window=ffplay

llogan (loul) on 2010-06-03
Changed in ffmpeg (Ubuntu):
status: New → Confirmed
llogan (loul) wrote :

I can confirm this on Lucid. Plays fine using SVN r23325. This is probably a duplicate of bug #305286 which has a fix released.

Reinhard Tartler (siretart) wrote :

Yes, it is.

This means, i have to compile ffmpeg on my own to use it with lucid?

The main Problem is: I'am using kdenlive for Videoediting and this Program seems to use ffplay to show the video (the videos in kdenlive are even colormismatched).

On Do, Jun 03, 2010 at 23:51:37 (CEST), kaputtnik wrote:

> This means, i have to compile ffmpeg on my own to use it with lucid?

either that, or work with upstream to provide an acceptable backport for
ffmpeg 0.5

> The main Problem is: I'am using kdenlive for Videoediting and this
> Program seems to use ffplay to show the video (the videos in kdenlive
> are even colormismatched).

oh, interesting

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Sorry, this Idea was wrong... kdenlive uses melt to show the Video, not ffplay.

Now i have compiled ffmpeg version 0.6, ffplay shows videos korrect, but kdenlive shows allways the wrong colors :-( I have to look at melt for a bugfix...

Forgotten: Thanks for your fix answers!

Reinhard Tartler (siretart) wrote :

I intend to provide ffmpeg 0.6 package in the motumedia ppa for lucid as
soon as it is officially released. stay tuned.

thanks :-)

Dan Dennedy (dan-dennedy) wrote :

If the fix is in the libs (i.e. libavformat, libavcodec), then mlt (melt) and thereby kdenlive will get it as well.
kaputtnik, you probably did not rebuilt mlt against your new ffmpeg version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers