FTBFS against libav9

Bug #1253071 reported by Dimitri John Ledkov
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ffmpeg-php (Ubuntu)
Undecided
Unassigned
gstreamer0.10-ffmpeg (Ubuntu)
Undecided
Unassigned
guymager (Ubuntu)
Undecided
Unassigned
libavg (Ubuntu)
Undecided
Unassigned
libnfo (Ubuntu)
Undecided
Unassigned
libvalhalla (Ubuntu)
Undecided
Unassigned
minidlna (Ubuntu)
Undecided
Unassigned
motion (Ubuntu)
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned
openwalnut (Ubuntu)
Undecided
Unassigned

Bug Description

Please remove:
* motion
* minidlna

FTBFS, not ported to libav9, removed from testing.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

These packages need to be temporarily demoted to -proposed until they are fixed to work with new libav. This is to follow debian removals from testing. Please contact me, if you need to remove block-proposed tag from any of these packages.

tags: added: block-proposed
summary: - demote to proposed for libav transition (removed from testing in Debian)
+ block migration & demote to proposed for libav transition (removed from
+ testing in Debian)
Changed in ffmpeg-php (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in gstreamer0.10-ffmpeg (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in libavg (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in libvalhalla (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in zoneminder (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in minidlna (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in motion (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in guymager (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Invalid
Adam Conrad (adconrad)
Changed in guymager (Ubuntu):
status: New → In Progress
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: Invalid → New
Revision history for this message
Logan Rosen (logan) wrote : Re: block migration & demote to proposed for libav transition (removed from testing in Debian)

zoneminder builds fine for me locally with Libav 9:
http://paste.ubuntu.com/6461797/

Changed in zoneminder (Ubuntu):
status: New → In Progress
no longer affects: zoneminder (Ubuntu)
Adam Conrad (adconrad)
Changed in openwalnut (Ubuntu):
status: New → In Progress
tags: removed: block-proposed
Changed in ffmpeg-php (Ubuntu):
status: New → Fix Released
Changed in guymager (Ubuntu):
status: In Progress → Fix Released
Changed in libavg (Ubuntu):
status: New → Fix Released
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Fix Released
Changed in libvalhalla (Ubuntu):
status: New → Fix Released
Changed in minidlna (Ubuntu):
status: New → Fix Released
Changed in motion (Ubuntu):
status: New → Fix Released
Changed in mplayer (Ubuntu):
status: New → Fix Released
Changed in openwalnut (Ubuntu):
status: In Progress → Fix Released
Changed in ffmpeg-php (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in gstreamer0.10-ffmpeg (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in guymager (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in libavg (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in libvalhalla (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in minidlna (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in motion (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in ffmpeg-php (Ubuntu):
status: Fix Released → Triaged
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: Fix Released → Triaged
Changed in libavg (Ubuntu):
status: Fix Released → Triaged
Changed in libnfo (Ubuntu):
status: New → Triaged
Changed in minidlna (Ubuntu):
status: Fix Released → Triaged
summary: - block migration & demote to proposed for libav transition (removed from
- testing in Debian)
+ block migration & demote to proposed & decruft NBS libav/ffmpeg (removed
+ from testing in Debian)
Changed in motion (Ubuntu):
status: Fix Released → Triaged
Changed in mplayer (Ubuntu):
status: Fix Released → Triaged
Changed in libvalhalla (Ubuntu):
status: Fix Released → Triaged
description: updated
Revision history for this message
Matthias Klose (doko) wrote : Re: block migration & demote to proposed & decruft NBS libav/ffmpeg (removed from testing in Debian)

Removing packages from trusty:
 libav-extra 6:0.8.7ubuntu1 in trusty
  libavcodec-extra-53 6:0.8.7ubuntu1 in trusty amd64
  libavcodec-extra-53 6:0.8.7ubuntu1 in trusty arm64
  libavcodec-extra-53 6:0.8.7ubuntu1 in trusty armhf
  libavcodec-extra-53 6:0.8.7ubuntu1 in trusty i386
  libavcodec-extra-53 6:0.8.7ubuntu1 in trusty powerpc
  libavfilter-extra-2 6:0.8.7ubuntu1 in trusty amd64
  libavfilter-extra-2 6:0.8.7ubuntu1 in trusty arm64
  libavfilter-extra-2 6:0.8.7ubuntu1 in trusty armhf
  libavfilter-extra-2 6:0.8.7ubuntu1 in trusty i386
  libavfilter-extra-2 6:0.8.7ubuntu1 in trusty powerpc
  libavformat-extra-53 6:0.8.7ubuntu1 in trusty amd64
  libavformat-extra-53 6:0.8.7ubuntu1 in trusty arm64
  libavformat-extra-53 6:0.8.7ubuntu1 in trusty armhf
  libavformat-extra-53 6:0.8.7ubuntu1 in trusty i386
  libavformat-extra-53 6:0.8.7ubuntu1 in trusty powerpc
  libavutil-extra-51 6:0.8.7ubuntu1 in trusty amd64
  libavutil-extra-51 6:0.8.7ubuntu1 in trusty arm64
  libavutil-extra-51 6:0.8.7ubuntu1 in trusty armhf
  libavutil-extra-51 6:0.8.7ubuntu1 in trusty i386
  libavutil-extra-51 6:0.8.7ubuntu1 in trusty powerpc
  libpostproc-extra-52 6:0.8.7ubuntu1 in trusty amd64
  libpostproc-extra-52 6:0.8.7ubuntu1 in trusty arm64
  libpostproc-extra-52 6:0.8.7ubuntu1 in trusty armhf
  libpostproc-extra-52 6:0.8.7ubuntu1 in trusty i386
  libpostproc-extra-52 6:0.8.7ubuntu1 in trusty powerpc
Comment: lp #1253071, completely remove libav-extra src+binaries (bin:libav-extra), superseded by libav 9, which is now in universe
1 package successfully removed.

Matthias Klose (doko)
tags: added: block-proposed
Revision history for this message
Ulrich von Zadow (uzadow) wrote :

Note that there's a new libavg version available upstream (1.8.0) that is compatible with current libav.

Matthias Klose (doko)
tags: removed: block-proposed
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Thanks, new libavg packaged into debian and synced into ubuntu.

Changed in libavg (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Updated description.

Changed in ffmpeg-php (Ubuntu):
status: Triaged → Fix Released
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: Triaged → Fix Released
Changed in libnfo (Ubuntu):
status: Triaged → Fix Released
Changed in libvalhalla (Ubuntu):
status: Triaged → Fix Released
Changed in mplayer (Ubuntu):
status: Triaged → Fix Released
summary: - block migration & demote to proposed & decruft NBS libav/ffmpeg (removed
- from testing in Debian)
+ Removed from testing, RC-buggy, FTBFS against libav9
description: updated
Revision history for this message
Marcos Magalhães (marcos-daekdroom) wrote :

gstreamer0.10-ffmpeg is needed to fix https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1051559 in Trusty

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1253071] Re: Removed from testing, RC-buggy, FTBFS against libav9

On 3 March 2014 00:24, Marcos Vinícius <email address hidden> wrote:
> gstreamer0.10-ffmpeg is needed to fix
> https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1051559 in Trusty

Please use gstreamer1.0-libav which is the replacement for gstreamer0.10-ffmpeg.

--
Regards,

Dimitri.

Revision history for this message
Marcos Magalhães (marcos-daekdroom) wrote : Re: Removed from testing, RC-buggy, FTBFS against libav9

Firefox still hasn't made the transition to gstreamer1.0 and is compiled against 0.10 in Ubuntu 14.04. Gstreamer1.0 is targeted for Firefox 30 (https://bugzilla.mozilla.org/show_bug.cgi?id=806917). I guess I'll wait.

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1253071] Re: Removed from testing, RC-buggy, FTBFS against libav9

On 3 March 2014 18:01, Marcos Vinícius <email address hidden> wrote:
> Firefox still hasn't made the transition to gstreamer1.0 and is compiled
> against 0.10 in Ubuntu 14.04. Gstreamer1.0 is targeted for Firefox 30
> (https://bugzilla.mozilla.org/show_bug.cgi?id=806917). I guess I'll
> wait.
>

Actually, I don't think it will work either way, since ffmpeg/libav
are demoted to universe from main in 14.04, and there currently aren't
resources needed to support ffmpeg/libav security-wise if used widely
by default. The supported scope of ffmpeg/libav in currently stable
releases is quite limited. Due to special updates procedures for
firefox however, it may be possible to use embedded copy which would
be holistically pushed via updates to all supported releases, but that
should go through security review to make sure attack vectors are
limited and ffmpeg/libav is properly contained/sandboxed.

--
Regards,

Dimitri.

Matthias Klose (doko)
tags: added: block-proposed
tags: added: ftbfs
Matthias Klose (doko)
tags: removed: block-proposed
Revision history for this message
Eugene San (eugenesan) wrote : Re: Removed from testing, RC-buggy, FTBFS against libav9

Fix was released in Debian's motion (3.2.12-4).
(use-new-api.patch, copy-old-api.patch)

tags: added: patch-accepted-debian
summary: - Removed from testing, RC-buggy, FTBFS against libav9
+ FTBFS against libav9, fixed in Unstable
Eugene San (eugenesan)
Changed in motion (Ubuntu):
status: Triaged → Fix Committed
summary: - FTBFS against libav9, fixed in Unstable
+ FTBFS against libav9
Changed in motion (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

minidlna was apparently removed a little while back:

  https://launchpad.net/ubuntu/+source/minidlna/+publishinghistory

Changed in minidlna (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Thanos Kyritsis (djart) wrote :

Can you please bring back (or schedule bringing back) minidlna ? It found its way back into Debian Sid (unstable). See also https://bugs.launchpad.net/ubuntu/+source/minidlna/+bug/1309651 and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717131

Revision history for this message
Scott Kitterman (kitterman) wrote :

Synced minidlna from sid.

Revision history for this message
Andoni Morales (ylatuya) wrote :

Unfortunately removing gstreamer0.10-ffmpeg in Trusty results in an unusable GStreamer 0.10 distribution, because any application that still uses GStreamer 0.10 will lack decoding support for many of the codecs included in this package (eg: H264), which is big regression. Either you remove GStreamer 0.10 completly in Trusty or you provide a complete distribution with ffmpeg support, but having a mix is completely useless.

As an example, Firefox (which still uses GStreamer 0.10 in version 29) will no longuer support h264 using GStreamer in Trusty.

Revision history for this message
Sebastian Dröge (slomo) wrote :

Note that Firefox can work with GStreamer 0.10 and 1.0 since version 30, and that there are also relatively simple patches for 29 to support 1.0.

Overall the GStreamer 0.10 packages should disappear completely as soon as possible, not just gstreamer0.10-ffmpeg.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers