Comment 7 for bug 488428

elsaturnino (elsaturnino-gmail) wrote :

I ran into the same problem but when I followed zvpunry's suggested fix, I didn't get an error when restoring. Instead, after I tried to open f-spot I received the following error:

Unhandled Exception: Mono.Data.SqliteClient.SqliteExecutionException: SQL logic error or missing database
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteStatement (IntPtr pStmt, System.Int32& cols, System.IntPtr& pazValue, System.IntPtr& pazColName) [0x00000] in <filename unknown>:0
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteStatement (IntPtr pStmt) [0x00000] in <filename unknown>:0
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior behavior, Boolean want_results, System.Int32& rows_affected) [0x00000] in <filename unknown>:0
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteNonQuery () [0x00000] in <filename unknown>:0
  at Banshee.Database.QueuedSqliteCommand.Execute () [0x00000] in <filename unknown>:0

There is a file called photos.db so it's not a missing file problem. I did notice that the original photos.db file was set to executable but the new version wasn't. I chmod +x'd it but still get the same error :(