karmic: f-spot doesn't start, crashes with SqliteSyntaxException

Bug #474644 reported by Florian Parnigoni
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Won't Fix
f-spot (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

I did a fresh ubuntu install last week, but I was unable to start f-spot from the beginning.

Today I removed and reinstalled f-spot, but it still won't start.

When run from the terminal, it looks like this:

flo@florian:~$ f-spot
[Info 20:51:04.023] Initializing DBus
[Info 20:51:04.179] Initializing Mono.Addins
[Info 20:51:04.460] Starting new FSpot server (f-spot
[Info 20:51:04.778] Updating F-Spot Database

Unhandled Exception: Mono.Data.SqliteClient.SqliteSyntaxException: no such table: tags
  at Mono.Data.SqliteClient.SqliteCommand.GetNextStatement (IntPtr pzStart, System.IntPtr& pzTail, System.IntPtr& pStmt) [0x00000]
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior behavior, Boolean want_results, System.Int32& rows_affected) [0x00000]
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteNonQuery () [0x00000]
  at Banshee.Database.QueuedSqliteCommand.Execute () [0x00000]

ProblemType: Bug
Architecture: i386
Date: Wed Nov 4 20:46:04 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: f-spot
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
SourcePackage: f-spot
Uname: Linux 2.6.31-14-generic-pae i686

Revision history for this message
Florian Parnigoni (florian-parnigoni) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

looks like an upstream bug, could you try removing the photos.db file and see if the application works fine after doing that? Thanks.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Andrew Keyes (akeyes) wrote :

Where is the photos.db file?

Revision history for this message
Florian Parnigoni (florian-parnigoni) wrote :


I purged f-spot once more and deleted the ~/.config/f-spot directory.

Reinstalled it again, and now f-spot is starting.

For me this issue is resolved, but I should mention again that this bug hit me after a clean installation on a new disk.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

ok just wanted to be sure, there's an upstream bug about those conflicts on the db, will link it here, thank for testing Florian.

Changed in f-spot (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
JOjo! (jojo-eljojo) wrote :

Hi, i removed ~/.config/f-spot and worked ok :D

Revision history for this message
Pedro Villavicencio (pedro) wrote :

cool, is the same bug then, thanks for reproducing.

Revision history for this message
Simon741 (simon-okko) wrote :

That didn't help for me. However, F-Spot worked fine with another appearance than New Wave, as described here:

Changed in f-spot:
importance: Unknown → Medium
status: Unknown → New
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.