f-spot crash, Exception in Gtk# callback delegate

Bug #293437 reported by Rob Frohne on 2008-11-04
36
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
High
Chris Coulson
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: f-spot

After updating to the latest f-spot (I am using intrepid proposed pre-release updates), I found that crashed on my first laptop to upgrade. I checked and f-spot worked fine on the other one. I then updated it, and it now crashes too with the following message:

frohro@frohro-d600:~/Desktop/mono-1.9.1$ f-spot
[Info 19:48:32.598] Initializing DBus
[Info 19:48:32.760] Initializing Mono.Addins
[Info 19:48:33.011] Starting new FSpot server
[Info 19:48:34.608] Starting BeagleService
[Info 19:48:34.608] Hack for gnome-settings-daemon engaged
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at FSpot.Tag.get_SizedIcon () [0x00000]
  at TagSelectionWidget.IconDataFunc (Gtk.TreeViewColumn column, Gtk.CellRenderer renderer, TreeModel model, TreeIter iter) [0x00000]
  at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GtkSharp.TreeCellDataFuncWrapper.NativeCallback(IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data)
   at GtkSharp.TreeCellDataFuncWrapper.NativeCallback(IntPtr , IntPtr , IntPtr , IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

I had previously compiled f-spot from source, and to make sure it wasn't a problem with having a locally compiled version of mono, I uninstalled mono and it makes no difference.

Hope this is of use.

Rob

Related branches

Glenn (glenn-strong-cs) wrote :

Yep, same traceback for me using 0.5.0.3-0ubuntu3 (from intrepid-proposed). A forced downgrade to 0.5.0.3-0ubuntu2 and everything works again.

Chris Coulson (chrisccoulson) wrote :

Thanks. I can't reproduce this at the moment. Could you please do the following, and attach the resulting file to this bug report:

"gconftool-2 -R /apps/f-spot > f-spot-gconf"

This will enable me to try it with your profile.

Changed in f-spot:
importance: Undecided → High
status: New → Incomplete
Rob Frohne (frohro) wrote :

Hi Chris,

Here you go....

Kytrix (kytrix) wrote :

Hi,

I get the same problem on 2 pc after an upgrade Hardy to Intrepid

here is my profile too.

Aurelien.

Changed in f-spot:
status: Incomplete → Triaged
Changed in f-spot:
assignee: nobody → chrisccoulson
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

Fantastic. I can reproduce it now by unhiding the tag icons and then displaying the tags in the left-hand pane.

Changed in f-spot:
status: In Progress → Triaged
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in f-spot:
status: New → Fix Committed
Chris Coulson (chrisccoulson) wrote :

For those testing the update, there is a test case in bug 291189 which you can use.

Kytrix (kytrix) wrote :

I enabled intrepid-proposed but synaptics does'nt propose me the update, so i flag as re-install,
synaptics say it use the proposed version and he install it.

here is my f-spot output:
$ f-spot
[Info 22:02:38.770] Initializing DBus
[Info 22:02:38.889] Initializing Mono.Addins
[Info 22:02:39.081] Starting new FSpot server

(f-spot:25238): Gtk-WARNING **: Theme directory 128x128 of theme StudioNewbuntu has no size field

[Info 22:02:40.523] Starting BeagleService
[Info 22:02:40.523] Hack for gnome-settings-daemon engaged
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at FSpot.Tag.get_SizedIcon () [0x00000]
  at TagSelectionWidget.IconDataFunc (Gtk.TreeViewColumn column, Gtk.CellRenderer renderer, TreeModel model, TreeIter iter) [0x00000]
  at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GtkSharp.TreeCellDataFuncWrapper.NativeCallback(IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data)
   at GtkSharp.TreeCellDataFuncWrapper.NativeCallback(IntPtr , IntPtr , IntPtr , IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

it seems to be no changes :/

Chris Coulson (chrisccoulson) wrote :

The latest version probably hasn't got to your mirror yet. What is the output of:

apt-cache policy f-spot

Klaus Doblmann (moviemaniac) wrote :

Confirming the new version to work, as already stated in bug 291189. Thanks!

Rob Frohne (frohro) wrote :

Thanks Chris and Martin!

Less than 24 hours after I reported this bug, you had it fixed! It took a while to get to my mirror, but I discovered that I could tell my machine to download from the main server. Once I did that, it worked.

Good job!

Rob

mkis62 (mihaikx62) wrote :

Hi,
Still crashing here. it's a silent one - clicking on 'preferences' from 'Edit'. No warning, no crash report. I'm using xubuntu intrepid, updated

mihai@miki:~$ f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
[Info 17:08:44.810] Initializing DBus
[Debug 17:08:45.131] DBusInitialization took 0.286513s
[Info 17:08:45.131] Initializing Mono.Addins
[Debug 17:08:45.911] Mono.Addins Initialization took 0.779211s
[Info 17:08:45.929] Starting new FSpot server
[Debug 17:08:46.574] Db Initialization took 0.359257s
[Debug 17:08:47.837] QueryToTemp took 0.001359s : SELECT id, time, uri, description, roll_id, default_version_id, rating, md5_sum FROM photos WHERE id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC
[Debug 17:08:48.119] PhotosPerMonth took 0.011283s
[Debug 17:08:48.126] TimeAdaptor REAL Reload took 0.222642s
[Info 17:08:48.802] Starting DBusService
[Debug 17:08:48.821] DBusService startup took 0.018069s
[Info 17:08:48.823] Starting BeagleService
[Debug 17:08:48.825] BeagleService startup took 2.3E-05s
[Info 17:08:48.825] Hack for gnome-settings-daemon engaged
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at FSpot.UI.Dialog.PreferenceDialog.LoadPreference (System.String key) [0x00000]
  at FSpot.UI.Dialog.PreferenceDialog..ctor () [0x00000]
  at FSpot.UI.Dialog.PreferenceDialog.Show () [0x00000]
  at MainWindow.HandlePreferences (System.Object sender, System.EventArgs args) [0x00000]
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.Signal.voidObjectCallback(IntPtr handle, IntPtr data)
   at GLib.Signal.voidObjectCallback(IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

f-spot is the last available version:
mihai@miki:~$ apt-cache policy f-spot
f-spot:
  Installed: 0.5.0.3-0ubuntu4
  Candidate: 0.5.0.3-0ubuntu4

Chris Coulson (chrisccoulson) wrote :

mkis62 - that is an unrelated problem. Please open a new bug report for that one

Martin Pitt (pitti) wrote :

intrepid-proposed package copied to jaunty.

Changed in f-spot:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Copied to intrepid-updates.

Changed in f-spot:
status: Fix Committed → Fix Released
Marcin Palacz (palacz) wrote :

Hi,

I still get the same (a very similar) crash, after trying
Edit->Preferences

I believe I have an up to date version of f-spot.

apt-cache policy f-spot
f-spot:
  Installed: 0.5.0.3-0ubuntu4
  Candidate: 0.5.0.3-0ubuntu4

I include below the error messages.

Marcin

palacz@maldonada:~$ f-spot
[Info 00:03:11.080] Initializing DBus
[Info 00:03:11.222] Initializing Mono.Addins
[Info 00:03:11.362] Starting new FSpot server
Count = 31
[Info 00:03:13.252] Starting BeagleService
[Info 00:03:13.252] Hack for gnome-settings-daemon engaged

(f-spot:6942): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at FSpot.UI.Dialog.PreferenceDialog.LoadPreference (System.String key) [0x00000]
  at FSpot.UI.Dialog.PreferenceDialog..ctor () [0x00000]
  at FSpot.UI.Dialog.PreferenceDialog.Show () [0x00000]
  at MainWindow.HandlePreferences (System.Object sender, System.EventArgs args) [0x00000]
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.Signal.voidObjectCallback(IntPtr handle, IntPtr data)
   at GLib.Signal.voidObjectCallback(IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

Chris Coulson (chrisccoulson) wrote :

Marcin - Your trace looks similar to that already posted in this bug report by mkis62, which is an unrelated problem. Please open a new bug report for your problem if one doesn't already exist

Taner Senyurt (turshu) wrote :

f-spot
[Info 11:44:48.883] Initializing DBus
[Info 11:44:49.025] Initializing Mono.Addins
[Info 11:44:49.280] Starting new FSpot server
get fences failed: -1
param: 6, val: 0
[Info 11:44:51.186] Starting BeagleService
[Info 11:44:51.186] Hack for gnome-settings-daemon engaged
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.ArgumentNullException: Argument cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[System.Object,System.Object].set_Item (System.Object key, System.Object value) [0x00000]
  at FSpot.Utils.DisposableCache`2[System.String,Gdk.Pixbuf].Add (System.String key, Gdk.Pixbuf value) [0x00000]
  at FSpot.Widgets.Filmstrip.GetPixbuf (Int32 i, Boolean highlighted) [0x00000]
  at FSpot.Widgets.Filmstrip.GetPixbuf (Int32 i) [0x00000]
  at FSpot.Widgets.Filmstrip.OnExposeEvent (Gdk.EventExpose evnt) [0x00000]
  at Gtk.Widget.exposeevent_cb (IntPtr widget, IntPtr evnt) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.exposeevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

Pedro Villavicencio (pedro) wrote :

Taner please open a new bug about that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers