exo-compose-mail-1 includes 64-bit installation prefix on 32-bit

Bug #1808694 reported by Sean Davis on 2018-12-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Exo
Fix Released
Medium
exo (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

Upstream bug: https://bugzilla.xfce.org/show_bug.cgi?id=14895

exo package versions before 0.12.2-2 link to a non-existent 64-bit binary on 32-bit systems.

The default E-Mail program could not be started. Child process "/usr/lib/x86_64-linux-gnu/xfce4/exo-compose-mail-1" can not be executed (file or directory not found)

Affected Xubuntu versions include 18.04 and 18.10.

lsb_release -rc
Release: 18.04
Codename: bionic

When Itry in thunar or Libre Office send a fil over Kontext menu send to E-mail I recieve following error. forgivea maybe bad translation.

The default E-Mailprogram could not be startet. childprozes "/usr/lib/x86_64-linux-gnu/xfce4/exo-compose-mail-1" can not be execute (file or directory not found)

exo-open --launch MailReader works as expctected and starts thunderbird with some theme parsing errors.

dpkg --print-architecture
i386

No ppa includet in my Installation. apt-cache policy xfce4-session exo-utils
xfce4-session:
  Installiert: 4.12.1-3ubuntu3
  Installationskandidat: 4.12.1-3ubuntu3
  Versionstabelle:
 *** 4.12.1-3ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status
exo-utils:
  Installiert: 0.12.2-0ubuntu0.18.04.1
  Installationskandidat: 0.12.2-0ubuntu0.18.04.1
  Versionstabelle:
 *** 0.12.2-0ubuntu0.18.04.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     0.12.0-1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages

To reproduce

Start thunar select a file and ty to send to E-Mail in kontextmenu

With regards

All thunar sendto-mail plugin does it to call exo_execute_preferred_application, passing "MailReader" as category.
That helper script on my system is located at /usr/lib/xfce4/exo-1/exo-compose-mail-1, looking at bionic-updates packages[1] contents, I can't find that file. Maybe a packaging issue.

1 - https://packages.ubuntu.com/search?keywords=exo&searchon=names&suite=bionic-updates&section=all

It's included in the libexo-1-0 package. In Debian and Ubuntu, the file is installed in an arch-specific location to allow 32-bit and 64-bit applications to coincide as needed.

/usr/lib/x86_64-linux-gnu/xfce4/exo-1/exo-compose-mail-1

dpkg -S exo-compose-mail-1
libexo-1-0:i386: /usr/lib/i386-linux-gnu/xfce4/exo-1/exo-compose-mail-1

file /usr/lib/i386-linux-gnu/xfce4/exo-1/exo-compose-mail-1
/usr/lib/i386-linux-gnu/xfce4/exo-1/exo-compose-mail-1: Perl script text executable

I have no Multiarch. Pure 32-bit.

Someone found a workaround

sudo mkdir -p /usr/lib/x86_64-linux-gnu/xfce4/exo-1/

and sudo ln -s /usr/lib/i386-linux-gnu/xfce4/exo-1/exo-compose-mail-1 /usr/lib/x86_64-linux-gnu/xfce4/exo-1/

I think I found out the problem, libexo-helpers package is arch independent but all .desktop files it contains use the x86-64 prefix.

Sean Davis (bluesabre) wrote :

This is resolved in Debian package version 0.12.2-2, currently available in Debian Testing/Unstable and Ubuntu 19.04.

xubuntu@xubuntu-VirtualBox:~$ dpkg -S exo-compose-mail-1
libexo-helpers: /usr/share/xfce4/exo-1/exo-compose-mail-1

Changed in exo (Ubuntu Disco):
status: New → Fix Released

This is resolved in Debian package version 0.12.2-2, currently available in Debian Testing/Unstable and Ubuntu 19.04.

xubuntu@xubuntu-VirtualBox:~$ dpkg -S exo-compose-mail-1
libexo-helpers: /usr/share/xfce4/exo-1/exo-compose-mail-1

I've created a downstream bug report to track this issue and prepare it for SRU.
https://bugs.launchpad.net/ubuntu/+source/exo/+bug/1808694

Marking this bug report resolved, please subscribe to the LP bug report above for further updates.

Changed in exo:
importance: Unknown → Medium
status: Unknown → Fix Released

This workaround solved it for me, my result from $ apt-cache policy xfce4-session exo-utils:

xfce4-session:
  Installed: 4.12.1-3ubuntu3
  Candidate: 4.12.1-3ubuntu3
  Version table:
 *** 4.12.1-3ubuntu3 500
        500 http://no.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status
exo-utils:
  Installed: 0.12.2-0ubuntu0.18.04.1
  Candidate: 0.12.2-0ubuntu0.18.04.1
  Version table:
 *** 0.12.2-0ubuntu0.18.04.1 500
        500 http://no.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     0.12.0-1 500
        500 http://no.archive.ubuntu.com/ubuntu bionic/universe i386 Packages

pauljohn32 (pauljohn32) wrote :

On Ubuntu 19.04, I still see this problem.

exo-utils 0.12.4-1

It is surprising because this was fine when still using Ubuntu 18.10.

Fix was:

    cd /usr/lib/x86_64-linux-gnu/xfce4/exo-1/
    sudo ln -sf /usr/share/xfce4/exo-1/exo-compose-mail-1 .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in exo (Ubuntu Bionic):
status: New → Confirmed
Changed in exo (Ubuntu Cosmic):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.