[SRU] Giant icons in Preferred Applications with some icon sets

Bug #1767326 reported by Alistair Buxton on 2018-04-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exo
Fix Released
Medium
exo (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]
* Icons inside the Preferred Applications folder are not correctly scaled with some icon themes.

[Test Case]
1. Open Appearance settings and set icon theme to ubuntu-mono-light, or Adwaita, or GNOME.

2. Open Preferred Application settings.

3. Firefox icon is huge.

[Additional Updates for exo 0.12.2]

Bug Fixes:
- UI: Use "user-bookmarks" instead of "bookmark-new" (Xfce #14243)
- UI: Properly scale application icons in Preferred Apps dialog (Xfce #14362, LP: #1767326)

Desktop Integration:
- Add PCManFM-Qt (from LXQt) to supported file managers (Xfce #14333)

Icon Chooser Improvements (Xfce):
- Drop deprecated International icon context, add Stock icon context
- Increase icon chooser context title length to support long translations
- Skip symbolic icons to boost performance

Translation Updates:
Albanian, Amharic, Belarusian, Bulgarian, Catalan, Chinese (China), Chinese (Taiwan), Czech, Danish, Dutch, English (Australia), Finnish, French, Galician, Greek, Hebrew, Hungarian, Italian, Polish, Portuguese, Russian, Slovak, Swedish, Turkish

[Regression Potential]

Regression potential is minimal. The vast majority of the changes in exo 0.12.1 and 0.12.2 are adding support for GCC7 and GCC8, all of which are also backwards-compatible to GCC6.

The changes to the symbolic logic in the icon chooser should lead to a
performance boost by dropping the duplicate -symbolic icons from contexts
where they would not be used (within Xfce).

[Original Report]

To reproduce:

1. Fresh install Xubuntu 18.04
2. Open Appearance settings and set icon theme to ubuntu-mono-light, or Adwaita, or GNOME.
3. Open Preferred Application settings.

Result: Firefox icon is huge.

Screenshot attached.

Note: This is a regression. It does not happen in 16.04 with any icon set.

It reminds me of a similar problem that happened when gnome-panel was first ported to gtk3: https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/1010326

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libexo-1-0 0.12.0-1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 27 11:20:37 2018
InstallationDate: Installed on 2018-04-04 (23 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180403.1)
SourcePackage: exo
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :
description: updated

Preferred Applications settings dialog is not scaling cons if they are the wrong size. This leads to it sometimes showing huge icons depending on the icon set in use.

Screenshot from Xubuntu 18.04, using the ubuntu-mono-light icon set (Adwaita and GNOME themes also reproduce) : https://launchpadlibrarian.net/367592323/exo.png

This seems to be a regression in the gtk3 port. A similar thing happened when gnome-panel was ported to gtk3: https://launchpadlibrarian.net/107130168/Screenshot%20from%202012-06-08%2006%3A44%3A22.png

Downstream bug: https://bugs.launchpad.net/ubuntu/+source/exo/+bug/1767326

Changed in exo:
importance: Unknown → Medium
status: Unknown → Confirmed

Created attachment 7685
Patch that scales the icons as expected

I added a patch that fixes the problem. If we want to change the icon size to something bigger, that's now easily possible too without breaking the scaling.

In , Gitbot (gitbot) wrote :

Simon Steinbeiss referenced this bugreport in commit ac0e2fbe71a069d072e30180654dc5585d78d2bb

Properly scale application icons in Preferred Apps dialog (Bug #14362)

https://git.xfce.org/xfce/exo/commit?id=ac0e2fbe71a069d072e30180654dc5585d78d2bb

Changed in exo:
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2018-07-10
summary: - Giant icons in Preferred Applications with some icon sets
+ [SRU] Giant icons in Preferred Applications with some icon sets
description: updated
Sean Davis (bluesabre) wrote :

Attaching debdiff for new release.

Changed in exo (Ubuntu Cosmic):
status: New → Fix Released
Changed in exo (Ubuntu Bionic):
status: New → In Progress

Hello Alistair, or anyone else affected,

Accepted exo into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/exo/0.12.2-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in exo (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sean Davis (bluesabre) wrote :

Installed Bionic on a VM, fully updated, enabled proposed, and installed exo. After switching to Adwaita, the giant icon bug is not present and other functionality works as well. Verification done.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package exo - 0.12.2-0ubuntu0.18.04.1

---------------
exo (0.12.2-0ubuntu0.18.04.1) bionic-proposed; urgency=medium

  * New upstream microrelease.
    - Fixes giant icons in preferred applications (LP: #1767326)

 -- Sean Davis <email address hidden> Tue, 10 Jul 2018 05:55:27 -0400

Changed in exo (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for exo has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.