Ubuntu

"Examples" folder link on users' home folders (and Live CD desktop) cannot be translated

Reported by Krzysztof Lichota on 2006-05-18
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
casper (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
example-content (Ubuntu)
Wishlist
Unassigned
Jaunty
Wishlist
Unassigned

Bug Description

Original report:

Kubuntu live CD version 20060518.

There is a folder link on desktop called Examples.
As this is regular symlink, it cannot be translated.

It should be changed into ".desktop"-style link and translation of this desktop file should be put in Rosetta to allow full translation of desktop for other locale than English.

Addition:

example-content binary package just installs /etc/skel/ file, which gets installed on users's home folders. The link on the Live CD is created by casper, which does mv /root/home/$USERNAME/Examples /root/home/$USERNAME/Desktop/. Casper would also thus need updating if this change is done.

Timo Jyrinki (timo-jyrinki) wrote :

Still a problem in Ubuntu 7.04, current daily builds.

Timo Jyrinki (timo-jyrinki) wrote :

And gutsy too. This bug covers also the same link put into each user's home folder by default. The xdg-user-dirs should take care of the other folders in Home, but not this.

Timo Jyrinki (timo-jyrinki) wrote :

Still a problem in hardy heron.

A. Walton (awalton) wrote :

Just curious, why is this so hard that it hasn't been done for ages? This might be "cheating", but it most certainly works (and don't laugh at the translations, they're babelfished for demonstration purposes):

in ~/Examples.desktop (or something):
[Desktop Entry]
Version=1.0
Type=Application
Name[en]=Examples
Name[fr]=Exemples
Name[es]=Ejemplos
Icon=folder
Comment[en]=Example content for Ubuntu
Comment[fr]=Contenu d'exemple pour Ubuntu
Comment[es]=Contenido del ejemplo para Ubuntu
Exec=xdg-open file:///usr/share/example-content/

The "cheating" part being that we're claiming it to be an application, though it's actually just a link to a folder that opens with whatever the desktop's default file browser is (of course, assuming it follows both the Desktop Entry specification and the File URI specification, which I believe to be rather universal today [please correct me if I'm wrong]). For CLI users this may look a tad bit odd ("huh, that thing's a .desktop file?"), but when they open it up in their editor they'll instantly realize what's going on.

Am I missing something here?

Daniel T Chen (crimsun) on 2008-09-13
Changed in example-content:
importance: Medium → Wishlist

2008/9/13 Daniel T Chen <email address hidden>:
> ** Changed in: example-content (Ubuntu)
> Importance: Medium => Wishlist

It is not a wishlist - untranslated item on the desktop is unreadable
for people who do not know English. It is a bug.

And I am really surprised it is really that hard to fix - it is enough
to replace symlink in /etc/skel with desktop file. Someone had already
posted the contents of desktop file...

--

 Krzysztof Lichota

The reason for not fixing it is probably that no-one really actively maintains the package from what I've followed. Ie. it's no-one's clear responsibility. It would help if someone would create a bazaar branch completely done, ready for merging... something that would fix both the live-CD icon, shown on the desktop, and the after-installation link from Home folder.

https://code.launchpad.net/example-content

This is indeed a bit nasty/ugly i18n problem, since it's relatively visible (even if ignoring the installation phase, it's placed on the Home folder of each user on every install).

Timo Jyrinki (timo-jyrinki) wrote :

I started something yesterday evening. If I have some free time today after work I will try to finish it, since theoretically it seemed to work but needs some more stuff to be corrected. Actually example-content package is only responsible for the home folder link after installation, I guess the link on the live-CD comes from somewhere else. But the home folder link is the most important.

Changed in example-content:
assignee: nobody → timo-jyrinki
status: Confirmed → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

The ~timo-jyrinki/example-content/folder_i18n branch changes the Examples link into an examples.desktop file, which is of type Link and points to the folder. It uses gettext to get translations on-the-fly from langpacks, therefore fixing the bug #45489 for the case of after-installation for every Ubuntu user's home folder. The link on the Live-CD desktop probably comes from elsewhere.

At the same time, some of the content was moved around. The python usage here is a bit of an overkill, but it was the way I (thought I) knew how to make this work. The only hack needed was for installing the .desktop file under /etc while still using cdbs defaults otherwise.

It's lintian clean and tested with pbuilder, and seems to work fine. I'm attaching a screenshot to the bug report of a situation where the examples.desktop is installed in /etc/skel (without translations), .mo files are in locale directories, a new user has been created and it has been logged in for the first time.

I didn't use Icon=Folder, since it's actually after the ordinary folders and the icon in my opinion confused the user. So it's just the default link icon, which I'd prefer over also a folder icon with a link arrow on it since it looks wrong in the alphabetical order if it looks like a folder but is after other folders in the list.

Timo Jyrinki (timo-jyrinki) wrote :

I forgot to mention that naturally Python is only used during building, there are no dependencies of any kind in the binary package.

Endolith (endolith) wrote :

But isn't all the content in the folder in English anyway?

Timo Jyrinki (timo-jyrinki) wrote :

People can understand images, sound, video similar to what's on the web, independent if they are fluent in the language of the material. But having an item in one's home folder in a foreign language, in the middle of all the familiar names in a localized user interface stands out as being unprofessional.

It's similar to any piece of highly visible non-translated string in Ubuntu - since Ubuntu is so well I18N:d otherwise, a single very visible item stands out as ugly or unprofessional. And I have probably heard about every I18N problem I have pursued from users multiple times, live or on the web, like "Ubuntu is quite nice and very usable in Finnish... but there is this English menu entry which my dad was confused about" etc.

Timo Jyrinki (timo-jyrinki) wrote :

Removed my assignment from the task and the "In Progress" status, since I can't anyway do any uploads so they probably shouldn't be used.

Changed in example-content:
assignee: timo-jyrinki → nobody
status: In Progress → Confirmed
description: updated
description: updated
description: updated
description: updated
Daniel Nylander (yeager) wrote :

For what it's worth..

Name[sv]=Exempel
Comment[sv]=Exempelinnehåll för Ubuntu

Colin Watson (cjwatson) on 2009-03-24
Changed in casper (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Fix Committed
Daniel Holbach (dholbach) wrote :

Thanks a lot.

Uploaded and sitting in the archive admin queue.

Changed in example-content (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package example-content - 36

---------------
example-content (36) jaunty; urgency=low

  [ Timo Jyrinki ]
  * Change symlink into a .desktop file
  * Add I18N infrastructure for the .desktop file using Python (LP: #45489)
  * Move content from root to main and source directories
  * Update Standards-Version (no changes)
  * Update copyright file

  [ Keith Worrell ]
  * oo-derivatives.doc: Added Xubuntu and Edubuntu banners from respective
    web sites to represent distributions in the same manner as Kubuntu within
    the document preserving single page layout.
  * Added banners used in oo-derivatives.doc to ./logos
  * oo-about-these-files: Updated "current" version of OpenOffice
  * oo-presenting-ubuntu.odp: updated slide 3 screenshot to reflect
    a more modern clean ubuntu install
  * Corrected format of case_Wellcome.pdf,
    case_Howard_county_Library.pdf, case_OaklandUniversity.pdf,
    case_oxford_archaeology.pdf
  * Fixed typos (LP: #342362, #209776, #223382)
  * Changed footer logo in certain case files to be more consistant
    where appropriate.

  [ Endolith ]
  * renamed all files to have more recognisable names. (LP: #43558)

  [ Jorge O. Castro ]
  * main/About_These_Files.odt: Update with the new content.
  * Ubuntu_adoption_case_studies/Oakland_University.pdf: Rename pdf from
    "University of Oakland" to the correct "Oakland University".
  * Add winners from the Free Culture Showcase Competition:
    - Invocation.ogg by MoShang,
    - SpiritOfUbuntu.ogv by Robbie Ferguson,
    - CanadianClouds.jpg by m0deth.

  [ Daniel Holbach ]
  * debian/control:
    - drop po-debconf Build-Depends.
    - changed xs-vcs-bzr to vcs-bzr.
    - move python-distutils-extra to Build-Depends-Indep.
  * debian/copyright: updated.
  * main/About_These_Files.odt: more updating.
  * Changed spaces to underscores in Endolith's changes. Moved case studies
    in separate directory.
  * Ubuntu_Free_Culture_Showcase/CanadianClouds.jpg,
    Ubuntu_Free_Culture_Showcase/Invocation.ogg,
    Ubuntu_Free_Culture_Showcase/SpiritOfUbuntu.ogv: embed artist and license
    information.

 -- Daniel Holbach <email address hidden> Tue, 24 Mar 2009 17:20:15 +0100

Changed in example-content:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.166

---------------
casper (1.166) jaunty; urgency=low

  [ Emmet Hikory ]
  * Show the ubiquity icon in kourou (LP: #338730)

  [ Timo Jyrinki ]
  * Move examples.desktop to Desktop/ if it exists, as an alternative to
    Examples (LP: #45489).

  [ Luke Yelavich ]
  * scripts/casper-bottom/30accessibility && ubiquity-hooks/30accessibility:
    - Make the special case disabling of pulseaudio per user, and not system
      wide.
    - Also disable PulseAudio for the Braille profile.
    - Fix incorrect paths when chowning files.
    - Don't use /root for the ubiquity hook accessibility script, /target is
      where the installed system is located.
    - Remove laptop detect code. Its not currently working, and getting it to
      work requires invasive changes.
    - Only set pulseaudio settings and create the .orca directory if sed
      packages are installed on the live filesystem and installed system.
  * ubiquity-hooks/30accessibility: Copy orca settings to the installed system.

 -- Luke Yelavich <email address hidden> Fri, 27 Mar 2009 14:38:20 +1100

Changed in casper:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers