Ubuntu

Upgrade from lucid trigger an unreadable error dialog (font issue?)

Reported by Nicolas Delvaux on 2012-03-26
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre

Bug Description

"update-manager -d" on an up-to-date (and almost vanilla) Lucid VM.

After a while (while installing the upgrades), an error message appears whose text is unreadable (each char is a square).
Same thing in the network manager applet.
Please see the attached screenshot.

nb: apport did not want to report this bug during the upgrade process... Ask me if you need any log.

Nicolas Delvaux (malizor) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) on 2012-03-29
tags: added: rls-mgr-p-tracking
Jean-Baptiste Lallement (jibel) wrote :

I reproduced it on bare hardware. The error message itself is an error from evolution-alarm-notify. In the case I reproduced the icon at the left of the message is also broken.

Changed in update-manager (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → ubuntu-12.04
Jean-Baptiste Lallement (jibel) wrote :

I copied the squares from the broken dialog to gedit, the content of the dialog (in french sorry)
"""
Une erreur est survenue lors du chargement ou de l'enregistrement des informations de configuration de evolution-alarm-notify. Certains de vos paramètres de configuration ne fonctionneront peut-être pas correctement.
"""

dist-upgrade logs attached.

Steve Langasek (vorlon) wrote :

Given that this error message comes from evolution, I'm not sure there's much that can be done from update-manager to address it; I think the package itself would need to take care to notice that it's in an inconsistent state somehow and avoid such broken pop-ups.

affects: update-manager (Ubuntu Precise) → evolution (Ubuntu Precise)
Changed in evolution (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Mathieu, we could run the counterpart of "evolution --force-shutdown" in the preinst if the upgrade detects that we are upgrading from an old version? I. e. kill all running e-a-n instances? There might be a more elegant solution to detect that situation at runtime, but I don't think we should waste too much time on this. After the upgrade you'll need to reboot anyway.

Changed in evolution (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Mathieu Trudel-Lapierre (mathieu-tl)

Yeah, sounds like a reasonable way to fix this kind of issue; I'll check if there is a way to stop just the alarm-notify binary and possibly the calendar and addressbook factories.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/965686

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 3.2.3-0ubuntu6

---------------
evolution (3.2.3-0ubuntu6) precise; urgency=low

  * debian/libevolution.preinst: if upgrading from versions prior to 3.2.0;
    kill all instances of evolution-alarm-notify to avoid an unreadable error
    message about state inconsistencies. (LP: #965686)
  * debian/patches/git_crash_in_mail_sidebar_936a488.patch: avoid crashing in
    the sidebar code when handling multiple windows. (LP: #650677)
  * debian/patches/alarm-notify-nodisplay.patch: don't show the alarm notifier
    in gnome-session-properties (add NoDisplay=true to the .desktop file).
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 05 Apr 2012 16:19:28 -0400

Changed in evolution (Ubuntu Precise):
status: Confirmed → Fix Released
Nicolas Delvaux (malizor) wrote :

Well, as shown in the screenshot in my first comment, the "boxes chars" not only appear in this error message, but also in the network-manager applet (and probably elsewhere). Should I report a new bug for this issue?

It's going to be very hard to fix this in nm-applet; the issue really comes from the fact that fontconfig or gtk or some other low-level part is getting broken by the upgrade. We do expect people to reboot after running the dist-upgrade though.

Nicolas, since it's obviously wrong, please file a separate bug, I'll look to see if this can be tracked down to a particular change.

Nicolas Delvaux (malizor) wrote :

Ok. Against which package should I report it?

I also experienced this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers