Ubuntu

evolution crashed with signal 5 in e_load_ui_builder_definition()

Reported by Juraj on 2011-08-23
166
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Ubuntu)
Medium
Unassigned

Bug Description

DId the same as here Bug #831308 ,but this time system generated automatic report

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: evolution 3.1.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
CrashCounter: 1
Date: Tue Aug 23 10:53:45 2011
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110814)
ProcCmdline: evolution
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
Signal: 5
SourcePackage: evolution
StacktraceTop:
 e_load_ui_builder_definition () from /usr/lib/evolution/3.2/libeutil.so.0
 ?? () from /usr/lib/evolution/3.2/modules/libevolution-module-addressbook.so
 ?? () from /usr/lib/evolution/3.2/modules/libevolution-module-addressbook.so
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/libedataserver-1.2.so.15
Title: evolution crashed with signal 5 in e_load_ui_builder_definition()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Juraj (juraj-hrcka) wrote :
Juraj (juraj-hrcka) on 2011-08-24
visibility: private → public

StacktraceTop:
 e_load_ui_builder_definition (builder=0x223c4400, basename=0x22a17ec "eab-contact-duplicate-detected.ui") at e-util.c:320
 match_query_callback (contact=0x220f1680, match=0x2228a190, type=EAB_CONTACT_MATCH_EXACT, closure=0x222a00f8) at eab-contact-merging.c:586
 query_cb (source_object=0x21fc9698, result=0x222edc08, user_data=0x22329e78) at eab-contact-compare.c:653
 g_simple_async_result_complete (simple=0x222edc08) at /build/buildd/glib2.0-2.29.16/./gio/gsimpleasyncresult.c:749
 finish_async_op (async_data=<optimized out>, error=0x0, in_idle=0) at e-client.c:2158

Changed in evolution (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in evolution (Ubuntu):
status: New → Confirmed
Changed in evolution:
importance: Unknown → Critical
status: Unknown → New
Changed in evolution:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

thanks for the report, can you reproduce it with 3.2 ? Thanks.

Changed in evolution (Ubuntu):
status: Confirmed → Incomplete
iMac (imac-netstatz) wrote :

My apport trace with 3.2.0-0ubuntu2 just ran on this same issue.

@ Pedro What does it do with that new trace data when I say "Yes, it is the same bug" .. is it lost?

Sometimes I note that my bug is the same, but the original reporter doesn't have the complete set of symbols installed..I am wondering in these cases if it is better to create a new bug, and mark it as a dupe noting the additional info.

Pedro Villavicencio (pedro) wrote :

could you please submit that report? there's no duplicates with 3.2 . Thanks.

iMac (imac-netstatz) wrote :

Evolution is still crashing, but apport doesn't seem to want to catch it unless the factory process dies, which it is not doing. Anyhow I attached a gdb backtrace.

iMac (imac-netstatz) wrote :

Actually, I just had an old apport evolution crash in /var/crash.. Re-run with current 3.2.0-0ubuntu2, attached to bug https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/862924

Changed in evolution:
status: Incomplete → New
Juraj (juraj-hrcka) wrote :

Again crashed with coredump.

Pedro Villavicencio (pedro) wrote :

Thanks for the response, will comment upstream.

Changed in evolution (Ubuntu):
status: Incomplete → Triaged
Juraj (juraj-hrcka) wrote :

Just zsync-ed oneiric alternate daily build. Did fresh install -> update -> upgrade -> install evolution.
Now I'm getting duplicate warning.

iMac (imac-netstatz) wrote :

After messing around with the Makefiles this problem can be resolved to the point where upstream believe it looks like the Ubuntu build process introduces an issue, or rouses this issue. Maybe someone familiar with the unique packaging and dpkg-buildpackage process can peek upstream and isolate the issue further.

old_toby (simon-hornweb) wrote :

my evolution crashes everytime I enter a new email-address in the addressbook.

Lisa Simpson (lisa-p) wrote :

Ok I'm adding my crash report to this. Hopefully, this will help you guys fix it.

This really is a crash that shouldn't happen: it's normally caused by missing UI definitions or something wrong with the definitions (unless using unofficial packages). If you're running into this issue, what would help a lot would be to add the output of starting evolution from the command-line.

Thanks in advance!

Changed in evolution (Ubuntu):
status: Triaged → Incomplete
old_toby (simon-hornweb) wrote :

This is all I get:

(evolution:10718): Tracker-DEBUG: Tracker Evolution plugin enabled
(evolution:10718): Tracker-DEBUG: Tracker plugin creating new object...
Trace/Breakpoint ausgelöst (Speicherabzug geschrieben)

What shall I do to get more info?

iMac (imac-netstatz) wrote :

@Mathieu - The command line output is show in this Sept. comment in the upstream bug. https://bugzilla.gnome.org/show_bug.cgi?id=659890#c4

Hoping somebody like yourself that knows the build / linking system in more detail can figure this out based on the upstream information.

Sten (q-sten) wrote :

Evolution always crashes when moving from one address to another address book from an address book. (If the email address is already present in the second address.)

Evolution 3.2.3, Ubuntu 12.04

tags: added: precise
tags: added: quantal
Changed in evolution:
status: New → Fix Released
Jörg Frings-Fürst (jff-de) wrote :

change status to Fix Relased (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.