Ubuntu

Evolution does not show persistent alarms in Unity

Reported by geoffrey on 2011-04-30
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

In 10.10 and before, Evolution alarms would appear in the system tray. With Unity, there is no persistent trace of alarms associated with calendar events after the notification bubble has disappeared.
I think this is a regression: I trusted this function to remind me of important appointments, but unless I am in front of my screen at the appropriate moment (when the notification bubble appears) I am not made aware of these appointments.

The workaround is to whitelist evolution-alarm-notify. But presumably there needs to be a solution that integrates better with Unity, perhaps a message in the message indicator and the icon turning blue, or the date-time glowing blue and appointment flashing under the date-time menu?

(This bug may be hidden by bug 1233176, where the notifications do not appear at all.)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, evolution should open a dialog for meeting reminders, not only a notification, that was enabled by default on natty see https://launchpad.net/ubuntu/+source/evolution/2.32.1-0ubuntu3

" * debian/evolution.gconf-defaults: Disable systray for alarms, as Unity
    doesn't have a systray. Use popup windows instead."

Changed in evolution (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Subscribing mpt since he's working on the design for systray replacements in Ubuntu, Matthew do you have any suggestion there?

leoperbo (leoperbo) wrote :

For some people, like me, the dialog that is opened by Evolution on every alarm is annoying, so, we use the "show alarms only in tray" option.

I agree with geoffrey about the need of a better integration of this option in Unity.

Thank you!

wimpunk (wimpunk) wrote :

Is there any evolution on this issue? Is there any systray replacement which could be tested?

wimpunk (wimpunk) wrote :

It looks like the icon is still there when using unity-2d. At least, it works on my computer.

Changed in evolution (Ubuntu):
status: New → Confirmed
Rockwalrus (rockwalrus) wrote :

As this makes evolution alarms almost useless, and caused me to miss an appointment which cost me money, "low" seems like the wrong priority.

This appears to be as being fixed in Oneiric (Ubuntu 11.10).

Although I agree we could do more (indicator ?), I'm not sure what else needs to be done. I've just been able to confirm in precise (though the packages in Oneiric as extremely similar, unlikely that there is any difference impacting alarms) that alarms cause both the alarm dialog to pop up in front of all windows, despite evolution to be closed (but e-calendar-factory needs to be running, but that's "obvious"), and it also causes a notification bubble to show up. The persistent trace would be the evolution alarm dialog that pops up. Any reason that this is not sufficient, besides the fact that a window popping up might be annoying for some?

tellapu (tellapu) wrote :

I am also with Ubuntu 11.10, but there is no pop-up window.
It would be good to have a pop-up window (and a possibility to stop it in the preferences for the people that do not like it.)
An indicator with a drop-down list of all active notification would be great as well. It would be handy if the notification(s) would be listed there (not disappear) until some action has been done (e.g. deactivate them by clicking on the entry).
Indicator-icon should change when there is a notification or should disappear when there is none.
And surely the importance of this issue/bug should be "high".

tellapu (tellapu) wrote :

Please assign somebody to this bug and change the importance to "high". It is still a problem, also on Ubuntu 12.04.

tellapu (tellapu) wrote :

Sayang, still low importance and no activity!

Changed in evolution (Ubuntu):
assignee: nobody → tellapu (tellapu)
tellapu (tellapu) wrote :

Dear Matthew Paul Thomas!
Thanks for the attention to the bug and assigning somebody to it, but I guess you you mis-clicked as you chose me. I would love to help with this bug, but unfortunately I lack the knowledge and skills for this. I am more than happy to help with testing and further feedback, but more would be out of my sphere. So please assign somebody that is capable to help with this bug and change the importance to "high".
Cheers, tellapu

Matthew Paul Thomas (mpt) wrote :

tellapu, you are welcome to find someone who can fix this bug. But if you can't, then don't be surprised that nobody else has either. A bug comment is rarely a good place to appeal for the bug to be fixed, because the only people who will see your comment are people who have already considered whether they can fix it.

Changed in evolution (Ubuntu):
assignee: tellapu (tellapu) → nobody
tellapu (tellapu) wrote :

Hi Matthew! Thanks a lot for the post and explanation. Hmm, where do we find people that could fix this? Or where should I appeal for the bug to be fixed? I thought developers of Ubuntu and evolution would be informed by and/or would check the bug reports ...

greenmoss (ktyubuntu) wrote :

No progress for almost two years? Ubuntu should be better than this.

What can we do to help debug this, and test solutions? Without persistence, alarms are completely useless.

Jörg Frings-Fürst (jff-de) wrote :

Bug from 2011. Version not longer supportet.
Change status to Invalid

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
renormalist (ss5) wrote :

*Of course* this version is no longer supported. But what about the actual (mis-)feature?
Is it actually *fixed* in a newer version?

Letting this *essential feature of ANY electronic calendar* hanging for years and then closing
as "Invalid" without any further information feels a bit... whatever.

Matthew Paul Thomas (mpt) wrote :

(Jörg Frings-Fürst, please don't close a bug as "no longer supportet" if it is reported as occurring in 12.04. Thanks.)

Changed in evolution (Ubuntu):
status: Invalid → Confirmed
Patrick Hetu (patrick-hetu) wrote :

An idea for this would be to modify evolution-indicator to make it add a nodification
for alarms and not just emails. I'll try to findout if the alarms are accessible in evolution API's or what
would be the way to "clear" the notifications in the indicator.

Patrick Hetu (patrick-hetu) wrote :

After checking deeper into it, it's more complex than I tought. There is no "alarm notification" either
from dbus or the evolution api. So the only possible thing that could be done without re-inventing
everything is to patch the evolution-alarm-notify daemon to make it add an item to the indicator.

Matthew Paul Thomas (mpt) wrote :

Patrick, the problem in this bug report is not that Evolution isn't using notifications. The problem is that it is using notifications when it shouldn't, because they are not persistent.

description: updated
Patrick Hetu (patrick-hetu) wrote :

I think indicator-messages devs are already working on that bug: https://bugs.launchpad.net/ubuntu-clock-app/+bug/1233176

Patrick Hetu (patrick-hetu) wrote :

err indicator-datetime

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers