Alarm notifications do not appear when an alarm is triggered

Bug #1233176 reported by Nekhelesh Ramananthan on 2013-09-30
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Charles Kerr
URL Dispatcher
Fix Released
High
Ted Gould
Ubuntu Clock App
Critical
Unassigned
indicator-datetime (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
url-dispatcher (Ubuntu)
Undecided
Unassigned

Bug Description

There is no indication when an alarm goes off. This should be done by the platform which opens the clock app when an alarm is triggered.

Related branches

Ted Gould (ted) on 2013-10-01
Changed in url-dispatcher:
assignee: nobody → Ted Gould (ted)
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
Changed in url-dispatcher:
status: New → Confirmed
importance: Undecided → High
Changed in indicator-datetime:
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-clock-app:
assignee: nobody → Nekhelesh Ramananthan (nik90)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:url-dispatcher at revision None, scheduled for release in url-dispatcher, milestone Unknown

Changed in url-dispatcher:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package url-dispatcher - 0.1+13.10.20131003-0ubuntu1

---------------
url-dispatcher (0.1+13.10.20131003-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Enfoce the ///. (LP: #1231444)
  * Make dispatcher more testable and add some application:/// tests.
  * Adding a calendar URL. (LP: #1231136)
  * Adding the alarm URL pattern. (LP: #1233176)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 32
 -- Ubuntu daily release <email address hidden> Thu, 03 Oct 2013 02:08:19 +0000

Changed in url-dispatcher (Ubuntu):
status: New → Fix Released
Ted Gould (ted) on 2013-10-07
Changed in url-dispatcher:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2013-10-08
Changed in indicator-datetime:
status: Confirmed → In Progress
Changed in ubuntu-clock-app:
assignee: Nekhelesh Ramananthan (nik90) → Riccardo Padovani (rpadovani)
status: Triaged → In Progress

Fix committed into lp:ubuntu-clock-app at revision 229, scheduled for release in ubuntu-clock-app, milestone final-1.0

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Nekhelesh Ramananthan (nik90) wrote :

Riccardo's patch has been reverted in the clock app due to failing autopilot tests, black screen on start up and other issues. This will be postponed to the next development cycle. other parts required to show notifications will still be landing.

Changed in ubuntu-clock-app:
status: Fix Committed → Triaged
Nekhelesh Ramananthan (nik90) wrote :

Despite Riccardo's patch been reverted, having indicator-datetime and urldispatcher alone would be enough for this cycle. The indicator-datetime should be able to trigger a notification when an alarm goes off.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-datetime at revision 277, scheduled for release in indicator-datetime, milestone Unknown

Changed in indicator-datetime:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Changed in ubuntu-clock-app:
milestone: final-1.0 → backlog
Changed in ubuntu-clock-app:
milestone: backlog → 14.04-month-1
martin (martinfasani) wrote :

Is there any way to make an alarm work at the current time ?
I tried all possible ways and still cannot make it sound. (on r5 raring)

Nekhelesh Ramananthan (nik90) wrote :

The Alarm works in the backend. The only thing missing here is the notification (sound and visual). That's something I am trying to coordinate with upstream devs responsible for this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu Saucy):
status: New → Confirmed
Ursula Junque (ursinha) on 2013-11-27
tags: added: avengers
Changed in ubuntu-clock-app (Ubuntu):
importance: Undecided → Critical
importance: Critical → Undecided
Ursula Junque (ursinha) on 2013-11-28
no longer affects: ubuntu-clock-app (Ubuntu)
Nicholas Skaggs (nskaggs) wrote :

Do we have an update on this? What is missing from being able to get an alarm to ring from clock?

Nicholas Skaggs (nskaggs) wrote :

Per Charles, a plain C Alarms API that's currently in draft form is completed. Plans implement this this right after Christmas break and then make indicator-datetime dogfood this API to connect to the EDS backend.

Once that is complete, clock should be able to make the API call via qml corect?

Changed in ubuntu-clock-app:
milestone: 1.2 → 1.6
Charles Kerr (charlesk) wrote :

Reopening for indicator-datetime. Looks like there's a bug in i-datetime's code that sees appointments/alarms in EDS on startup but isn't processing new ones when they're added. I'm looking into this now.

Changed in indicator-datetime:
status: Fix Committed → In Progress
Péter Trombitás (trombipeti) wrote :

what is going on with this? As I understand this bug actually means that the user cannot set a very primitive alarm clock to wake them up in the morning. I think this is almost as important as being able to receive calls. When can we expect it to work?

Changed in ubuntu-clock-app:
milestone: 1.6 → 1.8
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.04.20140219.1-0ubuntu1

---------------
indicator-datetime (13.10.0+14.04.20140219.1-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * support for ubuntu-clock-app's alarms (LP: #1233176)

  [ Ted Gould ]
  * Adding acceptance tests and merge review policies
 -- Ubuntu daily release <email address hidden> Wed, 19 Feb 2014 18:02:43 +0000

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Péter Trombitás (trombipeti) wrote :

It still doesnt work here. I set the alarm, but nothing happens when it should fire. I use r194 image on mako.

Nekhelesh Ramananthan (nik90) wrote :

Peter, I can confirm it still doesn't work as of image #194 on Mako. We are currently investigating the issue.

Nekhelesh Ramananthan (nik90) wrote :

Image #200 has been confirmed to have a working alarm notification support :)

Changed in ubuntu-clock-app:
milestone: 1.8 → 1.6
Changed in indicator-datetime:
status: In Progress → Fix Released
Changed in ubuntu-clock-app:
status: Triaged → Fix Committed
assignee: Riccardo Padovani (rpadovani) → nobody
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in indicator-datetime (Ubuntu Saucy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers