Ubuntu

Evolution Setup Assistant dialog too large for netbook screens

Reported by Hew McLachlan on 2010-06-03
182
This bug affects 35 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

Case ID: nrf-002
ISO: UNE Maverick Alpha 1
Computer: ASUS Eee 1005HA

Running from a live session, the Evolution Setup Assistant dialog was too tall for the 1024x600 netbook screen, and I was unable to see the forward button to progress.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.1.2-3ubuntu1
ProcVersionSignature: Ubuntu 2.6.34-5.13-generic 2.6.34
Uname: Linux 2.6.34-5-generic i686
Architecture: i386
Date: Thu Jun 3 14:31:28 2010
LiveMediaBuild: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Alpha i386 (20100602.3)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution

Hew McLachlan (hew) wrote :
Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Ritz (jonas-ritz) wrote :

I can confirm this. It is not possible to press "forward" on the first welcome window.
I am running 10.10 Alpha2 on a eee1000H

Sergio Zanchetta (primes2h) wrote :

Confirmed in Maverick Alpha 3

Changed in evolution (Ubuntu):
importance: Medium → High
Omer Akram (om26er) wrote :

express mode is for netbooks and apparently Evolution Setup Assistant dialog is simplified in express mode. so it fits nicely.

Changed in evolution (Ubuntu):
importance: High → Medium
Tiago Silva (tiagosilva) wrote :

I experienced the same problem when installing Ubuntu in a friend's decent computer with an old 800x600 monitor.
Why do they still impose static window sizes?

Dennis Baudys (thecondordb) wrote :

I would like to add, that I've just noticed, running current Ubuntu Maverick Beta with 1024x768 resolution in my virtual machine, the Evolution Setup window is too large too. Maybe it's not the same as the Evolution Setup Assistent window, but still too large to reach the »Help« button on the bottom. Please see the attached screenshot to get an imagination.

Ubuntu 10.10 beta, 2.6.35-20-generic
Evolution Version: 2.30.3-1ubuntu1

Thanks.

gil (jonny-g1917) wrote :

eeepc 901 too - slowing me down a lot

Alan Bell (alanbell) wrote :

This affects the Evolution preferences window as well as the setup routine.

Sergio Zanchetta (primes2h) wrote :

Confirmed in Maverick Final.

Didier Roche (didrocks) wrote :

If you install Ubuntu Netbook Edition and choose evolution in the launcher, the setup dialog is more suited on small screen size as targeted for netbooks.

Acker (ackerstaff) wrote :

I have the Problem: Samsung NC10. Is it possible to run the netbook optimised version of evolution on a standard ubuntu gnome installation?

Acker (ackerstaff) wrote :

Anything new on this?

Matthew Sweney (sweney) wrote :

I have the same problem with my Lenovo s10e - and not only can I not resize the window, I cannot find a workaround to even change the monitor resolution so that I can press "next" and setup Evolution. This is a dumb error, there's hardly any text at all in that Evolution Assistant window.

rad_sci_guy (radsciguy) wrote :

I'm having this issue on my asus eeepc 1005ha netbook as well. I did a clean install of ubuntu 10.10. I can't make changes to the preferences window without guessing at the location of the apply button.

The importance of this should be high not medium. it's preventing me from using evolution effectively

DavidW617 (davidw617) wrote :

This bug is extremely annoying to me. It should be an easy change as the panels already have scroll bars. The panels just need to have a much smaller minimal height.

A workaround for this bug is to ensure that the window is not maximized (Alt+F10) and then hold in Alt, click and drag the window up to see the content at the bottom.

The Calendar section of Evolution also explodes larger than my monitor. For those of you have not experienced this, I'm going to try to explain how annoying it is. My evolution window is sitting on Workspace 5 and it is maximized. If I happen to click on the Calendar, the window grows by about 80 pixels. Now if I happen to try and click on something the whole window jumps higher about 80 pixels making me miss what I tried to click on. I try to click again and the window will jump down the 80 pixels to where it started. It is impossible to even click on the Minimize, Restore and Maximize buttons. I have been in this scenario so often that I know to hit Alt+F10 and drag the window around before attempting to click on any items. When the window is not maximized, then this jumping around behaviour doesn't happen.

I would like to add that after click on the Calendar button, the entire program stays too large for my screen even after clicking back to Mail and the program needs to be shut down and restarted before it can be used properly.

Again, this should be an easy fix and Evolution should not ship with Ubuntu Netbook Remix if it does not fit on a netbook screen.

rad_sci_guy (radsciguy) wrote :

I just want to add that this problem is happening to me with the Desktop edition of ubunu 10.10. I haven 't installed the netbook edition so I believe this issue is with evolution itself not sizing the window correctly.

Chris Oliver (ardyceoliver) wrote :

works in ubuntu now

Christof Krüger (christofkr) wrote :

No, it does not work yet. I can't see the whole evolution preferences window on my laptop with 768px vertical resolution.

dummy9010 (aperto1973) wrote :

no matter what size the display is, the dialog should be resizable.

does not work here with a netbook.

You can use ALT and drag the dialog around to view the parts that aren't visible.

------Original Message------
From: dummy9010
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 589204
Subject: [Bug 589204] Re: Evolution Setup Assistant dialog too large fornetbook screens
Sent: 19 Jan 2011 11:43

no matter what size the display is, the dialog should be resizable.

does not work here with a netbook.

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (693709).
https://bugs.launchpad.net/bugs/589204

Title:
  Evolution Setup Assistant dialog too large for netbook screens

Joseph Bouchard via. BlackBerry

Gary M (garym) wrote :

Confirming the same problem is in the updated natty (11.04) alpha.

tags: added: natty
Gvozdik Artem (gvozdik) wrote :

Also on Natty Alpha 3. HP mini 2133. 1024x600.

I can confirm this bug on Natty Beta.

even adding the window to add the screenshot was too big for my netbook screen.

Avery (docaltmed) wrote :

Can get evolution assistant to work by making it fullscreen, but then clicking on the checkboxes causes random response by the window. By alternating between fullscreen and partial, I can eventually get the checkboxes to work.

All of that work is moot, however, because the calendar sizes larger than the screen size.

Seano (seanodea) wrote :

Rather than try to fix individual applications I've found the easiest way is to create a pan'able virtual desktop and bind the command to a couple of key combinations.

xrandr --output LVDS1 --panning 1024x786

xrandr --output LVDS1 --panning 1024x600

will flip in and out of a scrollable 'tall' desktop. I actually have them bound to Alt-T and Alt-S for tall and short as my memory sucks these days :)

Combine this with a utility to rotate the screen/trackpad for landscape/portrait use and a netbook becomes quite manageable.

--sean

no longer affects: evolution (Ubuntu Maverick)
Jeremy Bicha (jbicha) wrote :

I believe this is fixed at least for Evolution 3.8.4 on Ubuntu 13.10 Alpha. I set my screen resolution to 800x600, ran Evolution, clicked Edit>Preferences and took the attached screenshot.

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions